PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
PT Dead in Desert

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 07 Sep 2007, 09:44 pm
Fresh Cruiser
 
Join Date: Sep 2007
Posts: 1
Default PT Dead in Desert

2001 PT limited edition...On my way to work (62 miles) driving at 70mph with A/C on and listening to radio I was driving over a mountain pass of approx 10% grade when with out warning the engine shut down and would not start. There where no dash light indications, no abnormal sounds. I checked the MIL for error codes and it shows no error codes. Tried to start vehicle with both sets of keys and no luck, I even replaced the cam sensor. Presently when I stick the key in and turn it to start the car everything illuminates on the dash as it should however I get no clicking of relays or dimming of lights when I turn the ignition to run. This weekend I will start with a complete visual inspection however if anyone can assist me with idea's I would appreciate it

Last edited by millsm64; 07 Sep 2007 at 09:51 pm.
Reply With Quote
  #2 (permalink)  
Old 08 Sep 2007, 08:18 am
SRG SRG is offline
Cool Cruiser
 
Join Date: Aug 2002
Location: .
Posts: 320
Default Re: PT Dead in Desert

Not sure about your car, but maybe....

My wife's 03 Touring battery fried and dead-shorted last week Some of the same problems. It was 100 during the day, and we sat outside a Docs office for 25mins with the engine running and ac on. Went home no problem (25miles). 5 minutes after getting home, wife decided to go out to the store. Car was dead, no clicks, interior lights, nothing. It was the battery, it was a year old NAPA battery, no problems until then.

Hopes this helps....

srg
Reply With Quote
  #3 (permalink)  
Old 08 Sep 2007, 09:20 am
Obsessed Cruiser
 
Join Date: Dec 2002
Posts: 6,787
Default Re: PT Dead in Desert

so you have lights ?? can you beep the horn ?? sounds like you have power put the power isnt getting to start the car correct ??
Reply With Quote
  #4 (permalink)  
Old 14 Sep 2007, 07:16 am
Fresh Cruiser
 
Join Date: Aug 2007
Location: Dawesville. Western Australia
Posts: 20
Default Re: PT Dead in Desert

Main fuse blown......check all fuses first.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Horn going dead turbomangt General Turbo Discussions 5 20 Jun 2009 04:35 pm
Remove Dead BUGS ASAP!!!!! turbomangt The Detail Shop 8 07 Jun 2005 08:04 pm
Retro-fitting Dead Pedal for '03 GT? CarolinaBlue_GT Exterior & Interior Styling 16 01 Apr 2005 03:34 am
MOMO Pedal Set + Dead Pedal (Manual) **SOLD** Beacon Classifieds: For Sale/Trade 0 06 Jul 2004 07:28 pm


All times are GMT -5. The time now is 05:19 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors