PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Hard Misfire Under Load plugs changed

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 28 Dec 2007, 01:40 pm
Fresh Cruiser
 
Join Date: Dec 2007
Posts: 1
Default Hard Misfire Under Load plugs changed

This problem started at 37,000 +/- just out of the bumper to bumper warranty. 2005 GT PT manual 5 speed. When not warmed up runs smooth, good power will easily pull from 1500 rpm in any gear. When warmed to normal operating temp, will run good in 1st and 2nd start to misfire in 3rd, huge misfire in fourth or fifth, so severe engine feels like it shut off and rocks hard in its mounts. Put new plugs in at 37,000 noted inside of intake coated with oil (no oil use per dipstick between 3,000 mile changes) vehicle ran fine again for 2700 miles and started same pattern. Have noted a slight coolant use since last oil change, but not more than since new. Just returned from a 1000 mile trip and returned approximately 28.5 MPG. Changed plugs again, plugs looked good no sign of fouling. Immediately started the hard misfire once warmed up. Any ideas.
Reply With Quote
  #2 (permalink)  
Old 28 Dec 2007, 03:34 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Hard Misfire Under Load plugs changed

Sure. You never said anything about changing the wires and they are even more notorious for going bad and causing problems than the plugs. Anything is better than the stock wires so visit your nearest auto store and get some decent ones, or, for the best, go to www.RaceandStreet.com under "performance" and order the Crane wires.

If I'm right and you haven't changed the wires, your problems will be over as soon as you do.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 28 Dec 2007, 09:46 pm
Fanatic Cruiser
 
Join Date: Jul 2002
Location: Secane, PA, USA.
Posts: 530
Exclamation Re: Hard Misfire Under Load plugs changed

What Crewzin said...wires! The OEM wires are junk! ALSO, what did you gap the plugs at?The label under the hood may say 0.050" gap but there is a TSB out changing the gap to around 0.038-0.042".
__________________
John & Terry
"His" - 2002 Inferno Red Touring Edition
"Hers" - 2003 Electric Blue Limited Edition
Del Val PT Cruisers
Reply With Quote
  #4 (permalink)  
Old 31 Dec 2007, 11:08 am
Young Cruiser
 
Join Date: May 2003
Location: Pembroke, MA.
Posts: 90
Default Re: Hard Misfire Under Load plugs changed

My 03 PT Turbo had the misfire issue around 37K (just past the bumper to bumper anyway) at the time I replaced the wires with Bosch spiral cores and changed the plugs to Champion Platinum tip (no one in my area stocks anything for the Turbo PT's but platium or iridium tip plugs). That fixed the problem for about 10k miles. At that time I replaced the plugs again but this time I used Autolite Platinum (Very good luck with Autolite in my other vehicles). Again everything was good for about 10k miles and the misfire under load came back.

I didn't know about the TSB recommending the plug gap be reduced but I had figured I would try a smaller gap to see what it would do. Since all my other vehicles recommend about 0.035" I went with that gap. Again the misfire has been corrected.

My question is has anyone used the MSD Blaster coil and 8.5 MSD wires on there turbo motor? I have had good luck with MSD ignition parts on my Barracuda.

Also, what do folks recommend for plugs? I have had a turbo mopar continuously since I got my first Daytona Turbo in 85. The general consensus has always been that turbo motors are happier with plain copper core plugs and the fact that the PT came with copper cores would suggest that may be true since most other mopars now come with platinum tip plugs.
__________________
Dave Clement
\'03 GT, Electric Blue
Reply With Quote
  #5 (permalink)  
Old 31 Dec 2007, 11:28 am
Taggert_LOA's Avatar
Cool Cruiser
 
Join Date: Feb 2006
Location: Myrtle Beach SC
Posts: 422
Send a message via AIM to Taggert_LOA
Default Re: Hard Misfire Under Load plugs changed

the problem is the platinum plugs. they are a no no in turbo pt's the heat actually destroys the plugs, I tried the platinums in my gt and when my car misfired badly, i pulled the plugs and found out the hard way. the guy at napa thought i was full of shit till i showed him the plugs. went back to stock coppers, no problems since.
__________________
"Every civilization finds it necessary to negotiate comprimises with it's own Values"
Reply With Quote
  #6 (permalink)  
Old 31 Dec 2007, 11:54 am
Young Cruiser
 
Join Date: May 2003
Location: Pembroke, MA.
Posts: 90
Default Re: Hard Misfire Under Load plugs changed

That's what I have heard but no part stores stock anything but platinum or iridium plugs for the turbo PT. Copper core plugs have been a special order item.

FWIW, I have owned (4) turbo mopar cars starting with a Daytona in 85 with a total accumulated 575,000+ miles, including the 56,000 currently on the 03 PT. This is the first one I have had plug issues with, the others always had Autolite Platinum tip plugs that were changed out for good measure around 60,000 miles (always running good when changed). Even back in 85 I always heard the story that you can't run a platinum tip plug but I always have with very good success. The PT is the first that I have had ignition wire and plug issues with.

The platinum used in a plug is much much much more heat resistant than the standard materials, that is why they come in most new cars with a 100,000 mile change requirement. I always figured that the smaller electrode was more succeptable to fouling than the larger electrode of a coper core plug and that was the reason folks have had issues. I know back in the 70's when I raced moto-cross the Bosch platinum plugs in a 2-stroke motor fouled very easily.
__________________
Dave Clement
\'03 GT, Electric Blue
Reply With Quote
  #7 (permalink)  
Old 04 Jan 2008, 01:07 am
owls_rayne's Avatar
Fresh Cruiser
 
Join Date: Nov 2007
Location: Sedona, Az.
Posts: 10
Default Re: Hard Misfire Under Load plugs changed

I have a '04 PT Cruiser w/50k miles, what brand of spark plugs are recommended for replacement and also what Ing. Wires would be recommended. Also, how long do the coils last. I push the engine hard at times getting on the interstate here in Arizona, 6k rpm with automatic trans w/Weapons R intake plus turbo muffler.
Thanks.
Reply With Quote
  #8 (permalink)  
Old 04 Jan 2008, 01:22 am
Veteran Cruiser
 
Join Date: Mar 2003
Location: Oregon.
Posts: 3,521
Default Re: Hard Misfire Under Load plugs changed

Too many horror stories with turbo and platinum plugs (melting tips) with newer cars. When Mopar had a misprint for the stage 1 recommending platinum plugs they quickly recinded that. I use copper plugs in my modified '05 SRT-4. Car runs like a runaway locomotive on steroids.
__________________
\'05 Stone White SRT4

\'04 Graphite PT Automatic

Last edited by Mean Green; 04 Jan 2008 at 01:26 am.
Reply With Quote
  #9 (permalink)  
Old 09 Jan 2008, 01:40 pm
Senior Cruiser
 
Join Date: Jan 2003
Location: Huntington Beach, CA, USA.
Posts: 1,799
Default Re: Hard Misfire Under Load plugs changed

Quote:
Originally Posted by Mean Green View Post
Too many horror stories with turbo and platinum plugs (melting tips) with newer cars. When Mopar had a misprint for the stage 1 recommending platinum plugs they quickly recinded that. I use copper plugs in my modified '05 SRT-4. Car runs like a runaway locomotive on steroids.
Not sure where this myth about melting platinum tips got started but here is some info

Melting point of: copper - 1,984 F
platinum - 3,214 F
iridium - 4,471 F\

Search as I may over the years I have never found any difinitive data/studies indicating problems with platinum melting sooner than copper. All I have ever been able to come up with is the "my brother knows a guy who was once married to a girl whose brother's sister-in-law said her platinum plugs melted." I have come across some individual case studies that indicate smaller electrodes, (i.e. platinum and iridiam plugs) perform better. The smaller the electrode the better)Spark plug comparison - iridium vs platinum

The other side of this arguement would be on "high heat, high boost" racing engines (not really an issue with the PT GT). The platinum plug's tip, while smaller than copper, is somewhat larger than platinum which reduces it's ability to conduct heat away to prevent pre-ignition. Here is a discussion of this Spark Plugs - Turbo-Owners.com

General statements that "platinum plugs are bad for turbos" do not seem to be supported. The one issue that did arise years ago with iridiums that I read about was a problem early plugs had in manufacturing before they perfected a way to attach the iridium tips, and some came off. I have not read of this in many years though so I assume that issue was overcome.
__________________
'03 Inferno Red GT, 5 speed, STAGE 1, Mopar BOV, Plastic Intake, Modified Upper and Lower Airbox, Custom Airbox-to-turbo pipe, Borla dual exhaust, Maddog Short Shifter, Drilled/Slotter Rotors, Ceramic Pads, chrome wheels, chrome door spears, AMP chrome fuel door, PT Cruiser 3rd light diffuser, H&R Springs, Rear Sway Bar added, MGW chrome door lock pulls, Blane's hood struts, Custom license plate mount, some interior dress up stuff...more to come
Reply With Quote
  #10 (permalink)  
Old 09 Jan 2008, 03:49 pm
Dream4's Avatar
Regular Cruiser
 
Join Date: Mar 2006
Location: ANNAPOLIS, MD, USA.
Posts: 150
Default Re: Hard Misfire Under Load plugs changed

Quote:
Originally Posted by Cal Cruzer View Post
Not sure where this myth about melting platinum tips got started but here is some info

Melting point of: copper - 1,984 F
platinum - 3,214 F
iridium - 4,471 F\

Search as I may over the years I have never found any difinitive data/studies indicating problems with platinum melting sooner than copper. All I have ever been able to come up with is the "my brother knows a guy who was once married to a girl whose brother's sister-in-law said her platinum plugs melted." I have come across some individual case studies that indicate smaller electrodes, (i.e. platinum and iridiam plugs) perform better. The smaller the electrode the better)Spark plug comparison - iridium vs platinum

The other side of this arguement would be on "high heat, high boost" racing engines (not really an issue with the PT GT). The platinum plug's tip, while smaller than copper, is somewhat larger than platinum which reduces it's ability to conduct heat away to prevent pre-ignition. Here is a discussion of this Spark Plugs - Turbo-Owners.com

General statements that "platinum plugs are bad for turbos" do not seem to be supported. The one issue that did arise years ago with iridiums that I read about was a problem early plugs had in manufacturing before they perfected a way to attach the iridium tips, and some came off. I have not read of this in many years though so I assume that issue was overcome.
I have a posted this around here several times, but can't find it right now, but your old info is still correct for the PT Turbo. But here it goes again and my information was from the engineers at the Mopar Performance hot line that is listed on every Stage 1 install sheet 888-528-HEMI (528-4346), feel free to call them they are very nice and informiative,

It is not the Platinum that melts, it is the bonding metal that welds the Platinum tip to the center electrode (they only use a very small Platinum tip), and that the 2.4 Turbo PT & SRT4 have one of the highest combustion chamber temps of any production street car (approx 1700 to 1800 degrees F), the engine is designed & calibrated to run these temps both for performance and emissions, (Yes it is a issues as the PTGT is a very high heat engine), now you can run Platinum plugs on most other factory stock turbo cars, as they do not run this hot, stock you may get away with it, but with the higher boost & temps when modified with Stage 1 & above parts (ie larger turbo, stronger WGA, boost controllers etc) the Platinum plugs come apart and will embed the Platinum tip into the top of the piston or get stuck in a valve opening causing major damage.

They are also not recommended for NO2 or any Alcohol injection, and also any of the Meth/Water Injection systems, by Spark Plugs.com in their FAQ section. Sparkplugs.com - Spark Plug 411.

Again, if you want to use them that is up to you, But Mopar Performance highly recommends that you do not. As cheap as the recommended NGK copper 4306's are, I don't see why you would want to spend more anyway. (but that is me)
__________________
'05 GT Dream Cruiser Series 4. No.1109
http://www.alcamar.com/mods/
http://www.alcamar.com/dc4
http://www.alcamar.com/trailer/
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
spark plugs ote69 Turbo Performance 28 11 Jul 2010 09:59 am
Changed Plugs & Wires infernocruisr01 Tech & Performance Forum 4 30 May 2007 06:04 pm
Just changed plugs & wires gonzomania Tech & Performance Forum 2 04 Aug 2005 05:13 pm
Just changed plugs and wire...quick question... wyzard Tech & Performance Forum 5 10 May 2005 04:34 pm
Hard to find spark plugs...? Cal Cruzer General Turbo Discussions 2 15 Jan 2005 11:28 pm


All times are GMT -5. The time now is 04:38 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors