PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Engine Question!

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 28 Mar 2008, 12:28 pm
b0b88's Avatar
Fresh Cruiser
 
Join Date: Jan 2008
Posts: 43
Default Engine Question!

My pt cruiser doesnt seem to go over 4,000 rpm's at anytime anymore. not even in neutral. my main question is when the car is in neutral i can only rev to 4,000 rpm's before it kinda holds back and makes a weird noise?? and the car is quite sluggish lately like it doesnt have half the power as when i first got it?? does this seem familiar to anyone out there?? just throwing it out there hoping for some good info.
Reply With Quote
  #2 (permalink)  
Old 28 Mar 2008, 12:48 pm
ucantcme's Avatar
Senior Cruiser
 
Join Date: Aug 2007
Location: Wixom, Michigan
Posts: 1,486
Send a message via AIM to ucantcme Send a message via MSN to ucantcme Send a message via Skype™ to ucantcme
Default Re: Engine Question!

PT Cruiser 4 cylinder (non turbo) rev limit
__________________



My Baby:
01' Taupe Limited PT Cruiser w/ rear spoiler, Drop in K&N Air Filter, Limo tint all around, blue neon interior, blue LED windshield nozzles,
In-dash CD/DVD/Radio made by Jensen, Vent Visors, Chrome Antenna Bezel, Chrome Grille inserts, Dual Catback Exhaust, Scan Gauge II,
back-up camera, and a system containing 2 Lanzar 15" subwoofers and an MA Audio 1800watt amplifier.

Check me out on Car Domain!
Reply With Quote
  #3 (permalink)  
Old 28 Mar 2008, 01:05 pm
Cool Cruiser
 
Join Date: Mar 2008
Location: Gardenton, MB, Canada
Posts: 224
Default Re: Engine Question!

Have you done MX-5's shift mod? When I tried it on mine it shifted only at 4000rpm. I guess mine was one of the early ones that it didn't work on.

Are you turbo or N/A, auto or stick.

Ben
__________________
2001 Red PT Cruiser Limited, 16" OEM alloys, Airaid CAI, Screamin' Demon coil and Livewires, some shiny stuff inside, Alpine deck, Alpine four channel amp, Alpine PLT5 sub, Hertz speakers in 4 corners, Keystone ram air hood, 6000k 55w HID high beams, 6000k 35w HID fog lights, new stone chips every day to add character.

2007 Suzuki King Quad 700 4x4 for when the road gets bumpy.

Reply With Quote
  #4 (permalink)  
Old 28 Mar 2008, 01:33 pm
b0b88's Avatar
Fresh Cruiser
 
Join Date: Jan 2008
Posts: 43
Default Re: Engine Question!

im just a regular automatic.
Reply With Quote
  #5 (permalink)  
Old 28 Mar 2008, 07:18 pm
Obsessed Cruiser
 
Join Date: Dec 2002
Posts: 6,787
Default Re: Engine Question!

when you are driving you cant go over 4,000 rpms ?? if so car is in safe mode check for a code and let us know what it is
Reply With Quote
  #6 (permalink)  
Old 31 Mar 2008, 02:56 pm
Fresh Cruiser
 
Join Date: Feb 2008
Posts: 38
Default Re: Engine Question!

There is also an engineered limit so people don’t slip the trans into drive…the old neutral slam..
Reply With Quote
  #7 (permalink)  
Old 31 Mar 2008, 05:58 pm
b0b88's Avatar
Fresh Cruiser
 
Join Date: Jan 2008
Posts: 43
Smile Re: Engine Question!

i'm pretty sure you meant the tripometer trick to get the diagnostic codes, and the codes i got were FL0007 EE10 BL01 i normally get a code at the very end but there wasn't one this time.. even better to add to my problem someone honked at me today and told me my brake lights aren't working so i have another even bigger problem... just the other day i replaced the oil and air filter oil and the plugs, could i have possibly knocked something out of place when i was taking off the manifold??? or could a simple fuse be the problem?? my pt cruiser is an 03 without the turbo and its an automatic.
Reply With Quote
  #8 (permalink)  
Old 03 Apr 2008, 05:27 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Engine Question!

Those codes aren't error codes.
Turn key "on" (right before start)
back one click to "off"
then on, off, and on.
you should always get at least "done".

Is your idle okay? (smooth).
Checked you tire pressure - really - soft tires will bog you down.
How many miles on the PT?
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Replacing Timing belt: Engine support question cardana24 Tech & Performance Forum 4 21 Mar 2008 07:55 pm
"Mysterious" turbo engine noise...??? Gary04GT Turbo Performance 76 21 Aug 2006 08:28 am
Review: $2200 for a NA replacement engine PT Ctown General PT Cruiser Discussions 8 24 Jul 2006 01:08 pm
Cleaning engine question... Cuco General PT Cruiser Discussions 1 09 Apr 2006 03:18 pm
Check engine oil light question AaronR General PT Cruiser Discussions 5 28 Aug 2004 03:18 am


All times are GMT -5. The time now is 08:41 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors