PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
2004 Rough Idle A/C problems

 
Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 16 Apr 2008, 02:05 pm
Fresh Cruiser
 
Join Date: Apr 2008
Posts: 1
Default 2004 Rough Idle A/C problems

Hey guys not sure if this issue has already been addressed but here goes....

ok I have got a 2004 regular pt cruiser and for the last 6 months I have been having this rough idle. Whenever I start my car the a/c is not as cold as it is when I am driving or moving like on the highway or something. Now whenever I come to a stop after I have been driving it will start to sputter and act like it is going to die but it doesnt.....its like it is sputtering from the spark plugs...so I changed the plugs and the wires and nothing changed. Also I had pep boys run through a computer analysis and the only thing that came back was my freon level in the a/c was kind of low. Now I put one of those a/c boosters in a couple of weeks ago but it really didnt help do you think its really low and I need another booster? I just dont know at all what it is and nobody I know seems to either. Please help!
Reply With Quote
  #2 (permalink)  
Old 16 Apr 2008, 02:53 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: 2004 Rough Idle A/C problems

Welcome to the forum.

Since you changed the wires and plugs and still have a rough idle, your problem might be the IAC (Idle Air Controller) located next to the throttle body. It could be dirty or malfunctioning.



If the air-conditioning is colder when moving it's because the air coming into the condenser is being cooled by the incoming air as you move. You might have a problem with one of the speeds in the fan motor that cools the condenser/radiator when your standing still at idle.
Reply With Quote
  #3 (permalink)  
Old 16 Apr 2008, 09:58 pm
Fresh Cruiser
 
Join Date: Apr 2008
Posts: 1
Default Re: 2004 Rough Idle A/C problems

I am having the exact same problem with my 2003 Limited. What is the best way to go about removing the IAC and cleaning it?
Reply With Quote
  #4 (permalink)  
Old 12 Jun 2012, 05:00 pm
Cool Cruiser
 
Join Date: Oct 2005
Location: northern, ca.
Posts: 209
Default Re: 2004 Rough Idle A/C problems

use a "torx" driver to remove the 1 bolt holding down the IAC. see crewzin's great pic for its location.

because the IAC uses a couple of o-rings, use a wide-blade standard screw driver to carefully "walk-out" the sensor. once removed, disconnect the connector.

wrap a rag around the sensor and soak it with carb cleaner - inside and out. wipe it down inside and out with a clean rag using care around its 2 o-rings.

wrap a carb cleaner soaked rag around a sharpie pen or philips screwdiver to clean deep inside the sensor. i filled up this hole with carb cleaner and let it sit for a second or 2.

back at the engine, wrap your fore finger with a clean - carb cleaner soaked rag to clean the inside of the sensor hole that is attached to the throttle body. mine was coated with black sticky sludge.

carefully seat the sensor back into the throttle body, then reattach its connector.

this cleaning procedure resulted in a day/night hot idle performance on my '03 gt with 82K miles. hope you get the same results.
neverwillbe likes this.
__________________
gt model, modified airbox with cold air induction, magnecor plug wires, tyc b/up lenses, chrome grille kit, retro 3d taillights painted steel blue, buick-style portholes, nomad chevy trunk trim, blue interior light strips, and massive turned down diesel-type exhaust tip.

Last edited by pppt03turbo; 12 Jun 2012 at 06:33 pm.
Reply With Quote
  #5 (permalink)  
Old 12 Jun 2012, 06:06 pm
Regular Cruiser
 
Join Date: Jul 2011
Location: Detroit, MI
Posts: 106
Default Re: 2004 Rough Idle A/C problems

Jiddypop, does this only happen when the A/C is on? If so, it's probably your radiator fan needs replacing.
Reply With Quote
  #6 (permalink)  
Old 12 Jun 2012, 07:00 pm
Fresh Cruiser
 
Join Date: Feb 2012
Location: MPLS,Mn
Posts: 32
Default Re: 2004 Rough Idle A/C problems

The reason it idles bad with the AC on is the HIGH speed fan is not coming on AND the compressor is hitting the HIGH limit (pressure) if you put a gauge on it it will probably read 140 LBS, to high so it trips the high limit,turn off the air and it should run smooth. Here is a test (easy) At normal temp turn on the air,close all the windows,air on max. and when it starts to bog down the motor, spray COLD water from a garden hose on the radiator/ condenser, the interior air temp should drop by 20-30 degrees and it should idle smoother (not up/ down).What you are doing is mocking a high speed radiator fan. If this helps replace the fan/relay assembly. There about $130.00 on line and takes about an hour to do.With no high speed fan the head pressure (in the compressor)gets to high slowing down the little four banger engine and trips the high limit and turns off the compressor.Simple when you think of it.If this is actually the problem, left as is it could take out the power module and thats expensive.
Reply With Quote
  #7 (permalink)  
Old 18 Jun 2012, 03:43 pm
Regular Cruiser
 
Join Date: Oct 2006
Location: miami, florida, USA.
Posts: 133
Default Re: 2004 Rough Idle A/C problems

misterfixit:
My PT idles correctly when engine cold but the A/C is not putting out cold air. When I hosed down the condenser it gets very cold quick.
I hear the fan working and it speeds up when I turn the A/C on.

When I rev up and drive away it immediately cools but at the first traffic light it stops cooling and after a while, when engine is hot, the A/C works perfectly, even at idle.

You mention replacing Fan/Relay Assembly $130.00 but I only find Radiator Fan/Relay for around $8.00.
Could you help me on this?
Reply With Quote
  #8 (permalink)  
Old 18 Jun 2012, 10:41 pm
mdfrodolives's Avatar
Senior Cruiser
 
Join Date: May 2010
Posts: 1,313
Default Re: 2004 Rough Idle A/C problems

It's actually the fan that needs replacing. And you can purchase these for about $130.00 (and cheaper on E-Bay). Most times, the relays are not the problem. It's the brushes in the fan motor that are the culprit in the majority of fan issues. OEM brushes simply run off to join the circus, I suppose.

Tim
Reply With Quote
  #9 (permalink)  
Old 19 Jun 2012, 09:07 am
Regular Cruiser
 
Join Date: Oct 2006
Location: miami, florida, USA.
Posts: 133
Default Re: 2004 Rough Idle A/C problems

mdfrodolives:
Thanks for reply. So I guess this means that the fan's "high speed" is not working since I hear the fan turning on.
I found the fan assembly online for $84.89 plus shipping at RockAuto.com. AdvanceAuto sells the very same fan for $169.99!
Reply With Quote
  #10 (permalink)  
Old 21 Jun 2012, 11:59 pm
Fresh Cruiser
 
Join Date: Feb 2012
Posts: 26
Default Re: 2004 Rough Idle A/C problems

Quote:
Originally Posted by rcalzadilla View Post
misterfixit:
My PT idles correctly when engine cold but the A/C is not putting out cold air. When I hosed down the condenser it gets very cold quick.
I hear the fan working and it speeds up when I turn the A/C on.

When I rev up and drive away it immediately cools but at the first traffic light it stops cooling and after a while, when engine is hot, the A/C works perfectly, even at idle.

You mention replacing Fan/Relay Assembly $130.00 but I only find Radiator Fan/Relay for around $8.00.
Could you help me on this?
Don't know if you've fixed this as of yet. Maybe you already know there are two fan relays. One for the high speed and one for the low..I too found a fan assembly for around 85 bucks or so. Think it was from one of the sponsors listed..
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stalling, rough idle, running "hard", hesitation LiLOrion Tech & Performance Forum 36 21 May 2013 12:43 pm
New PT but rough idle?? Ed Tech & Performance Forum 9 05 Mar 2013 06:38 am
Help Rough Low Idle almost cuts off.. lockupman1 General PT Cruiser Discussions 14 05 Jan 2011 01:28 pm
PT idle rough and smoke scrisp2 Tech & Performance Forum 2 01 Oct 2007 02:18 pm
Rough Idle BlueBlurCruiser General PT Cruiser Discussions 15 07 May 2004 09:50 am


All times are GMT -5. The time now is 11:38 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors