PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Blowing Fuses

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 16 Apr 2008, 06:44 pm
Fresh Cruiser
 
Join Date: Apr 2008
Posts: 4
Default Blowing Fuses

CARTMAN Thanks for the response..Engine wiring harness has been repaired..Traced LB/WT wire from fuse panel fuse #11(ENG MOD/ABS-TRAC) to the PCM pin #20. With the connector disconnected and ignition key on LB/WT wire reading 12.5 volts and fuse is good. Also all connectors on engine disconnected. PCM connector plugged back in, battery connected and key turned on, the fuse blows. Could I have a bad PCM causing the fuse to blow??

Last edited by DragAsp; 16 Apr 2008 at 07:16 pm.
Reply With Quote
  #2 (permalink)  
Old 16 Apr 2008, 10:43 pm
Cool Cruiser
 
Join Date: Dec 2007
Posts: 369
Default Re: Blowing Fuses

that fuse also powers the fuel pump relay and the ABS controller. replace the fuse, and disconnect the abs controller connector and remove the fuel pump relay. if the fuse doesnt blow, put the relay back in. if it blows, the relay or the wiring harness for the relay is bad. if it doesnt blow, connect the abs controller. if it blows then, the abs controller may have an internal fault and may require replacement or its wiring harness is damaged. of course, if all that is disconnected, and just the PCM is connected, and the fuse blows, yeah id say its the PCM. but start with the cheap stuff first. also check to see if you have the correct fuse in that location, it should be a 10 amp. good luck.
__________________
06 Touring Edition NA/Auto. Airaid intake, Magnaflow Stainless cat-back exhaust, Taylor Thundervolt plug wires, rear lowered 1.75" with H&R Springs.
Yep, buying parts I cant afford with money I dont have to impress people I dont like anyways.
Reply With Quote
  #3 (permalink)  
Old 17 Apr 2008, 04:58 pm
Fresh Cruiser
 
Join Date: Apr 2008
Posts: 4
Question Re: Blowing Fuses

Thanks, Checked - No ABS, pulled all the relays in the PDC, plugged connector into PCM, connected battery, key on, fuse blows... So, I'm assuming the PCM is bad. Also ohmed pin 20 in the PCM to the case, it's indicating grounded. Is there any way to check (continuity or otherwise) the engine wiring harness that would cause the PCM to short? Hate to put another PCM in and blow it too. Would a PCM connector pin diagram help to check each circuit in the engine harness? Just pulling straws right now,,,,
Reply With Quote
  #4 (permalink)  
Old 19 Apr 2008, 01:17 am
Cool Cruiser
 
Join Date: Dec 2007
Posts: 369
Default Re: Blowing Fuses

youve still got a damaged wire in there somewhere. pin 20 shouldnt be grounded. that direct short to ground would blow that fuse. that particular circuit goes all over the engine compartment from what i can tell.
__________________
06 Touring Edition NA/Auto. Airaid intake, Magnaflow Stainless cat-back exhaust, Taylor Thundervolt plug wires, rear lowered 1.75" with H&R Springs.
Yep, buying parts I cant afford with money I dont have to impress people I dont like anyways.
Reply With Quote
  #5 (permalink)  
Old 21 Apr 2008, 07:34 pm
Fresh Cruiser
 
Join Date: Apr 2008
Posts: 4
Default Re: Blowing Fuses

Cartman

Chased a lot of wire last several days to no avail, I was about to give up and let a shop look at it until I disconnected the EVAP PURGE SOLENIOD. Hooked everything back up and tried the scanner,,,It got some codes..P0118 P0340. Missed the temperature sensor connection and swapped the cam position sensor. The motor finally started but only ran for 10 seconds. Acted like it was running out of fuel each time. Tomorrow I'll chase that...
Anyway what I wanted to say was ...THANKS for steering me in the right direction.
Reply With Quote
  #6 (permalink)  
Old 21 Apr 2008, 11:33 pm
Cool Cruiser
 
Join Date: Dec 2007
Posts: 369
Default Re: Blowing Fuses

no problem
__________________
06 Touring Edition NA/Auto. Airaid intake, Magnaflow Stainless cat-back exhaust, Taylor Thundervolt plug wires, rear lowered 1.75" with H&R Springs.
Yep, buying parts I cant afford with money I dont have to impress people I dont like anyways.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ciggy lighter & Power outlet not working -all fuses fine. swisstony10 Tech & Performance Forum 19 09 May 2016 02:59 pm
fog lamp fuse blowing smilanatu Tech & Performance Forum 13 19 Jul 2009 11:07 am
Blowning fuses DragAsp Tech & Performance Forum 1 15 Apr 2008 12:14 am
fuses alice Stage Turbo Kits 7 07 May 2005 10:08 am


All times are GMT -5. The time now is 10:52 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors