PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Well crap.

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 18 Apr 2008, 07:22 pm
thegoldpt's Avatar
Fanatic Cruiser
 
Join Date: Apr 2005
Location: Port Orchard, Washington
Posts: 771
Send a message via MSN to thegoldpt Send a message via Yahoo to thegoldpt
Default Well crap.

So, again the car is doing something strange. I think the AC is messed up, because when you turn the AC, and run iut for a while, it starts making a hissing sound, and then it starts shooting out a steam like substance from underneath the car with a loud pop. It only happens when the AC is running.

So it's going in tommorrow.
Reply With Quote
  #2 (permalink)  
Old 18 Apr 2008, 07:51 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Well crap.

Jonathan,

Are you sure it isn't the condensation that builds up when the air is on and it's dropping onto the hot exhaust? That would cause the hissing and popping and cause steam to rise off the hot exhaust. The condensation overflow tube is supposed to catch the water and divert it harmlessly onto the pavement/floor near the passenger front wheel but if the tube is damaged or come loose, the water could drip on a part of the hot exhaust.

The dealer will charge you at least an hour's labor ($95 ??) to find it. If you can, get under the car on the passenger side and look for that rubber black overflow tube and see if you can trace it back to source to see it it's loose or torn.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.

Last edited by CREWZIN; 18 Apr 2008 at 07:57 pm.
Reply With Quote
  #3 (permalink)  
Old 18 Apr 2008, 07:56 pm
thegoldpt's Avatar
Fanatic Cruiser
 
Join Date: Apr 2005
Location: Port Orchard, Washington
Posts: 771
Send a message via MSN to thegoldpt Send a message via Yahoo to thegoldpt
Default Re: Well crap.

No it's not, this smells like a burning sorta smell, it's not that.
Reply With Quote
  #4 (permalink)  
Old 18 Apr 2008, 07:58 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Well crap.

OK. Good luck. Hope it's not expensive.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #5 (permalink)  
Old 18 Apr 2008, 08:31 pm
Fanatic Cruiser
 
Join Date: Dec 2003
Location: San Antonio, Texas
Posts: 535
Default Re: Well crap.

More than likely your cooling fan has stopped working. The head pressure gets too high when the fan doesn't move air over the condensor while your idling. The pressure gets too high and vents. Pretty common.
Reply With Quote
  #6 (permalink)  
Old 18 Apr 2008, 08:56 pm
outfit's Avatar
Cool Cruiser
 
Join Date: Feb 2008
Location: Sinton Texas
Posts: 221
Send a message via Yahoo to outfit Send a message via Skype™ to outfit
Default Re: Well crap.

this falls right under the well crap ...... Had my first problem with the PT.. Dang battery went to.. well you get the idea..it would have been okay if I was in it when it happened...... Anyone else come accros a dead battery.. out of the blue...
__________________
<---- Just installed.
2006 PT Cruiser Touring Non-Turbo
3 -Hyper White Thin Flexible 5mm LED Dome Lights from Oznium Damn they make a dif in the inside ,let me tell you the best led lights you can buy
1 -Hyper White 921 Superstar Bulbs from Autolumination
1 -Hyper White T10 Wedge 194 (Lic Pllate) Super White LED from Autolumination

Pioneer Head unit W/ HD & Satellite radio

2 - 7inch DVD/Headrests Monitors... dvd players built in the headrests
HID Lights 8000k 9006 for lows from xhidoutlet....
HID Slim 55w 6000K for high's from HIDGEEK.

Reply With Quote
  #7 (permalink)  
Old 24 Apr 2008, 01:07 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Well crap.

Dead batery on an '06? Sounds like you multifunction switch went - the left stalk for lights, turn signals... when it goes, lights can come on & drain your battery...
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #8 (permalink)  
Old 24 Apr 2008, 01:15 pm
thegoldpt's Avatar
Fanatic Cruiser
 
Join Date: Apr 2005
Location: Port Orchard, Washington
Posts: 771
Send a message via MSN to thegoldpt Send a message via Yahoo to thegoldpt
Default Re: Well crap.

Quote:
Originally Posted by slartyblarfast View Post
More than likely your cooling fan has stopped working. The head pressure gets too high when the fan doesn't move air over the condensor while your idling. The pressure gets too high and vents. Pretty common.
Exactly what happened... They replaced it all is good now!
Reply With Quote
  #9 (permalink)  
Old 24 Apr 2008, 01:16 pm
thegoldpt's Avatar
Fanatic Cruiser
 
Join Date: Apr 2005
Location: Port Orchard, Washington
Posts: 771
Send a message via MSN to thegoldpt Send a message via Yahoo to thegoldpt
Default Re: Well crap.

BTW I have the 7 year warranty.. so it was all covered.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Quick & easy-Bull Crap! littleblueGT General Turbo Discussions 1 17 Sep 2007 02:22 pm
OH CRAP!! Car died Stephen R. Tech & Performance Forum 5 24 Oct 2003 04:56 pm
Crap, crap, crap PTGT Redman Turbo Performance 6 18 Sep 2003 08:15 am
Crap!!! Make sure you read the instructions... hyracer Stage Turbo Kits 1 17 Aug 2003 04:55 pm


All times are GMT -5. The time now is 07:54 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors