PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
electrical power lost !!!!!

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 04 May 2008, 11:01 pm
Fresh Cruiser
 
Join Date: May 2008
Posts: 5
Default electrical power lost !!!!!

my wife has a 02 limited, recently it lost all power to the windows, a-c blower and the check engine light,ABS is on,,,,,ALL fuzes are good ALL relays are good....any sugestions????? thank Jeremy
Reply With Quote
  #2 (permalink)  
Old 04 May 2008, 11:04 pm
Fresh Cruiser
 
Join Date: May 2008
Posts: 5
Default Re: electrical power lost !!!!!

this hpppened about a year ago for a few weaks ......now it's happing again
Reply With Quote
  #3 (permalink)  
Old 05 May 2008, 12:34 am
Cool Cruiser
 
Join Date: Dec 2007
Posts: 369
Default Re: electrical power lost !!!!!

so the problem corrected itself earlier?
__________________
06 Touring Edition NA/Auto. Airaid intake, Magnaflow Stainless cat-back exhaust, Taylor Thundervolt plug wires, rear lowered 1.75" with H&R Springs.
Yep, buying parts I cant afford with money I dont have to impress people I dont like anyways.
Reply With Quote
  #4 (permalink)  
Old 05 May 2008, 09:29 am
Fresh Cruiser
 
Join Date: May 2008
Posts: 5
Default Re: electrical power lost !!!!!

yes it did,,,,, any idea where to start throwing money at???
Reply With Quote
  #5 (permalink)  
Old 05 May 2008, 07:50 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: electrical power lost !!!!!

My hunch is battery. When it starts to go, weird things happen. If you have a new battery, check the clamps and battery terminals.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #6 (permalink)  
Old 05 May 2008, 10:37 pm
Fresh Cruiser
 
Join Date: May 2008
Posts: 5
Default Re: electrical power lost !!!!!

are there any more places to look besides the 2 fuze boxes?
Reply With Quote
  #7 (permalink)  
Old 10 May 2008, 09:51 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: electrical power lost !!!!!

Just the one by driver's left knee and the one underhood behind air intake. Get a voltmeter and check you have power to the fuses (take a fuse out, and put probes in - you should see 12V.) Check grounds. Nasty problem.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #8 (permalink)  
Old 10 May 2008, 11:13 pm
Cool Cruiser
 
Join Date: Dec 2007
Posts: 369
Default Re: electrical power lost !!!!!

agree with qsd. check battery, cables and terminals. make sure all is tight.
__________________
06 Touring Edition NA/Auto. Airaid intake, Magnaflow Stainless cat-back exhaust, Taylor Thundervolt plug wires, rear lowered 1.75" with H&R Springs.
Yep, buying parts I cant afford with money I dont have to impress people I dont like anyways.
Reply With Quote
  #9 (permalink)  
Old 30 Jul 2008, 09:16 pm
Fresh Cruiser
 
Join Date: May 2008
Posts: 5
Default Re: electrical power lost !!!!!

dealership found the problem,,,, the ignition switch,,,$300..DONE!!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2008 lineup saves on fuel, but not power skylight PT Cruiser News and Rumors 0 13 Oct 2007 04:09 pm
Help. No Power Door Locks with Ignition off. Lloyd General PT Cruiser Discussions 2 15 Jul 2007 10:17 am
Guide: 2006 Power windows and Sunroof always on. zapwizard General PT Cruiser Discussions 3 21 May 2007 09:23 am
How to get power to my mp3 player & other concerns Doktor X Sound and Security Forum 3 29 Jul 2005 10:38 pm
need advice on strange electrical problem in Jeep comPuTer General PT Cruiser Discussions 1 07 Jul 2004 07:31 pm


All times are GMT -5. The time now is 01:31 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors