PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Car stalled 3 days after work done

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 25 May 2008, 05:52 pm
Young Cruiser
 
Join Date: Sep 2007
Location: OxCx - SO CAL
Posts: 71
Default Car stalled 3 days after work done

On Wednesday I had all the plugs and wires replaced, new MAP sensor and new coil pack. Cleaned throttle body and tune up.

I had the work done at a mechanic we've used for over 20 years - honest and great.

3 days later on the freeway, I was stopped and the car died. No warning, just shut off. It started right back up again.

It's driving but of course I can't see the mechanic till after the Memorial Day holiday.

I've driven it a few times since, and it has not stalled. I'm scared it will do it again.

Any ideas of what or why it would do this after all this work?

edit:
I checked for codes and it said 'done'
I just cleaned my cold air intake filter 2 weeks ago.

Last edited by R_I_PT; 25 May 2008 at 06:02 pm.
Reply With Quote
  #2 (permalink)  
Old 25 May 2008, 06:42 pm
Veteran Cruiser
 
Join Date: Mar 2003
Location: Oregon.
Posts: 3,521
Default Re: Car stalled 3 days after work done

Why was the coil replaced? I've never heard of one going out, ever.
__________________
\'05 Stone White SRT4

\'04 Graphite PT Automatic
Reply With Quote
  #3 (permalink)  
Old 25 May 2008, 06:56 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: Car stalled 3 days after work done

Mean Green, here's the thread that goes thru all the problems R-I-PT went thru with bad dealers.

06 turbo check engine light

R-I-PT,

Two main things bring the engine to a halt, fuel and spark. Although your mechanic might be good, sounds like he may have left something electrical loose. Check your battery connections and if you can all the wires to the coil. Also check anything he might have disconnected to clean the TB and replace the MAP sensor.
Reply With Quote
  #4 (permalink)  
Old 25 May 2008, 07:52 pm
Veteran Cruiser
 
Join Date: Mar 2003
Location: Oregon.
Posts: 3,521
Default Re: Car stalled 3 days after work done

Quote:
Originally Posted by CREWZIN View Post
Mean Green, here's the thread that goes thru all the problems R-I-PT went thru with bad dealers.

06 turbo check engine light

R-I-PT,

Two main things bring the engine to a halt, fuel and spark. Although your mechanic might be good, sounds like he may have left something electrical loose. Check your battery connections and if you can all the wires to the coil. Also check anything he might have disconnected to clean the TB and replace the MAP sensor.
Ahhh, so the coil was replaced as a reach. Crewzin is right. Double and triple check everything.
__________________
\'05 Stone White SRT4

\'04 Graphite PT Automatic
Reply With Quote
  #5 (permalink)  
Old 26 May 2008, 02:31 pm
Young Cruiser
 
Join Date: Sep 2007
Location: OxCx - SO CAL
Posts: 71
Default Re: Car stalled 3 days after work done

I'm beginning to wonder if I have a bigger problem overall that is affecting the car. Lemon? or not.
I'll have to have the mechanic check as you two recommended.
Thanks.
Reply With Quote
  #6 (permalink)  
Old 29 May 2008, 02:04 pm
Young Cruiser
 
Join Date: Sep 2007
Location: OxCx - SO CAL
Posts: 71
Default Re: Car stalled 3 days after work done

SO
The car began surging again.
I called Chrysler in India then got connected to Michigan. I documented what has happened lately.
They told me they can't do anything til I get a diagnosis from Chrysler if something is REALLY wrong with my car. Which will cost a million dollars an hour for their cruddy diagnosis.

Here's my list of issues:
- Rack and pinion replaced at 43K miles courtesy of Chrysler
- A/C leak fixed and paid by dealer because they scratched and dinged my car, which they fixed also.
- Spark plugs replaced at 43K in addition to MAJOR service, which included every fluid flush possible, throttle body service, plus more
- Serpetine belt replaced around 49K
- Windshield wiper cord broke
- 58K miles Spark plus diagnosed as bad and wires bad
- 58K miles MAP sensor cracked
- 58k Miles coil pack replaced along with new wires plugs and throttle body service. Coil pack hadn't been found by Chrysler, but my indy mechanic.
- Steering wheel vibrates violently at 60mph+; both the dealer and independent mechanic diagnosed it as a bad tire even though this symptom existed on 2 different sets of tires.
- Battery replaced at 25k miles by dealer under warranty
Car still surging, stalled.

I added Mopar, dealer installed Cold Air Intake, and added after market, no muffler exhaust.

Chrysler now says it could be my Throttle Position Sensor.
Chrysler in Michigan requires me to take it to the dealer to get a furthur diagnosis of the problem, in order for me to request that Chrylser pay for it.
Problem is, I don't want to keep spending the $$ for diagnosis, repair and then something else breaks.

Can anyone steer me in the right direction on what to request from the dealer when I take it in?
Reply With Quote
  #7 (permalink)  
Old 29 May 2008, 04:07 pm
Young Cruiser
 
Join Date: Sep 2007
Location: OxCx - SO CAL
Posts: 71
Default Re: Car stalled 3 days after work done

Yippee skippe
Check engine light just came on
pulled the code
340 - No camshaft signal being received by the computer

Called the dealer, won't cover it under my remaining powertrain warranty.
It better be a sensor and not the camshaft
>=(
Reply With Quote
  #8 (permalink)  
Old 29 May 2008, 04:51 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: Car stalled 3 days after work done

First, if it is the Camshaft sensor it's not too expensive and it's pretty easy to replace ...see picture.

Second, I had the same code. Turned out to be the wiring harness from the sensor to the computer. The harness fell from it's mooring (a little 2 cent hook) and let the harness fall into the path of the front passenger-side halfshaft that while spinning burnt through the harness and the wires from the sensor. No wires, no camshaft signal, no go.

Reply With Quote
  #9 (permalink)  
Old 29 May 2008, 05:05 pm
Young Cruiser
 
Join Date: Sep 2007
Location: OxCx - SO CAL
Posts: 71
Default Re: Car stalled 3 days after work done

Crewzin -
thanks again.
It's always good to hear others that had the same problem, so I don't feel like my PT is going to die...

I'll provide an update soon.
Reply With Quote
  #10 (permalink)  
Old 30 May 2008, 06:15 am
Obsessed Cruiser
 
Join Date: Dec 2002
Posts: 6,787
Default Re: Car stalled 3 days after work done

good luck, keep us posted !!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Detail work. check list turbomangt The Detail Shop 9 22 Jun 2006 08:34 am
Will stage 2 wastegate off a SRT-4 work. nastyvr6 Turbo Performance 5 23 Jul 2005 05:17 am
Chrysler Group Launches Top Down Days skylight PT Cruiser News and Rumors 2 15 Sep 2004 06:19 pm


All times are GMT -5. The time now is 02:55 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors