PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
P0420--Cat efficiency low bank 1?

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 15 Jun 2008, 04:20 pm
Fresh Cruiser
 
Join Date: Jun 2008
Posts: 3
Default P0420--Cat efficiency low bank 1?

Hi,

01 (fixed typo!) PT Cruiser, auto, non-turbo, 73K miles

Getting above error code, with--accordign to autozone computer--four possible causes; 1. Cat converter defective, 2) Engine misfire, 3) Large vacume leak, 4) Engine oil leakage past rings.

- Reset it 3 x still comes back on in about a day
- replaced plugs, wires look good
- car runs good
- no oil consumption

Any thoughts on what I can test/check at home befoer bringing to the dreaded dealer? Any way to test the cat?

Thx
ZY

Last edited by ZY100; 16 Jun 2008 at 08:52 pm.
Reply With Quote
  #2 (permalink)  
Old 15 Jun 2008, 04:50 pm
JoeHundredAire's Avatar
Young Cruiser
 
Join Date: Aug 2007
Location: Arlington, TX
Posts: 93
Default Re: P0420--Cat efficiency low bank 1?

Quote:
Originally Posted by ZY100 View Post
Hi,
- Reset it 3 x still comes back on in about a day
- replaced plugs, wires look good
- car runs good
- no oil consumption

Any thoughts on what I can test/check at home befoer bringing to the dreaded dealer? Any way to test the cat?

ZY
There's no way to tell what condition the wires are in by looks. If they are the original mopar wires, then go ahead and replace them.
As far as testing the CAT I'm not sure if there is a way to test it without special equipment, but I'm sure there is something.
Given that you said it's running fine, but it's possible that it's a bad sensor rather than the CAT itself. Typically you can test the O2 sensors with an Volt/Ohm meter. Of course, I just replaced the CAT on our '01 Celica & it was running perfectly fine as well. So even if the cat isn't doing it's job, doesn't mean it's hampering performance. Either way if it's a bad sensor or a bad cat, I wouldn't take it to a dealer for that. Find a cheap muffler shop & have them replace the cat. It'll be alot cheaper than a "stealership".
Reply With Quote
  #3 (permalink)  
Old 15 Jun 2008, 05:03 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: P0420--Cat efficiency low bank 1?

Welcome to the forum.

What year did you say your PT Cruiser is ....91 ????

Anyway, here's something to read about your fault code P0420...

Troubleshooting P0420 Catalyst Code
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #4 (permalink)  
Old 15 Jun 2008, 06:19 pm
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: P0420--Cat efficiency low bank 1?

Aren't Catalytic Converters covered under longtime warranty under Federal Emissions?
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #5 (permalink)  
Old 15 Jun 2008, 06:34 pm
ucantcme's Avatar
Senior Cruiser
 
Join Date: Aug 2007
Location: Wixom, Michigan
Posts: 1,486
Send a message via AIM to ucantcme Send a message via MSN to ucantcme Send a message via Skype™ to ucantcme
Default Re: P0420--Cat efficiency low bank 1?

I traded in my 91' because it had the same problem, lol

Just messin'! Welcome to the forums - Hopefully you can resolve this code quickly!
__________________



My Baby:
01' Taupe Limited PT Cruiser w/ rear spoiler, Drop in K&N Air Filter, Limo tint all around, blue neon interior, blue LED windshield nozzles,
In-dash CD/DVD/Radio made by Jensen, Vent Visors, Chrome Antenna Bezel, Chrome Grille inserts, Dual Catback Exhaust, Scan Gauge II,
back-up camera, and a system containing 2 Lanzar 15" subwoofers and an MA Audio 1800watt amplifier.

Check me out on Car Domain!
Reply With Quote
  #6 (permalink)  
Old 15 Jun 2008, 07:38 pm
Regular Cruiser
 
Join Date: Mar 2008
Posts: 102
Default Re: P0420--Cat efficiency low bank 1?

My '88 did the same thing. I just bought a newer one.
__________________

'03 Pt, headrest monitors, dvd, painted interior (kind of), modified air box, K&N drop in filter
Reply With Quote
  #7 (permalink)  
Old 15 Jun 2008, 10:07 pm
Young Cruiser
 
Join Date: Aug 2007
Posts: 73
Default Re: P0420--Cat efficiency low bank 1?

Get or make a O2 simulator, after you install it and your code goes away then you know the Cat is bad and needs to be replaced.
Reply With Quote
  #8 (permalink)  
Old 25 Jun 2008, 07:36 pm
Fresh Cruiser
 
Join Date: Jun 2008
Posts: 3
Default Re: P0420--Cat efficiency low bank 1?

Thx Guys!

It was the CAT and it was covered under the 8yr/80K warranty! And I was at 77.3K, so your info was just in time.

However, as it was there and the timing belt was making nose, I had them do the belt, pully upgrade and apparently a new cover....got me for $1K.

Wow....I probably could have found a local garge for ~600, but they had me by the curlies. I took the path of least resistance and let them do the belt. Boy, I do hate the delaers though.

ZY
Reply With Quote
  #9 (permalink)  
Old 11 Aug 2012, 10:20 am
Fresh Cruiser
 
Join Date: Jun 2009
Posts: 9
Default Re: P0420--Cat efficiency low bank 1?

They didn't do the water pump at the same time?
Reply With Quote
  #10 (permalink)  
Old 11 Aug 2012, 10:30 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: P0420--Cat efficiency low bank 1?

....and most PT's go to at least 100.000 miles before the belt needs changing (along with the water pump as suggest above). Seems like the dealer scared you into changing the belt early because of some noise, which could have been anything
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Check Engine Light came on - code 1188? coolvirus General Turbo Discussions 38 25 May 2011 09:01 am
Error Codes skylight Tech & Performance Forum 7 28 Apr 2011 03:34 pm
obd-II codes Punch General Turbo Discussions 13 06 Jul 2009 06:54 pm
Error Codes thegoldpt Turbo Performance 6 07 Apr 2007 02:26 pm
Error Code List skylight General Turbo Discussions 6 07 Apr 2007 02:11 pm


All times are GMT -5. The time now is 02:38 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors