PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
'04 2.4 With a Skip, no codes?

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 23 Jul 2008, 09:46 pm
Fresh Cruiser
 
Join Date: Jul 2008
Location: Up-state NY
Posts: 13
Default '04 2.4 With a Skip, no codes?

New here! Have a '04 2.4 in a Jeep 2.4 that has a slight skip at 2,000 to 2,500 RPM. Jeep dealer can't find anything wrong, or so they say! I see reading your forum that a lot of you with the 2.4 change the wires often, I did with OEM wires, still skips??? I was hoping you guy's could help me out! Changed the plugs (champion copper plus) new wires OEM Jeep, new TPS, cleaned the throttle body (twice) re-flashed the ECM, no codes a all????? Factory tech came out and said nothing is wrong with the Jeep, he must have his head up,,,,, well you know the rest. I just want the thing to run right, please any help to fix this little old Jeep?

Reply With Quote
  #2 (permalink)  
Old 24 Jul 2008, 11:55 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: '04 2.4 With a Skip, no codes?

Not sure if the engine is identical, but on the PT, you have to take the intake manifold off to get at the plugs/wires, and sometimes there's an intake gasket leak... It usually is a rough idel, too. test is to spray WD40 along the intake manifold seam, and if idle smooths out, it's an intake manifold leak.

It usually is wires, and it is better to buy Crane wires, which really last, than stock ones.
What did you gap plugs at? A TSB - I believe was for ALL 2.4L egines, revised gap from 0.050 to 0.040.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #3 (permalink)  
Old 25 Jul 2008, 06:19 pm
Fresh Cruiser
 
Join Date: Jul 2008
Location: Up-state NY
Posts: 13
Thumbs up Re: '04 2.4 With a Skip, no codes?

I'd like to thank all you guy's for the post about all the trouble with the plug wires on the 2.4's! I wasn't able to get a set of Crane wires (yet) but did install a set of NAPA's best wires and reset the gap to .040 after the dealer set them @ .050 my Jeep now runs the way it should!!! I've had this Jeep back to the selling dealer many times, they replaced the plugs, wires (OE wires) coil, TPS, air filter, cleaned the throttle body and four bottles of fuel cleaner then GAVE up on it and told me nothing was wrong with it and wouldn't do anything more because they had a factory tech come out and couldn't see anything wrong with it, NO CODES so nothing wrong,,, right?
That's when I thought that the PT's use the same 2.4 and you guy's should know,,,,, and you DID!! I can't tell you how much you've helped me, I was getting ready to trade it in and loose about $3,000 or more I was so unhappy with it!

Reply With Quote
  #4 (permalink)  
Old 25 Jul 2008, 07:46 pm
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: '04 2.4 With a Skip, no codes?

Glad you were able to find what you needed on this Forum for your Jeep.
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #5 (permalink)  
Old 02 Aug 2008, 02:18 pm
Fresh Cruiser
 
Join Date: Jul 2008
Location: Up-state NY
Posts: 13
Default Re: '04 2.4 With a Skip, no codes?

Okay, bought a set of Bosch Platinum+4 and installed them last night. Only took the Jeep just down the road and it seams to run even better yet!!! I couldn't find anyone that had any of the plug wires that most of you are running, ended up with NAPA best 7mm wires they had (they even match my Jeep, blue wires) they alone made a big difference with the copper plus plugs, oh by the way, the Jeep dealer set the plugs at .050 Can you believe they did that? I guess they don't read the TSB's the factory sends out!
When I can I want to change the wires over to the Crane setup, can anyone tell me, do the Crane wires have the big boot to seal up the hole through the valve cover like the stock ones do?
Reply With Quote
  #6 (permalink)  
Old 02 Aug 2008, 02:52 pm
Cool Cruiser
 
Join Date: Mar 2008
Location: Gardenton, MB, Canada
Posts: 224
Default Re: '04 2.4 With a Skip, no codes?

I didn't realize that the Wrangler's could be had with the 2.4, I thought they only had the 2.5 AMC. It probably wouldn't be too hard to run the GT engine out of the PT in the Jeep. 215-230HP depending on the year, and you'd still get good fuel mileage if you keep your foot out of it! I think I'd come across someone putting that into a Jeep before, but I thought they'd done an engine swap to a 2.4, not that they had an existing 2.4.

If you don't mind my asking, what kind of fuel mileage do you get, are you manual or auto, and what kind of purchase price are those guys used?

Sorry I can't help you with the wires. I'm running Livewires on mine. They're expensive, and I never noticed a difference.

Ben
__________________
2001 Red PT Cruiser Limited, 16" OEM alloys, Airaid CAI, Screamin' Demon coil and Livewires, some shiny stuff inside, Alpine deck, Alpine four channel amp, Alpine PLT5 sub, Hertz speakers in 4 corners, Keystone ram air hood, 6000k 55w HID high beams, 6000k 35w HID fog lights, new stone chips every day to add character.

2007 Suzuki King Quad 700 4x4 for when the road gets bumpy.

Reply With Quote
  #7 (permalink)  
Old 02 Aug 2008, 03:49 pm
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: '04 2.4 With a Skip, no codes?

IMHO, I think the performance wires (MOPAR or Crane) is that they don't break down as fast as the stock wires have a tendency to do.
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #8 (permalink)  
Old 02 Aug 2008, 07:27 pm
Fresh Cruiser
 
Join Date: Jul 2008
Location: Up-state NY
Posts: 13
Default Re: '04 2.4 With a Skip, no codes?

cleverklutz

I live in up-state New York, Mid-State as they call it around here, moved here almost three years ago from the lakes region of New Hampshire. The '04 Jeep Wrangler I bought up here had a price tag of $12,000, it's a model SE,5 speed, tilt wheel, no air, hard top, Jeep's little steel wheel's, full door's (hard top & full door's add more) with the 2.4 twin over head cam 4 cylinder with 44,500 miles on it. One of the main reason's I bought this one was the fact that it was a certified used Jeep from a Jeep dealer! I looked at an '02 sport with the 4.0 six cylinder with not much of any warranty, but come to find out the selling dealer will NEVER sell me another Jeep or anything! They didn't check ANYTHING over on this used Jeep, I've had it back and back to them time after time to the point they then said nothing is wrong with it and won't do any more on it! Skinner & Damulis must have bought their five stare rating, they sure didn't get it from doing what should be done! I've even had to take it back during the first rain we had because the wipers wouldn't even clean the windshield off, new muffler from cat back and then a whole list of parts they threw on the motor trying to take away the skip. They told me one of the times they had it that it had "random multiple misfires" but still couldn't fix it! That's when I turned to you guy's, I thought if anyone should know the 2.4's you guy's should!!!! And you guy's did help, I can't thank this forum enough! I even talked to two other Jeep dealers about the skip and none had a answer for me?? I was about at wits end with this Jeep, ready to trade it in and lose $3,000 or more.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Check Problem Codes Yourself! turbomangt General PT Cruiser Discussions 14 01 Jun 2016 01:37 am
Check engine light, ever hear of these codes? MINIHEMI46 Turbo Performance 16 30 Mar 2015 04:02 pm
Error Codes skylight Tech & Performance Forum 7 28 Apr 2011 03:34 pm
2003 Error codes Reed Tech & Performance Forum 4 15 Aug 2007 08:12 am
Error Codes thegoldpt Turbo Performance 6 07 Apr 2007 02:26 pm


All times are GMT -5. The time now is 03:37 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors