PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
My Turn ...all you tech's out there.

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 12 Aug 2008, 12:38 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default My Turn ...all you tech's out there.

Got a problem and I know what's wrong, I hope.

The HAVC controls aren't working. The interior fan is blowing like crazy but there's no air coming to the vents inside. So the problem is the control cables (I hope).

I haven't pulled the HVAC control panel in the center console yet and hopefully one or both of the cables have slipped off the control knob. Easy fix.

But my luck it's the other end of the cable(s) down under the dash.

I have pictures of it and know what to look for but here's the question. Will I be able to fix one or both of the control cables without taking apart the dash?

I'm really gonna hate to do that if I have to.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #2 (permalink)  
Old 12 Aug 2008, 01:23 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: My Turn ...all you tech's out there.

....half hour later.

Went out to the PT too in hand.

Pulled out the center console and looked at the HVAC control. Everything looked good and working when I turned the knobs. Pulled on the cables, as best I could to see if they were loose on the other end ...tight.

Stuck the key in the ignition, put just the control knobs back on without the surrounding console and ............. Freezing cold air comes blasting out of the outlets.

Tested all the knobs in every position and everything works. What the heck is going on?

Thinking back to an old car I had, there was a problem that the air was so cold (and the PT will freeze your fingers off) that some control somewhere was freezing up and stopped the air conditioning (can't remember exactly how) but when it warmed up a bit, it started working again. I wonder if I have the same kind of problem?

Any suggestions out there?
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 12 Aug 2008, 03:07 pm
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: My Turn ...all you tech's out there.

Carey, I think you have a "ghost" in your control panel. Seriously, your thought may be closer than you think with all of the humidity we have had this year. It could cause the control to "freeze" up.
Hooligan
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #4 (permalink)  
Old 12 Aug 2008, 07:40 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: My Turn ...all you tech's out there.

Think I found out what's going on.

Went to my Corvette meeting tonight and spoke with a couple people about what's happening with my PT.

I was told that over time, the air-conditioning system looses freon (R134) and at a certain point it actually gets colder than it should. Remember when I said mine would freeze your fingers off. Well, because it's so cold it actually freezes the evaporator. When that freezes (covered in ice) the air to the vents can't get through anymore. Waiting awhile till the ice thaws will then let the cold air up to the vents again.

I had waited awhile till I tried it again which gave it time to thaw. Sounds good to me and as I said I remember it happening to one of my old cars.

To fix the problem, the R134 has to be regulated/mixed (whatever) back to the correct balance.

One thing about R134 compared to the old R60, was that it's good/better for the environment but didn't get as cold as the old R60 but mine was absolutely freezing which goes along with the theory of the freezing evaporator.

Here's hoping that's all it is.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #5 (permalink)  
Old 13 Aug 2008, 09:59 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: My Turn ...all you tech's out there.

I guess I'm the only one diagnosing my own problem...which I just did.

Took it in to have the freon checked but before that I did a lot of internet searching. Turns out my problem with the evaporator freezing there could be two reasons. One, low on R134, two the pressure cycling switch is bad.

Shop tested and I was 1/2 pound low in R134 and we let it run for awhile. I'm getting 36 degree air thru the vents ...4 degrees above freezing so no wonder my hands were cold but, the compressor never cycled. So the re-cycling switch is my culprit and by not letting the compressor turn off and on it eventually got so cold it froze up the evaporator.

Ordered the part and will throw it in this afternoon.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #6 (permalink)  
Old 13 Aug 2008, 11:42 am
Johns Steel Blue's Avatar
Fanatic Cruiser
 
Join Date: Jun 2005
Location: Midlothian, Va.
Posts: 567
Default Re: My Turn ...all you tech's out there.

Physician, Go FOrth and Heal Thyself
__________________
John








People say I have a drinking problem. I Drink... I Get Drunk... I Fall Down... No problem! ! !
Reply With Quote
  #7 (permalink)  
Old 13 Aug 2008, 11:50 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: My Turn ...all you tech's out there.

No truer words were ever spoken john.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #8 (permalink)  
Old 13 Aug 2008, 07:53 pm
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: My Turn ...all you tech's out there.

Makes you wonder why you asked us, doesn't it.
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fog lights won't turn off... emhymas Tech & Performance Forum 27 20 Nov 2016 08:57 pm
turn signals AlexJB Exterior Accessories Forum 6 12 May 2008 08:12 pm
Noise in front when making left turn; not right Runkle Wheels, Tires, Suspension 2 12 Feb 2007 01:04 pm
Turn Signals Not Working Indynick General PT Cruiser Discussions 9 15 Sep 2004 02:25 pm
Key will not turn relytgerg General PT Cruiser Discussions 11 17 Feb 2004 02:36 pm


All times are GMT -5. The time now is 07:35 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors