PT Cruiser Forum  
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

stage one srious bogging problems

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 17 Oct 2008, 05:54 pm
Fresh Cruiser
 
Join Date: Jul 2007
Location: coquitlam, bc canada
Posts: 20
Default stage one srious bogging problems

ok here it goes.
i have a 2003 pt gt with a stage one pcm, custom dual exhaust, bov, and cold air intake. When i first put in my stage one pcm everthing worked excellent way more power ect. but I have had it in for around 4 months and suddenly when i step on the gas hard it bogs down big time. I tried changing spark plugs and wires but it did not help (iruduim gapped at .32 ) no error codes are showing up I am baffled. So i took it in to my chrysler dealership they looked at it and after charging me an hours labour $100.00 they told me to take my stage one out and put my old computer back in rrrrrrrrrrrrrrrrrr . anyway i am going to try that and see if it fixes the problem but I really really do not want to . Does :anyone have any suggestions.... i am deperate !!!! thanks to all who respond.....
Reply With Quote
  #2 (permalink)  
Old 17 Oct 2008, 07:06 pm
Cool Cruiser
 
Join Date: Sep 2004
Location: .
Posts: 271
Default Re: stage one srious bogging problems

Check for boost leaks! Look around turbo for lines that have blown off. Secure all lines with tie wraps as they will blow off, and one small line will cause loss of power. If you have a plastic manifold check the seams, if you have an aluminum manifold check the gasket areas. You can use soapy bubble leak detector, apply in the area you want to check and rev the engine a little, if there is a leak you see bubbles.
Reply With Quote
  #3 (permalink)  
Old 17 Oct 2008, 07:40 pm
Veteran Cruiser
 
Join Date: Mar 2003
Location: Oregon.
Posts: 3,521
Default Re: stage one srious bogging problems

Your dealer is a very poor one. I wouldn't use that one any more.

Do check for boost leaks. As was stated zip tie all vacuum lines and replace crappy factory hose clamps on the intercooler hoses with t bolt clamps.
__________________
\'05 Stone White SRT4

\'04 Graphite PT Automatic
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
stage one bogging when i floor it ??? murman40 Tech & Performance Forum 6 23 Sep 2008 12:49 am
Stage II for PT is here! skripo General Turbo Discussions 9 12 May 2008 10:11 pm
Stage 1 problems!!!!! ValAir Stage Turbo Kits 5 21 Sep 2005 10:21 pm
STAGE 1 PROBLEMS!!!! EDGAR TAMAYO Stage Turbo Kits 4 06 Apr 2004 02:25 am
Stage 2 info from SRT-4 site dtbrks Stage Turbo Kits 24 26 Nov 2003 05:24 pm


All times are GMT -5. The time now is 05:42 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors