PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Need help with engine whine and pop

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 06 Apr 2009, 07:48 pm
Fresh Cruiser
 
Join Date: Apr 2009
Posts: 6
Unhappy Need help with engine whine and pop

We have a 2003 turbo with auto tranny,

It just started a weird couple issues I believe must be related because they started together,
If you get on it, not hard just more than normal driving it will "pop" then with the hood open for inspection when it pops it sounds pretty much like a tinny high end backfire thru the intake, but I am partly guessing,

The other issue is a whine that sounds a lot like a winding up electric motor, but it's not, it's related in some way to engine RPM,

Both these issues come and go but seem to be getting worse so I had my wife park it and now she is forced to drive the vette,

The PT is auto tranny but with do this driving along or revving it up in park,
Otherwise it runs pretty well as far as I can tell.

Many thanks for any and all help,
Cheers,
P.

Last edited by The13bats; 06 Apr 2009 at 08:02 pm.
Reply With Quote
  #2 (permalink)  
Old 06 Apr 2009, 07:53 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Need help with engine whine and pop

Welcome.
Sounds like a vacuum leak to me.
Try posting on PTCrew - lotsa turbo gurus there.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #3 (permalink)  
Old 15 Apr 2009, 08:04 pm
Fresh Cruiser
 
Join Date: Apr 2009
Posts: 6
Default Re: Need help with engine whine and pop

Thanks for the tip on the other site but sadly no help there either,
Hard for me to believe that no one have experence with this problem I have but it seems to be a reall stumper,

Here is my last update on all I have tried so far,
Ok...update and please help me out on this one,

The new spark plugs and wires made no difference what so ever and neither did the new MAP sensor,

After taking the weekend off I learned the hard way two different aftermarket MAP sensor companies have the non-turbo MAP sensor listed as Turbo and these do NOT interchange,
To start with the plugs are different,


So I buy the correct part from my local Mopar dealer and did have hopes it would at least help,
I start the PT all is fine, I drive around the block a few times all seems well, I turn a corner and hear a couple "pops"
Then the whinnying sound is back again, I compare the sound to revving say a Dremel tool,

I fear it is the Turbo spinning up and the pop is the pop off valve, now keep in mind I have almost zero turbo experience, but I do have good knowledge of normal aspirated engines and these whinnying is nothing like I ever heard before, the "pop" is more or less the type pop one might hear back thru the intake for various reasons,

Is there a way I can at the very least rule out the turbo or drive a nail in the coffin it IS turbo related,

I really hate to pay the dealer 100.00 just to tell me what's wrong, yea, they apply that to the repair but I really can't afford huge repairs right now,

I am in Orlando Florida does anyone know of a good honest shop around my parts?

I am also open to other forums I could try posting this on,

Many thanks all!
Cheers,
P.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:14 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors