PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Check Engine Light On

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 13 May 2009, 10:33 pm
Fresh Cruiser
 
Join Date: May 2009
Posts: 5
Question Check Engine Light On

I have a 2005 PT cruiser with only 18000 miles on it. The check engine light came on the first time with 15000 miles on it and the service department replaced the cam sensor. The problem went away until this week. I had to have the car towed into the dealer as it lurched for lack of a better term when pressing the accelerator. The service department said it was the cam sensor again and told me I needed to have a fuel and air induction service done because that was causing the problem. I'm pretty sure that the induction services weren't really necessary at this point, but followed their advice. They did all that and the problem was still there. Then they determined that the crank sensor was shorting out the cam sensor so that was replaced. Two days later I'm having the same problem and the car will once again be towed into the Chrysler service department tomorrow. Has anyone had this type of problem? I would appreciate any advice anyone has on solving this problem. Thanks!!!
Reply With Quote
  #2 (permalink)  
Old 14 May 2009, 06:23 am
Regular Cruiser
 
Join Date: May 2008
Location: Washington State
Posts: 176
Default Re: Check Engine Light On

CAM Sensor and fuel injection service have nothing in common.

If you feel that you need to have the fuel system cleaned-purchase a can of Chevron Fuel Injector Cleaner and dump it into your tank. Fill up and go for a nice long trip. Run the tank to apporx 1/4 tank and refill. Your fuel system is now clean and your injectors are clear of any build up. Do this annually and you will have few if any dirty fuel system issues.

If you feel that your throttle boday is dirty--use SEAFOAM--available in most if not all auto parts stores--follow directions on label.
Reply With Quote
  #3 (permalink)  
Old 14 May 2009, 07:01 am
Fresh Cruiser
 
Join Date: May 2009
Posts: 5
Default Re: Check Engine Light On

Thanks. I did think the service department was trying to get more money out of me when they told me the fuel and air induction service could be causing the problem with the cam sensor. I just followed their recommendations. Unfortunately, the engine light is on and the car won't run so I have to take it back to them again today. They have replaced the cam and crank sensor, but the car is still doing the same thing...bucking or lurching when you press on the accelerator. Do you have any ideas of what could be wrong?
Reply With Quote
  #4 (permalink)  
Old 14 May 2009, 07:48 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: Check Engine Light On

Vicky,

Do you know how to pull the codes stored in the computer or did they tell you which codes were found?

Major causes of your problem could be a bad fuel injector or one of the plugs or wires malfunctioning. Lastly, you might have a loose or cut hose somewhere.

Last edited by CREWZIN; 14 May 2009 at 07:56 am.
Reply With Quote
  #5 (permalink)  
Old 14 May 2009, 10:20 am
Fresh Cruiser
 
Join Date: May 2009
Posts: 5
Default Re: Check Engine Light On

Thanks for the help. Another person in the forum suggested turning the car on and off again a few times and I tried that, but no codes showed up on mine. The car is currently at the Chrysler dealer so I'm waiting to see what they tell me today.
Reply With Quote
  #6 (permalink)  
Old 14 May 2009, 01:47 pm
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: Check Engine Light On

Not sure, but those sensors should have been covered by EPA warranty to at least 50,000 miles. Sounds like someone is throwing parts at a problem and crossing their fingers. You might try a reputable service center if this keeps causing you $$$$'s. Good Luck!!!! Codes would help us diagnose the problem.
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #7 (permalink)  
Old 14 May 2009, 08:16 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Check Engine Light On

Quote:
Originally Posted by vicky52 View Post
Thanks for the help. Another person in the forum suggested turning the car on and off again a few times and I tried that, but no codes showed up on mine. The car is currently at the Chrysler dealer so I'm waiting to see what they tell me today.
Did the word "done" appear? If not, you did it wrong.
Turn key to "on" - but do not start engine (not "start")
back one click to "off".
On
Off
On
codes may appear, followed by done, but you always get "done" - with or without codes.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #8 (permalink)  
Old 16 May 2009, 10:20 pm
Fresh Cruiser
 
Join Date: May 2009
Posts: 5
Default Re: Check Engine Light On

Thanks. I didn't turn the ignition all the way to start, but did do the on, off, on, off, on, off and nothing came up.

I should add that this problem started last October and at that time the code was 0340. The cam sensor was replaced at that time and the car only had 15,178 miles on it. Now the problem has reared its ugly head again and the car has 18,319 miles.

The original code was PO344 and both the cam and crank sensor was replaced last Monday. It ran for two days and the engine light came back on. Car went back to the service department last Thursday and this time they cleaned the connector at the pcm and the cam sensor. It ran great until this evening and once again the engine light is on and it is lurching or surging. Of course the service department is closed until Monday and I plan on taking it back in once again. Does anyone know what the mechanics should be doing to fix the problemor have any ideas what could be going on with the car?

I just don't know what to tell them. Well maybe I do, but I guess I shouldn't. Anyway any advice would be appreciated. Thanks!!!
Reply With Quote
  #9 (permalink)  
Old 21 May 2009, 08:40 pm
Fresh Cruiser
 
Join Date: May 2009
Posts: 5
Default Re: Check Engine Light On

Just wanted to add that my car has been at the service department all week and they have determined that my PCM needs to be replaced. I know that is covered under the extended warranty. I'm hoping to get the car back tomorrow and will let you know if the problem is solved. I did ask about the wiring harness and they said it was good. We'll see.......
Reply With Quote
  #10 (permalink)  
Old 23 May 2009, 01:14 am
Young Cruiser
 
Join Date: May 2009
Posts: 93
Default Re: Check Engine Light On

Quote:
Originally Posted by quicksilverdon View Post
Turn key to "on" - but do not start engine (not "start")
back one click to "off".
On
Off
On
codes may appear, followed by done, but you always get "done" - with or without codes.
Are you saying that this is the way to get a code to show up without plugging it into a computer? If so, where does this code appear?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Check Engine" idiot light on AGAIN tezz General Turbo Discussions 17 17 Sep 2015 11:54 am
Check Engine Light CHROMEDCRUISER General PT Cruiser Discussions 13 30 Apr 2012 04:49 pm
Check engine light, skipping ab1 Tech & Performance Forum 2 02 Aug 2008 11:13 pm
06 turbo check engine light 06SilverTurbo Tech & Performance Forum 23 21 May 2008 02:20 pm
Check engine oil light question AaronR General PT Cruiser Discussions 5 28 Aug 2004 03:18 am


All times are GMT -5. The time now is 10:46 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors