PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Back with another over-heating prob...

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 15 May 2009, 04:23 pm
Fresh Cruiser
 
Join Date: Jun 2008
Posts: 18
Default Back with another over-heating prob...

Back in August of last year, I had to replace the thermostat in my PT. Went for a little ride. First 10 or so miles, everything was fine. Ran a few miles more and noticed the temp gauge was showing hotter than normal. Few miles later, got just a little hotter and kept getting hotter, a little at a time, but didn't get into the red. I noticed that the temp would go down just a little when I hit the brakes. Temp sensor? Something easy and inexpensive?
Reply With Quote
  #2 (permalink)  
Old 15 May 2009, 05:38 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Back with another over-heating prob...

Not enough information. Are you running the A/C? Is the fan ON when the A/C is on even at idle and when you first start it up in the morning? Are you using any water? Is there hot air in the cabin if you switch the control over to heat? Hw is the overheating when you come to a stop and idle for a few minutes?

PT Overheating at idle
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.

Last edited by CREWZIN; 15 May 2009 at 05:42 pm.
Reply With Quote
  #3 (permalink)  
Old 24 May 2009, 03:56 pm
Fresh Cruiser
 
Join Date: Jun 2008
Posts: 18
Default Re: Back with another over-heating prob...

Yes, I did have the A/C on at the time. Tried to fill the water up when we got back home, but I wasn't able to put in much before it overflowed.


I have good heat, but that's when it was running normal temp. If that makes sense. Kinda gun-shy after thinking I actually fixed it, only to have it go bad a few months later. I haven't had it out much, only to Wal-Mart, which is about 5 miles from my place.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2002 PT Intermittent Starting Problems, Very Long, Goes Back 3 Years BeBeCroozer Tech & Performance Forum 21 11 Jul 2011 09:30 am
Bell crank Back order steelheep General PT Cruiser Discussions 0 02 Dec 2008 09:58 pm
FLOW BACK CATCH CAN littleblueGT Turbo Performance 4 03 Sep 2006 02:18 pm
better put your back seats back Ctown General PT Cruiser Discussions 0 26 Feb 2006 11:21 pm
Back power window switches not working lumofny Tech & Performance Forum 3 16 Jan 2005 10:00 pm


All times are GMT -5. The time now is 09:29 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors