PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
06 cruiser idle/fan problems

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 24 May 2009, 10:06 am
TFD TFD is offline
Fresh Cruiser
 
Join Date: May 2009
Posts: 10
Default 06 cruiser idle/fan problems

Hello,
Ive read through here and other sites and see this is a pretty common problem. My GFs cruiser has the rough idle problem when were sitting at a light or in park. You can hear the compressor come on when it does it. Also the more you drive it the weaker the ac blows and the warmer the air that comes out. I went to check the fan like I see people talk about and its not moving at all. Doesn't matter if its hot, cold or the AC is on or off. This car has 57k miles and its a 4 cyl non turbo car.

-So where should I start and what should I check?
-Anyone have a link to buy the radiator fan motor cheap?
-best way to replace the fan motor? Do I take the shroud off or what?
-AC probably needs coolant since I dont think its ever been charged and its only semi cool at stratup. Do I have to add oil separately? any recommendations on what brand to get? I have autozone and oriellys near me

thanks!

Last edited by TFD; 24 May 2009 at 10:09 am.
Reply With Quote
  #2 (permalink)  
Old 24 May 2009, 11:01 am
TFD TFD is offline
Fresh Cruiser
 
Join Date: May 2009
Posts: 10
Default Re: 06 cruiser idle/fan problems

checked the fuse marked for radiator fan, 50a it was fine. Where are these relays I keep reading about and how can I check them?


also where is the port to charge the AC? I see one on top, its the thin tube and I assume the high side, that thicker line has no port to charge with coolant? Is it underneath?


thanks
Reply With Quote
  #3 (permalink)  
Old 24 May 2009, 01:12 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: 06 cruiser idle/fan problems

Quote:
Originally Posted by TFD View Post
Hello,

-So where should I start and what should I check?
-Anyone have a link to buy the radiator fan motor cheap?
-best way to replace the fan motor? Do I take the shroud off or what?
-AC probably needs coolant since I dont think its ever been charged and its only semi cool at strat up. Do I have to add oil separately? any recommendations on what brand to get? I have autozone and oriellys near me
thanks!
Some things change on the 06-08 cruisers so not all answer pertain if you have one of the newer ones.

The high and low relays for the fans are in the fuse box in the engine compartment. They are marked. You can't swap the high speed but the low speed relay can be swapped for the horn relay. If you swap them and the horn works, the relay for the fan is working.

To double check, you need to get under the car, find the one set of wires that go to the fan motor and find the electrical connection. Pull that apart and add a ground and hot wire to the terminals and the fan should start turning, if not, the motor is burned out.

The fan motor should be able to be picked up at AutoZone, or eBay has the whole motor and fan for about $100. You still have to take everything apart even if you can change only the motor.

The shroud, front grill, top radiator support, upper radiator hose and front brace bar across the front of the radiator all have to come off as the radiator has to lean forward and the shroud and fan lifted up and out.

Personally I'd take it to a professional shop to refill the A/C. It has to be balanced correctly (High and low side) for the A/C operation to work well. No extra oil is needed unless the whole system has been discharged.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #4 (permalink)  
Old 24 May 2009, 02:06 pm
TFD TFD is offline
Fresh Cruiser
 
Join Date: May 2009
Posts: 10
Default Re: 06 cruiser idle/fan problems

Ok great. Thanks for the reply crewzin! I'll post back with what I find.
Reply With Quote
  #5 (permalink)  
Old 26 May 2009, 06:24 pm
TFD TFD is offline
Fresh Cruiser
 
Join Date: May 2009
Posts: 10
Default Re: 06 cruiser idle/fan problems

Quote:
Originally Posted by CREWZIN View Post
Some things change on the 06-08 cruisers so not all answer pertain if you have one of the newer ones.

The high and low relays for the fans are in the fuse box in the engine compartment. They are marked. You can't swap the high speed but the low speed relay can be swapped for the horn relay. If you swap them and the horn works, the relay for the fan is working.

To double check, you need to get under the car, find the one set of wires that go to the fan motor and find the electrical connection. Pull that apart and add a ground and hot wire to the terminals and the fan should start turning, if not, the motor is burned out.

The fan motor should be able to be picked up at AutoZone, or eBay has the whole motor and fan for about $100. You still have to take everything apart even if you can change only the motor.

The shroud, front grill, top radiator support, upper radiator hose and front brace bar across the front of the radiator all have to come off as the radiator has to lean forward and the shroud and fan lifted up and out.

Personally I'd take it to a professional shop to refill the A/C. It has to be balanced correctly (High and low side) for the A/C operation to work well. No extra oil is needed unless the whole system has been discharged.
on the relays. Are they the ones with the glass tops? I was looking for ther older tyrp relays and I dont see any. The fuses are obvious. The diagram on the cover doesnt list relays and it doesnt list the horn. Im guessing its in one of the clusters for instruments or something? The only thing I see is the "rad fan" with a 50 on the top (the only 50 in the box, there are several 40s so I dont want to switch something before I know what Im doing). Looking through the glass the 50 looks intact but I dont know if that is a relay and if the glass on top is meant to show if its burned out similar to a fuse. Any direction here would be great.

On the fan. Before it wasnt working at all. I hot wired it as directed and it has 3 wires. high, low and ground I guess. The fan comes on for one but not the other when I add power. then when I plugged it back in and started the car the fan was working but it was 92 today and the engine was warm so I dont know if it was the high speed or low?

So where am I at? I'll start it cold in the morning with the ac on and see if the low speed fan is working I guess?


Thanks in advance for any help
Reply With Quote
  #6 (permalink)  
Old 26 May 2009, 07:45 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: 06 cruiser idle/fan problems

As I said, things chnaged in the 06-08 cruiser and I'm not familiar with the fuse/relay set-up on the newer ones.

Do your cold start with the A/C and see if the fan comes on. The high speed makes a heck of a racket when on, the low speed is a nice quiet sound.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.

Last edited by CREWZIN; 26 May 2009 at 07:48 pm.
Reply With Quote
  #7 (permalink)  
Old 08 Jul 2009, 02:45 am
Fresh Cruiser
 
Join Date: Jul 2009
Posts: 4
Default Re: 06 cruiser idle/fan problems

On an 06 Cruiser there is not Relays for the AC in the PDC the fan relay is on the shroud, The A/C Clutch has no relay they went with a computer mod to control it.
Reply With Quote
  #8 (permalink)  
Old 10 Jul 2009, 06:06 am
TFD TFD is offline
Fresh Cruiser
 
Join Date: May 2009
Posts: 10
Default Re: 06 cruiser idle/fan problems

Quote:
Originally Posted by misterfixxit69 View Post
On an 06 Cruiser there is not Relays for the AC in the PDC the fan relay is on the shroud, The A/C Clutch has no relay they went with a computer mod to control it.
what is a PDC? the fan works on high speed but not low
Reply With Quote
  #9 (permalink)  
Old 10 Jul 2009, 06:17 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: 06 cruiser idle/fan problems

Quote:
Originally Posted by TFD View Post
what is a PDC? the fan works on high speed but not low

That's the Power Distribution Center otherwise known as the fuse box. Did you find the relays on the shroud? You can try replacing the low speed if there's 2 of them (high and low speed fan) but again I'm not familiar with the newer models. The 01-05 cruisers had two separate relays. If there's only one on yours it will work both fan speeds and you said your high speed is working so the relay should be good. It sounds like part of the fan motor (low speed) is burnt out. A pretty common problem with the PT.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #10 (permalink)  
Old 10 Jul 2009, 07:19 am
TFD TFD is offline
Fresh Cruiser
 
Join Date: May 2009
Posts: 10
Default Re: 06 cruiser idle/fan problems

Quote:
Originally Posted by CREWZIN View Post
That's the Power Distribution Center otherwise known as the fuse box. Did you find the relays on the shroud? You can try replacing the low speed if there's 2 of them (high and low speed fan) but again I'm not familiar with the newer models. The 01-05 cruisers had two separate relays. If there's only one on yours it will work both fan speeds and you said your high speed is working so the relay should be good. It sounds like part of the fan motor (low speed) is burnt out. A pretty common problem with the PT.
I havent had a chance to look yet but I figure its the fan and I ve been putting off the replacement lol. Thanks for the help
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 Chrysler PT Dream Cruiser Series 3 skylight PT Cruiser News and Rumors 10 18 Jun 2009 08:57 am
Exterior Mod List slayerdarkcross Exterior Accessories Forum 8 22 Jul 2008 03:54 pm
2006 PT Street Cruiser Route 66 Edition skylight PT Cruiser News and Rumors 35 17 Nov 2007 02:39 pm
'02 Cruiser with lots of problems :( slpknt2886 Tech & Performance Forum 4 07 Aug 2007 02:17 pm
New 2005 Convertible PT Dream Cruiser skylight PT Cruiser News and Rumors 4 11 Jan 2005 06:12 pm


All times are GMT -5. The time now is 02:07 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors