PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Melted fuse scares me HELP!

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 24 May 2009, 03:42 pm
Young Cruiser
 
Join Date: Apr 2009
Posts: 58
Default Melted fuse scares me HELP!

Hi long time lurker first time poster. I LOVE this site soo helpfull in every single way. I own a 2001 cruiser 80k miles i love the my cruiser and since i just bought it 2 months ago the right low beam head lamp blew out. Or so i thought it did. It just happened a week ago it just didnt click on so i thought no big deal ill just install a new bulb well it didnt work. So i thought ok maybe its a fuse so i check the fuse panel in the card and immediately am horrified by the site of a MELTED 25 amp fuse in the #19 position. I donot have an owners manual but was lucky enough to find a wonderfull chilton type manual from this site. I still cannot find what the fuse is responsible for powering. Any help on what might cause this? And any reason why the low beam only side of the light would jsut suddenly stop working fuse issues? Battery problems HELLLLLLLP!!! Many thanks in advance for this great site also i would be lost without it!

EDIT Ok nm on that turn the cover over to the fuse panel and waddayaknow right HL #19 10amp fuse. Someone shoved a 25 in there and called it a day. Thanks anyways live and learn right haha!

Last edited by invidious; 24 May 2009 at 04:24 pm.
Reply With Quote
  #2 (permalink)  
Old 24 May 2009, 05:08 pm
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: Melted fuse scares me HELP!

invidious, Welcome to the Forum!!!

Glad you found the problem and reported same, many don't. Thanks!!!!
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ignition Off Draw (IOD) Fuse Effects and Replacement Hints ObiMatt87 Tech & Performance Forum 25 30 Apr 2017 08:33 pm
"no fuse" light came on!!! hermtm2 General PT Cruiser Discussions 21 30 May 2014 01:15 am
no Fuse problem and not iod fuse ptcarter Tech & Performance Forum 24 09 Jul 2013 03:21 am
Fog Light Fuse SuperTroy Exterior Accessories Forum 1 17 Aug 2007 06:50 am
Autometer gauges PTGT Redman Turbo Performance 12 23 Jul 2003 09:08 am


All times are GMT -5. The time now is 10:28 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors