PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
pt blowing fuse to shut off engine ?

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 17 Jun 2009, 06:21 pm
Fresh Cruiser
 
Join Date: Jun 2009
Posts: 2
Default pt blowing fuse to shut off engine ?

Hi I am a new user here , i Have a 2001 pt LE and once and a while i am blowing the 20a fuse that shuts off the engine , but soon as i change the fuse its good for awhile again like 2 -3 days ? has anybody eles had this problem or if they know what it is ? Help !
Reply With Quote
  #2 (permalink)  
Old 17 Jun 2009, 08:07 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: pt blowing fuse to shut off engine ?

Welcome.
Which fuse? Under hood? What is it labeled as? Look for what else is on that circuit.
Haven't read of anything like your problem.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #3 (permalink)  
Old 23 Jun 2009, 10:32 pm
Fresh Cruiser
 
Join Date: Jun 2009
Posts: 2
Default Re: pt blowing fuse to shut off engine ?

HI sorry never got back to you right away , thanks for your reply , its never blew again for some reason ? so now i cant find the problem , ? I drove for about an hour in it , then went for a long drive , again no problem , but i checked the engine and only found a vacume line off ? dont know if that made somthing over heat , but everything is good for now willl keep in touch if problem arrises again once again thank you for your help , hope i can use you in the future ! Murray
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ignition Off Draw (IOD) Fuse Effects and Replacement Hints ObiMatt87 Tech & Performance Forum 25 30 Apr 2017 08:33 pm
fog lamp fuse blowing smilanatu Tech & Performance Forum 13 19 Jul 2009 11:07 am
HEATED SEATS (FUSE KEEPS BLOWING) BIGZ General PT Cruiser Discussions 9 16 Feb 2009 10:39 pm
The noise engine makes when you shut off? stirfry Tech & Performance Forum 7 26 Apr 2004 06:50 pm
Autometer gauges PTGT Redman Turbo Performance 12 23 Jul 2003 09:08 am


All times are GMT -5. The time now is 05:55 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors