PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
EVIC frozen?

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 02 Jul 2009, 06:18 am
Travis2k7's Avatar
Cool Cruiser
 
Join Date: May 2009
Location: Seattle, WA
Posts: 406
Default EVIC frozen?

The strangest thing happened last night.

My EVIC screen froze and wouldn't take any input from the push button... it was locked at 89 degrees and the radio station display stayed the same even when I changed to another....



When I turned off the car all the internal displays shut down except for the EVIC. It stayed illuminated for a good 3 minutes before finally shutting down.

I then cranked the car and it worked fine, and it worked fine this morning on the way to work.

Just a glitch or am I about to have a EVIC failure?

Edit: Guess it was a glitch Been fine for the last few days.
__________________
2006 Limited, Auto, 100k miles

Last edited by Travis2k7; 06 Jul 2009 at 10:13 am.
Reply With Quote
  #2 (permalink)  
Old 22 Mar 2011, 10:31 am
Fresh Cruiser
 
Join Date: Jul 2007
Location: Middle Village, NY
Posts: 27
Default Re: EVIC frozen?

I usually do all city driving, short trips, but this past weekend I drove 200 miles and returned.

While on highway driving, I switched EVIC to indicate the rough fuel consumption rate (MPG). At the end of the trip the push button would not switch displays, it was just stuck here. I shut the car, removed key, and it still displayed the same. I even did gauge/lamp and code test procedures, and the EVIC was still stuck.

I let the car sit a couple hours and went back to the it. Opening the door, I saw that the "door ajar" symbol now appeared normally, and all was normal since then. I don't know why it got stuck, or what made it restore other than luck. I know some EVIC readings cannot be accessed unless car is in PARK.

I was tempted to briefly disconnect battery cable as I've seen some suggest to fix problems, but didn't want to mess anything else up.
Reply With Quote
  #3 (permalink)  
Old 22 Mar 2011, 02:30 pm
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: EVIC frozen?

Quote:
Originally Posted by alvin201 View Post
I usually do all city driving, short trips, but this past weekend I drove 200 miles and returned.

While on highway driving, I switched EVIC to indicate the rough fuel consumption rate (MPG). At the end of the trip the push button would not switch displays, it was just stuck here. I shut the car, removed key, and it still displayed the same. I even did gauge/lamp and code test procedures, and the EVIC was still stuck.

I let the car sit a couple hours and went back to the it. Opening the door, I saw that the "door ajar" symbol now appeared normally, and all was normal since then. I don't know why it got stuck, or what made it restore other than luck. I know some EVIC readings cannot be accessed unless car is in PARK.

I was tempted to briefly disconnect battery cable as I've seen some suggest to fix problems, but didn't want to mess anything else up.
------------------------------------------------
By disconnecting the battery for 5-10 will not affect any of your settings. It will allow the computer to readjust to your driving habits, which could be a good thing.

The EVIC mileage readout is a VERY rough estimate of your mileage. Maybe you should disconnect your cables any way.
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #4 (permalink)  
Old 22 Mar 2011, 02:57 pm
Fresh Cruiser
 
Join Date: Jul 2007
Location: Middle Village, NY
Posts: 27
Default Re: EVIC frozen?

Thanks, I realize the reading is a very very rough estimate, was just curious to use it as a guide to try and improve my driving habits (60, vs 65, vs 67mph; cruise control vs foot on the gas, etc); and thanks for advice on briefly disconnecting battery doing no harm.
__________________
2007 Touring, NA, automatic, Marine Blue
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I tell if my 06 Cruiser can have the EVIC installed? mecha_maniac10 General PT Cruiser Discussions 3 11 Jun 2009 07:44 am
Frozen Window Solution SteveANJ PT Cruiser Convertible Forum 3 14 Mar 2008 06:18 pm
Dead nonstarting frozen PT GT careyk Canada PT Forum 5 09 Feb 2008 03:19 pm
does PT has hidden EVIC menus just as 300c do? avatar General PT Cruiser Discussions 0 04 Sep 2007 11:45 pm
Frozen Windshield Washer Nozzles pavplus General PT Cruiser Discussions 4 15 Jan 2005 02:29 pm


All times are GMT -5. The time now is 12:30 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors