PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
'04 with p0016 and p0344 codes-PLEASE help

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 10 Jul 2009, 07:52 am
Fresh Cruiser
 
Join Date: Jun 2009
Location: West Central Florida, USA
Posts: 4
Unhappy '04 with p0016 and p0344 codes-PLEASE help

I have an '04 PT with about 73,000 miles on it. My check engine light came on a few weeks ago when the car started stuttering while I was accelerating and I took it to a local repair shop to have the codes read (I didn't know about the key trick to check the codes yet). They told me it was the P0344 code for the Cam Sensor that needed to be replaced and quoted me around $200 for parts and labor.

I had a friend who works for a dealership buy me the Mopar part and my husband replaced it (with the help of some step by step posts I found here)but he didn't clear the codes. I took it to an auto parts store and they cleared the codes with a small, handheld computer type thing that they plugged into my fuse box and said that perhaps the car wasn't recognizing that it had a new part since it hadn't been cleared.

I drove a few miles down the road and it seemed that the car was now seeing it had a new part and seemed to be driving fine. A few minutes later the engine light came back on and started acting up like it had before. They reset it again and it popped back on immediately after I started it up this time.

The stutter in the acceleration happens mostly when I get up to about 35-40 mph and occasionally happens a little higher or lower. During all of this I have also had the car stall on me when I am in reverse pulling out of a parking spot, turning my wheel to the left.

I have been lucky enough to be able to drive my husbands truck during some of this but I am still driving the PT when I have to. This morning a new code came up when I did the key test, P0016, in addition to the P0344 that had all ready been there. From reading in the posts I see that this is a "crank & cam out of sync" code. Also from reading the posts, I see that when both of these codes are present it could mean more than just the cam sensor.

Any insight as to what to do and how to take care of it would be greatly appreciated. I don't really have a dealership/mechanic here that I know/trust so I am at the mercy of word of mouth (and my meager earnings) unfortuately.

On a side note, a month before this happened the car stalled at a traffic light and when I tried to start it I got power to all of my lights/dash/radio but it wouldn't turn over, wouldn't even click. I waited a few minutes and it started again so I drove to a local mechanic. They thought it was the computer so I had it towed to a dealership (this is one of the only parts that is still under warranty). They finally found out that it wasn't the computer or the plug/wires, it was a blown fuse. A simple $1 part cost me that plus diagnostic labor. Don't know if this plays into the lovely, new problem i'm having...
Reply With Quote
  #2 (permalink)  
Old 10 Jul 2009, 09:17 am
Travis2k7's Avatar
Cool Cruiser
 
Join Date: May 2009
Location: Seattle, WA
Posts: 406
Default Re: '04 with p0016 and p0344 codes-PLEASE help

Quote:
Originally Posted by tsnapp52 View Post
This morning a new code came up when I did the key test, P0016, in addition to the P0344 that had all ready been there. From reading in the posts I see that this is a "crank & cam out of sync" code. Also from reading the posts, I see that when both of these codes are present it could mean more than just the cam sensor.

Any insight as to what to do and how to take care of it would be greatly appreciated. I don't really have a dealership/mechanic here that I know/trust so I am at the mercy of word of mouth (and my meager earnings) unfortuately.
I'm no mechanic but you could be looking at timing belt issues as well. 73,000 miles seems a little early for that but it's possible based on what I've read around here previously.

Unfortunately there is no cheap fix for changing the timing belt. It's a 5-7 hour job and the smart thing to do is change the water pump, tensioner, serpentine and alternator belts at the same time since it's all right there.
__________________
2006 Limited, Auto, 100k miles

Last edited by Travis2k7; 10 Jul 2009 at 09:19 am.
Reply With Quote
  #3 (permalink)  
Old 10 Jul 2009, 10:32 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: '04 with p0016 and p0344 codes-PLEASE help

I'd have to guess at the timing belt also. The first signs of the belt about to go south is stretching. When it does that, things aren't lined up properly and the cam and crank sensors notice that something's wrong.

Try and ask around, neighbors, car hangouts, people at work and find someone that you can trust to properly diagnose your problem.
Reply With Quote
  #4 (permalink)  
Old 13 Jul 2009, 01:27 pm
Fresh Cruiser
 
Join Date: Jun 2009
Location: West Central Florida, USA
Posts: 4
Default Re: '04 with p0016 and p0344 codes-PLEASE help

Thanks for your replies! I actually quoted my mileage wrong, it's only 72,050 which seemed a little early to me for the timing belt to be the issue but from the posts I'm reading sounds like it might be.

Would your advice be to take it to the dealership, to a chain garage, or a privately run garage?
Reply With Quote
  #5 (permalink)  
Old 13 Jul 2009, 01:41 pm
Travis2k7's Avatar
Cool Cruiser
 
Join Date: May 2009
Location: Seattle, WA
Posts: 406
Default Re: '04 with p0016 and p0344 codes-PLEASE help

Quote:
Originally Posted by tsnapp52 View Post
Thanks for your replies! I actually quoted my mileage wrong, it's only 72,050 which seemed a little early to me for the timing belt to be the issue but from the posts I'm reading sounds like it might be.

Would your advice be to take it to the dealership, to a chain garage, or a privately run garage?
My advice would be to take it to a mechanic you can trust, be it a stealership or elsewhere.

I've seen posts of people getting the parts for $250ish. The kicker is the labor.

$1000 for the job (parts included?) seems to be the ballpark figure from what I've seen posted here previously.
__________________
2006 Limited, Auto, 100k miles
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:45 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors