PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Will not go past 40mph

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 16 Jul 2009, 01:21 pm
Fresh Cruiser
 
Join Date: Jul 2009
Location: Prince Frederick, MD
Posts: 9
Default Will not go past 40mph

Hello all.

I put the cruise back together and took it for a spin. No codes showed up after 2 trips and it still did not exceed 40 mph. When I accelerate the tachometer does not go above 2000 rpm if it even goes up at all. I was going up the driveway, had it floored and the vehicle did not respond. It only cut out on me once, I waited, started it up again and continued home.
I have metered most of the PCM with 8w-30 and 8W31 information. So far to no avail.
If anyone else has any insight to this I appreciate it. I would to just throw parts at it to make it work, it basically defeats the troubleshooting process.
Reply With Quote
  #2 (permalink)  
Old 16 Jul 2009, 01:51 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: Will not go past 40mph

I tried doing an extensive search for your problem and came up almost empty. The only thing I found was from the Dodge truck forum, that one owner had that code (p0884 from your first post) and it turned out to be a weak battery. Don't think that will help you, but check to see if yours is putting out the correct voltage. Sounds like yours is in a "limp" mode which is what happens when the computer finds a fault that could get worse and doesn't want you to do any more harm by going too fast so it limits your speed.
Reply With Quote
  #3 (permalink)  
Old 16 Jul 2009, 02:05 pm
Fresh Cruiser
 
Join Date: Jul 2009
Location: Prince Frederick, MD
Posts: 9
Default Re: Will not go past 40mph

Thank you, I will meter the battery and if necessary I will put a new on in. The current one might be 3 years old, I cannot remember and it is cheaper than the PCM. The main thing that kept throwing me off was no "limp" mode code. Maybe the Solus scanner could not interpret it, I will find out tonight. Thank you for your help. I will repost the results tomorrow to let you know.
Reply With Quote
  #4 (permalink)  
Old 17 Jul 2009, 09:39 pm
Fresh Cruiser
 
Join Date: Jul 2009
Location: Prince Frederick, MD
Posts: 9
Default Re: Will not go past 40mph

Hooked everything back up and installed a new battery. Got it moving down the driveway (1500ft) turned onto the main road and it still did not go past 20mph. the engine shutdown as I was going up a steep hill. (trip one I guess). Coming back to the house I put it in neutral and cycled the key to the off position. This was about 5 seconds. Not much traffic goes down the road so it was safe. Cycled key on/run (Trip 2). Still did go above 20 mph. Repeated neutral/cycle trick once I hit the driveway but did not attempt to exceed 20 mph, fear off sudden engagement and smashing into a tree. Parked, cycled the PRNDL lever leaving it in each gear for 1 minute, cycled to park, let it idle for 5 minutes, no codes, turned it off and went inside to make a few calls and repost my results.
End result no dice on new battery. Someone mentioned timing belt, but honestly do not see the relationship between gear shifting and cam/crank position.
Thanks again you all for helping me. I will continue on with this endeavor.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wont rev past 2500 HELP!! CRFDAD Tech & Performance Forum 37 12 Jun 2009 10:55 am
Past Chrysler Brand Anthem skylight PT Cruiser Videos 0 11 Nov 2007 06:17 pm
2 car shows this past weekend CREWZIN General PT Cruiser Discussions 1 07 Mar 2005 11:08 pm
Engine going past redline. PTucker Tech & Performance Forum 10 06 Nov 2003 12:42 am


All times are GMT -5. The time now is 11:28 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors