PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Error code P0340 ADVICE???

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 16 Aug 2009, 09:09 pm
mjb457's Avatar
Fanatic Cruiser
 
Join Date: Oct 2005
Location: Bucks County,PA. USA
Posts: 955
Default Error code P0340 ADVICE???

OK Ive posted & read confusing info on this code-my check engine lite came on last week. I thru site got dash to show the code P0340-(cam sensor circuit.....( I disconnecte NEG battery-retaped wire to cam sensor-(also changed gas cap-PT is 03 with 72K)lite went out for 200 miles but came back on...... changing sensor seems simple but will that fix it? Or does it need tobe flashed?? HELP thanks MJB
Reply With Quote
  #2 (permalink)  
Old 17 Aug 2009, 04:38 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Error code P0340 ADVICE???

The camshaft sensor is easy and the computer doesn't need to be flashed. Before changing it, check all the wiring as best you cn from sensor all the way round to the back of the engine. A couple of us (including me) have had the wiring harness burnt or torn that caused the same error.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 17 Aug 2009, 02:59 pm
mjb457's Avatar
Fanatic Cruiser
 
Join Date: Oct 2005
Location: Bucks County,PA. USA
Posts: 955
Default Re: Error code P0340 ADVICE???

Crewzin again thankyou- I did check wire last time & gain rechecked it,,, it does have a hard plastic protector over it--- I retapped it near sensor--- the lite came on again- I reset computer by disconnecting NEG terminal-its out-- what Im trying to determine does this code say bad wire? Or bad sensor? I can get asensor for $50.00+ at dealer-would you just change it? I dont want to just waste monet though & not fix issue? That is the advice I need,thanks MJB
Reply With Quote
  #4 (permalink)  
Old 17 Aug 2009, 03:05 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Error code P0340 ADVICE???

Would I get it? .......After my P0340 left me stranded in the middle of highway 95 at 11pm in South Carolina, YES, but that doesn't mean you should. Your call.

You already did, but make sure you stick with the sensor from Chrysler. Others have failed.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #5 (permalink)  
Old 17 Aug 2009, 04:59 pm
mjb457's Avatar
Fanatic Cruiser
 
Join Date: Oct 2005
Location: Bucks County,PA. USA
Posts: 955
Default Re: Error code P0340 ADVICE???

OK CREWZIN: Im getting sensor from dealer tommorrow-installing it WED- they said (dealer)I need gasket also?-any special sealant for gasket or preparation-again many thanks ( I quess a cheap $50.00 safty net) MJB
Reply With Quote
  #6 (permalink)  
Old 17 Aug 2009, 07:17 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Error code P0340 ADVICE???

Neither the Chilton nor Haynes manual mention a gasket on the camshaft sensor for the 01-03 PT's. If yours is newer they might have added a gasket in the later years. If your kit comes with a new "target magnet" it says to make sure the dowels in the magnet are lined up with locating holes at the end of the camshaft and to tighten the sensor down to a torque of 115 in-lbs. The magnet comes off with a screw n the middle and that magnet retaining screw needs a torque of 32 in-lbs.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #7 (permalink)  
Old 19 Aug 2009, 07:57 pm
mjb457's Avatar
Fanatic Cruiser
 
Join Date: Oct 2005
Location: Bucks County,PA. USA
Posts: 955
Default Re: Error code P0340 ADVICE???

Crewzin thanks for advice: I scheduled for service at local dealer-(my origional purchase dealer closed last year) anyway I called Chrysler before going to see if there was a flash or recall- they took all info and gave me a ref#( the actually were very nice) I mentioned this at the dealer-bottem line dealer replaced boththe cam & crank sensors(the tech stated that they be replaced with code P0340 in pairs-he also checked my PCM for all updates( I paid just labor) which was less than $100.00** I HAD A $50.00 coupon introducing me to this dealer-(Chrysler warranted parts) YIPPEE MJB
Reply With Quote
  #8 (permalink)  
Old 19 Aug 2009, 08:02 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Error code P0340 ADVICE???

Not bad. Looks like you found a good dealer. Still, replacing both sensors is just covering there tails and throwing more parts at it than needed. Easy way out, replace everything. Glad it's running OK.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #9 (permalink)  
Old 20 Aug 2009, 08:24 pm
mjb457's Avatar
Fanatic Cruiser
 
Join Date: Oct 2005
Location: Bucks County,PA. USA
Posts: 955
Default Re: Error code P0340 ADVICE???

Seems to be running smoother..is that possible? thanks MJB
Reply With Quote
  #10 (permalink)  
Old 20 Aug 2009, 08:40 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Error code P0340 ADVICE???

Quote:
Originally Posted by mjb457 View Post
Seems to be running smoother..is that possible? thanks MJB
Sure. If the sensor was about to fail it would have sent erratic signals to the computer, and you were getting code so something was wrong.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
03 PT with p0340 and p0344 need help. sufe70 Tech & Performance Forum 25 22 Aug 2016 02:49 pm
Help... P0340 and electrical short somewhere (need correct PCM diagram for 2.4 liter) Munkeyboy Tech & Performance Forum 1 20 Apr 2009 02:26 pm
Need some advice !!!! blarneyny PT Cruiser Convertible Forum 0 31 Jul 2005 03:31 am
Advice on Bridgestone Potenza tires, please stargazer Turbo Wheels/Suspension/Handling 20 29 Oct 2004 01:46 am
Advice On Selling... Cruizin2k General PT Cruiser Discussions 12 02 Jun 2004 01:07 pm


All times are GMT -5. The time now is 02:57 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors