PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Blinkers and Hazards not working

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 03 Sep 2009, 06:10 pm
Fresh Cruiser
 
Join Date: Sep 2009
Posts: 1
Default Blinkers and Hazards not working

Help! I have a 2006 PT Cruiser Touring edition with roughly 50k miles on it.

All of my blinkers and hazards are out. They were working fine this morning but now the internal signal is blinking quickly but nothing is happening outside.

The headlights seem to work just fine and none of the bulbs or fuses look like they have exploded.

I read that it could be the multifunction switch? Does anyone have any idea of what the problem could be or how to fix it? I commute every day so I can't really leave it at the shop to be fixed/have it not working!

Any help or suggestions would be greatly appreciated.

Thanks!
Reply With Quote
  #2 (permalink)  
Old 03 Sep 2009, 08:55 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Blinkers and Hazards not working

Welcome.
Sure sounds like the multifunction switch...
I didn't think the hazard lights went thru the MF switch... They're the "button" on top of steering column.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:18 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors