PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
HELP!!!!!

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 09 Sep 2009, 12:40 pm
Fresh Cruiser
 
Join Date: Sep 2009
Posts: 5
Default HELP!!!!!

HELP!!!!!!! i have a 2004 pt cruiser and it just died on me. i was driving down the road and it just quit, i lost all power stearing and everything else but still had power to radio lights windows and locks. is it the alternator, the starter, the battery or what???? thanks for the help!!!!


PTGRL2009
Reply With Quote
  #2 (permalink)  
Old 09 Sep 2009, 02:05 pm
Regular Cruiser
 
Join Date: Sep 2009
Location: Michigan
Posts: 135
Default Re: HELP!!!!!

We need more info please.
What does it do now when you try to start it, crank fast, slow, or not at all?
Any lights on the dash before it stopped?
Any smells or smoke (insert you own joke here) from the car?
Reply With Quote
  #3 (permalink)  
Old 09 Sep 2009, 02:34 pm
Fresh Cruiser
 
Join Date: Sep 2009
Posts: 5
Default Re: HELP!!!!!

It does nothing at all dash lights radio and windows still work but it doesnt turn over at all or sound like its trying no noise what so ever thank you for replying

No funny smells or sounds was running fine and no lights came on before it died
Reply With Quote
  #4 (permalink)  
Old 09 Sep 2009, 02:57 pm
Regular Cruiser
 
Join Date: Mar 2009
Posts: 140
Default Re: HELP!!!!!

Quote:
Originally Posted by ptgrl2009 View Post
It does nothing at all dash lights radio and windows still work but it doesnt turn over at all or sound like its trying no noise what so ever thank you for replying

No funny smells or sounds was running fine and no lights came on before it died
How old is the battery? The OEM battery should have been replaced by now, lucky to get 3 years out of them.

A jumb start might be worth trying.

Reply With Quote
  #5 (permalink)  
Old 09 Sep 2009, 03:04 pm
Fresh Cruiser
 
Join Date: Sep 2009
Posts: 5
Default Re: HELP!!!!!

The battery is a year old and there is some corrosion on the cables to the battery i have tried a jump start but the aaa man used only the jump start attachment instead of hooking up to the battery. thank you so much for the help i can use all that i can get
Reply With Quote
  #6 (permalink)  
Old 09 Sep 2009, 03:06 pm
Regular Cruiser
 
Join Date: Mar 2009
Posts: 140
Default Re: HELP!!!!!

Quote:
Originally Posted by ptgrl2009 View Post
The battery is a year old and there is some corrosion on the cables to the battery i have tried a jump start but the aaa man used only the jump start attachment instead of hooking up to the battery. thank you so much for the help i can use all that i can get
Remove cables from battery and clean the terninals - baking soda and water works good. Use dielectric grease or those anti corrosion felt washers for the install.

Have the battery tested at any auto parts store or Les Schwab tire store etc.


Last edited by lmmegt; 09 Sep 2009 at 03:10 pm.
Reply With Quote
  #7 (permalink)  
Old 09 Sep 2009, 03:11 pm
Fresh Cruiser
 
Join Date: Sep 2009
Posts: 5
Default Re: HELP!!!!!

if its not the battery what else could it possibly be? thanks for the help
Reply With Quote
  #8 (permalink)  
Old 09 Sep 2009, 03:13 pm
Regular Cruiser
 
Join Date: Mar 2009
Posts: 140
Default Re: HELP!!!!!

Quote:
Originally Posted by ptgrl2009 View Post
if its not the battery what else could it possibly be? thanks for the help


Battery cable connections alone can play havock. Time for a mechanic to look at it if checking and cleaning cables and battery doesn't bring her to life.



12 volts won't shock you - but doing things wrongs could short out cables and cause the battery to explode.

I suggest getting experienced help.


Last edited by lmmegt; 09 Sep 2009 at 03:55 pm.
Reply With Quote
  #9 (permalink)  
Old 09 Sep 2009, 03:52 pm
Senior Cruiser
 
Join Date: Jan 2008
Location: I live in Edmonton AB Canada
Posts: 1,643
Default Re: HELP!!!!!

I guess its going to the shop and the money will be leaving your wallet just like me
__________________
PT Cruiser Inferno Red GT Cruiser. 5Spd 215HO HP 17" Chrome wheels, Chrome gas cap, door spears, door handle cups, door buttons,door lock pins, vent covers,rear spoiler,rear painted mudflaps,, chrome/carbon fibre/like ebrake cover, wiper jet covers,bra, seat covers,Mr. Mikes welting, chrome valve stems and caps, leather ebrake boot,chrome change holder cover,black/red leather steering wheel cover, chrome antenna bezel and chrome 12:" antenna,rear quarter window decals, winter car cover for winter storage, special made DREAM CREWZER dash plaque.upper windshield eyebrow tint , gts headlight protectors, carbon fibre taillight covers,car cover,K&N drop in filter, AMX intake pipe, shiny metal steering wheel spoke covers:Mopar door sills, rear chrome licence insert.street series badge,billett grill,engine start button, red brake calipers,painted engine manifold,chrome vent knobs,chrome/carbon fibre shift knob
Reply With Quote
  #10 (permalink)  
Old 09 Sep 2009, 07:33 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: HELP!!!!!

Quote:
Originally Posted by ptgrl2009 View Post
The battery is a year old and there is some corrosion on the cables to the battery i have tried a jump start but the aaa man used only the jump start attachment instead of hooking up to the battery. thank you so much for the help i can use all that i can get
I replied to your other post on the same problem...
Try to wiggle the battery cables - they should not move.
At any auto store, get a battery terminal cleaner - it has 2 halves - a brush for the inside of the clamp, and a round brush for the posts.
Take the cables off, clean, and tighten.
The starter wouldn't cause it to die, and if the alternator had died, you wouldn't have any lights.
The starter takes LOTS of amps, and needs a good connection, so that's where to start.
Get a friend and try a jump direct on the battery.
No check engine light?
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:48 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors