PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
P0340 Code - Changed CSPS, stil not turning over

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 19 Sep 2009, 03:57 pm
Fresh Cruiser
 
Join Date: Sep 2009
Posts: 4
Default P0340 Code - Changed CSPS, stil not turning over

2004 Touring Edition (Not Turbo)

My Cruiser died in the middle of traffic early this week casuing me to have to tow it home. When trying to get it to turn over she acts like she really wants to, but never quite gets there. Pulled the codes and got a P0340 indicating Crankshaft Position Sensor problem. So, my wife went out an bought one this week. I slapped it in this afternoon (much easier job than I anticipated) and...she STILL isn't turning over. Check the codes agian - same code! I'm lost with what to do know! Where do you think I should go with this?

Thanks in advance!
Reply With Quote
  #2 (permalink)  
Old 19 Sep 2009, 05:17 pm
Fanatic Cruiser
 
Join Date: Dec 2003
Location: San Antonio, Texas
Posts: 535
Default Re: P0340 Code - Changed CSPS, stil not turning over

Most likely the timing belt broke. The PCM is seeing the crankshaft turn but not the camshaft. That's why it sets that code. Does it seem to crank kind of odd? Speeds up and slows down when you crank?
Reply With Quote
  #3 (permalink)  
Old 19 Sep 2009, 05:40 pm
Fresh Cruiser
 
Join Date: Sep 2009
Posts: 4
Default Re: P0340 Code - Changed CSPS, stil not turning over

No, it really is more of a steady near turn over - sounds like it is just BARELY away from starting up, but doesn't make it. I haven't actually tried to turn it over for more an a couple of seconds at a time, but I would think that would be enough to hear the difference.

Alright - at the risk of sounding like a complete idiot - where will that be located and what would I be looking for to see if it is?

Thanks for such a quick response!
Reply With Quote
  #4 (permalink)  
Old 19 Sep 2009, 06:09 pm
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: P0340 Code - Changed CSPS, stil not turning over

OEM or aftermarket sensor? Some aftermarket sensors do not work well to be able to operate. Did you disconnect the negative battery for about 5 minutes? There is a cover that can be removed, I think on the front of the engine that will uncover a opening about the size of a 50 cent piece, it is not easy to see in there tho. If I'm wrong someone will chime in and correct me.

BTW: Welcome to the Forum!!!
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #5 (permalink)  
Old 19 Sep 2009, 06:18 pm
Fresh Cruiser
 
Join Date: Sep 2009
Posts: 4
Default Re: P0340 Code - Changed CSPS, stil not turning over

The sensor is a Duralast SU3019.

I had the negative terminal disconnected the entire time I worked on the vehicle. Habit - better safe than sorry.

Not sure what you are refering to with the 50 Cent size hole. What would be the purpse and what should I do with regards to it.

Thanks for the welcome! :
Reply With Quote
  #6 (permalink)  
Old 19 Sep 2009, 06:30 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: P0340 Code - Changed CSPS, stil not turning over

The cover and "peephole" is to look at the timing belt.
How many miles?
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #7 (permalink)  
Old 19 Sep 2009, 06:45 pm
Fresh Cruiser
 
Join Date: Sep 2009
Posts: 4
Default Re: P0340 Code - Changed CSPS, stil not turning over

Oh - okay. Have to look when there is more light...

About 108k
Reply With Quote
  #8 (permalink)  
Old 19 Sep 2009, 07:00 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: P0340 Code - Changed CSPS, stil not turning over

Quote:
Originally Posted by JMatthewM View Post
About 108k
You've just confirmed everyone's thoughts with that 1 answer. Timing belt should be chnaged (along with the water pump and a couple other items) at around 90-100,000 miles. Luckily it's a non-interference engine and you won't have internal damage.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #9 (permalink)  
Old 19 Sep 2009, 10:28 pm
Regular Cruiser
 
Join Date: Mar 2009
Posts: 140
Default Re: P0340 Code - Changed CSPS, stil not turning over

I knew that code before I opened the thread - very common - does not cause cranking problems.

Our PT threw the code before 30K and it was the sensor - but the car still ran and drove - I replaced it myself.

Sounds like timing belt in your case.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
P0340 cam sensor code in 2006 cruiser deighter Tech & Performance Forum 13 12 Jan 2012 07:41 am
2004 PT GT Stalls with P0340 code ron2004gt General Turbo Discussions 18 17 Apr 2011 06:46 pm
Error code P0340 ADVICE??? mjb457 Tech & Performance Forum 10 20 Aug 2009 09:24 pm
Cam Sensor code changed sensor still dead RottenKid Tech & Performance Forum 8 18 Nov 2008 08:17 am
code p0340 sflamedic General PT Cruiser Discussions 5 21 Oct 2008 06:12 am


All times are GMT -5. The time now is 10:10 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors