PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Power Steering troubles??

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 04 Apr 2002, 10:20 pm
Regular Cruiser
 
Join Date: Jan 2002
Location: Beckley, WV, USA.
Posts: 145
Default Power Steering troubles??

We've had 4 PT's as of now loose their power steering, 3 lost the belt off the pump...just wondering if anyone out there has had any trouble like this or heard of anything.....be cool, James

Reply With Quote
  #2 (permalink)  
Old 20 May 2003, 08:44 pm
Cool Cruiser
 
Join Date: Jan 2003
Location: NJ, USA.
Posts: 362
Default

Hey James my 03 GT just lost it's power steering today! Just what I needed as I pulled into the Dentist's parking lot. Go it up to the dealer 30 miles no power steering, like driving a truck! The hose came off the PS cooler. They replaced the clip and fluid and away I went! I didn't even know that I had a power seering cooler!..
__________________
http://www.imagestation.com/album/?id=4290145623
It\'s gone but not forgotten. Still love the Cruiser but my heart got stolen buy a Ruby Red 05 Legacy GT!
Reply With Quote
  #3 (permalink)  
Old 20 May 2003, 09:34 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default

Lost mine a few months ago. I was out of the Chrysler warranty at the time but had an aftermarket warranty. Covered the price of a new pump, air-conditioning gases and labor all except the deductable. The pump went without warning and was told there was a nationwide shortage of pumps but my dealer managed to find one at another dealer 90 miles away.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #4 (permalink)  
Old 23 May 2003, 09:20 pm
Fresh Cruiser
 
Join Date: Apr 2002
Location: .
Posts: 23
Default

I had a steering rack and a pump replaced at about 20,000. The rack was leaking internally and the pump bearing was noisy ... I'd say poor quality control.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power steering whine problem identified sawdust123 General Turbo Discussions 5 10 Dec 2008 07:24 pm
ATF + 4 or 5 for power steering? quicksilverdon General PT Cruiser Discussions 2 21 Feb 2005 05:00 pm
I think I'm having a power steering problem! lumofny Tech & Performance Forum 5 18 Jan 2005 01:12 pm
Exfessive whining from power steering Ripped General PT Cruiser Discussions 7 13 Jul 2004 01:46 pm
Power steering leak . . . gonzowing Tech & Performance Forum 5 15 Apr 2004 10:28 pm


All times are GMT -5. The time now is 03:44 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors