PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
A/C not cooling at all

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 09 Oct 2009, 07:01 am
Fresh Cruiser
 
Join Date: Oct 2009
Posts: 5
Default A/C not cooling at all

hello everyone, i have 05 PT NON Turbo and i have been going through this site for couple of day reading on what may be wrong with my A/C but i had no luck lots of great tips....


1) i changed fan motor ($100) because high speed side of the fan was not working no luck A/C still blows warm



2)ordered and replaced a low presure switch ($30) but still no luck with getting cold air

i here compresser kick on and off and the two ac line running into the firewall one line on the left side starts to get cold then freeze up and cool down again. i dont know what else to do. Im buying a gauge to check the freon...but if you have any extra tips on what it may be Im willing to check..


OO before i forget when we would turn the A/C on we would hear a pop like a vent door opening or closing but we no longer hear that noise...
Reply With Quote
  #2 (permalink)  
Old 09 Oct 2009, 07:15 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: A/C not cooling at all

Welcome to the forum Joe.

The vent door noise is/was because pressure was building up in the A/C system, either because the system itself was hot (fan not working) or the R134 was not at the right levels.

You hear the compressor coming on and going off. Is it a fast recycling of the compressor (every couple of seconds) because that's a sure sign of low R134.
Reply With Quote
  #3 (permalink)  
Old 09 Oct 2009, 06:40 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: A/C not cooling at all

Agree w/ Crewzin - sounds like low refrigerant (freon or whatever it is).
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #4 (permalink)  
Old 09 Oct 2009, 08:56 pm
Senior Cruiser
 
Join Date: Jan 2008
Location: I live in Edmonton AB Canada
Posts: 1,643
Default Re: A/C not cooling at all

my ac is up and running again...the mechanic forgot to plug it in BUT it is -15 with windchill....dug out my wintercoat,warm pants and have the heater up full blast and full HOT....thank god for good Toyota heaters
__________________
PT Cruiser Inferno Red GT Cruiser. 5Spd 215HO HP 17" Chrome wheels, Chrome gas cap, door spears, door handle cups, door buttons,door lock pins, vent covers,rear spoiler,rear painted mudflaps,, chrome/carbon fibre/like ebrake cover, wiper jet covers,bra, seat covers,Mr. Mikes welting, chrome valve stems and caps, leather ebrake boot,chrome change holder cover,black/red leather steering wheel cover, chrome antenna bezel and chrome 12:" antenna,rear quarter window decals, winter car cover for winter storage, special made DREAM CREWZER dash plaque.upper windshield eyebrow tint , gts headlight protectors, carbon fibre taillight covers,car cover,K&N drop in filter, AMX intake pipe, shiny metal steering wheel spoke covers:Mopar door sills, rear chrome licence insert.street series badge,billett grill,engine start button, red brake calipers,painted engine manifold,chrome vent knobs,chrome/carbon fibre shift knob
Reply With Quote
  #5 (permalink)  
Old 10 Oct 2009, 02:02 pm
Fresh Cruiser
 
Join Date: Oct 2009
Posts: 5
Default Re: A/C not cooling at all

hey guys thanks for all the help, my wife and newborn thank you also..i just got back with a can of freon and put it all into the car and it cooling again. i just got lucky a cool front came into south texas cause it had been 100+ degrees over here for a good while...

We thank you again
Reply With Quote
  #6 (permalink)  
Old 10 Oct 2009, 02:42 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: A/C not cooling at all

Glad it's working for you Joe and it's nice that it was a simple fix. Good luck.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
cooling fan no go on the low nealtotheking General PT Cruiser Discussions 10 03 Aug 2017 08:19 pm
Cooling Fan No Go when AC is Turned ON betterred Tech & Performance Forum 14 20 Feb 2011 11:05 pm
cooling fan blades Magu Tech & Performance Forum 2 30 Sep 2009 05:45 am
Cooling Fans mhsballplaya2369 Tech & Performance Forum 3 04 Dec 2008 05:08 pm
Cooling Fan Mod AZ_IceMan Stage Turbo Kits 3 25 May 2005 04:07 am


All times are GMT -5. The time now is 03:09 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors