PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Need Help!!!

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 27 Oct 2009, 08:29 am
Fresh Cruiser
 
Join Date: Oct 2009
Posts: 3
Default Need Help!!!

I just got my first 2001 Pt Cruiser Touring 121,000 miles....runs great! With the exception of overheating, coolant smell and gurgling sound after 1 hour of driving it...is there any remedy for this , What's the problem??
PD. Already gave a radiator flush...stills overheating...
ANY HELP??
THANK YOU!!!
Reply With Quote
  #2 (permalink)  
Old 27 Oct 2009, 08:49 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Need Help!!!

Have you done basics?
Thermostat?
Making sure engine fans works?
For fan, open hood, start engine, turn on A/C, go out and make sure elec fan is runnin - if not, that's your problem.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #3 (permalink)  
Old 27 Oct 2009, 08:58 am
Fresh Cruiser
 
Join Date: Oct 2009
Posts: 3
Default Re: Need Help!!!

Fans Ok....Need to check thermostat!
Thank You!!!
Reply With Quote
  #4 (permalink)  
Old 27 Oct 2009, 01:41 pm
Regular Cruiser
 
Join Date: Jul 2009
Location: Lake-O-The-Pines , E.Texas
Posts: 199
Default Re: Need Help!!!

may be air pocket in cooling system , do a search here..
__________________
This Black Thing Keeps Chasing Me



YES ! That is a Ron Paul for President Sticker..

Growing OLD is Natural - Growing UP is Optional It's NEVER too late to have a Happy Childhood

Ed Sidders , Lake-O The-Pines , Northeast Texas
Reply With Quote
  #5 (permalink)  
Old 27 Oct 2009, 01:54 pm
Fresh Cruiser
 
Join Date: Oct 2009
Posts: 3
Default Re: Need Help!!!

THANKS!!!!
U Guys R The Experts!!!
I'm Working Today This Issues...
I'll Let U Know If Solved Or Not...
Reply With Quote
  #6 (permalink)  
Old 27 Oct 2009, 07:54 pm
Fresh Cruiser
 
Join Date: Sep 2009
Location: WAUPACA, WI
Posts: 16
Default Re: Need Help!!!

I second the opinion you may have air in the system. If that's not your problem you can always take the thermostat out and put it in a pan of water and heat it on stove and see if it opens at the right temperature. It may be stuck closed.
James
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 10:12 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors