PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Transmission oops

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 04 Dec 2009, 11:55 pm
Fresh Cruiser
 
Join Date: Dec 2009
Location: under the hood
Posts: 6
Default Transmission oops

Hi everyone,
I frequent a couple different jeep forums and do most of the maintenance, and repairs on my 85 cherokee.

However, my wife has an 03 pt. cruiser with the 2.4l, automatic transmission. Typically she takes it to Jiffy Lube. And honestly i am not sure how often, or what else she has done to it.

Due to my alternator going out i took her cruiser to work today. As i was leaving the parking lot, It went in reverse just fine. But when i put it in drive all it did was rev the engine. Did not move, until i got it to about 4k rpm. The engine light came on but not a tranny related code. I drove it to the local parts store that knows me well and when we checked the trans. fluid it was good. But when i went through the gears and back to park, the stick had no fluid on it.

WE added just under 2 quarts of tranny fluid. If you put your hand under the drivers side while it was running, you get a nice shower of trans. fluid. The counter guy told me it is most likely the fluid lines. That the clamps are known to cut the hose. I plan on putting the car on jackstands in the morning. But my long winded question here is. Should i go ahead and replace the filter while i am under there? I have been searching here for about an hour and reading alot of dead ended threads.. But i did learn the transmission is a weak link. So i am aware i will be told to go get it flushed with the machine. That is not something that can happen this week. Should i fix the hoses and leave it parked until i can get it flushed?


Any advice will be very helpful and appreciated.

I also know that my grammar and punctuation are horrible. So any grammar Nazis please be kind. I went to portland public schools.. lol
Reply With Quote
  #2 (permalink)  
Old 05 Dec 2009, 04:49 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Transmission oops

Welcome.
If I read it right, you were low on fluid due to hose leaks, and you've put fluid in - and fixed the leaks?
Drive it. You just did a partial flush....
Schedule a flush - if you're sure leaks are fixed.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
oops lt4supr General PT Cruiser Discussions 3 23 Jan 2009 07:36 am
Newby oops Cliff5550 General PT Cruiser Discussions 8 02 Nov 2008 11:40 pm
Need Transmission help!! jennylyn General PT Cruiser Discussions 0 20 Oct 2008 07:05 pm
New Transmission Red GT General PT Cruiser Discussions 3 02 Nov 2004 08:55 am
OOPS - Forgot the windows again... Stephen R. Sound and Security Forum 2 31 Oct 2003 09:00 pm


All times are GMT -5. The time now is 07:26 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors