PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
2008 PT Starting Issues

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 14 Jan 2010, 04:53 pm
Fresh Cruiser
 
Join Date: Jan 2010
Location: San Antonio, Texas
Posts: 2
Cool 2008 PT Starting Issues

I have a 2008 PT Cruiser with 50k. I noticed that it was hard to start (like a low charged battery) when I attempted to start the car. The next day it seemed to start just fine. The next day it started just fine and I drove it to work. When I went to start it after work it would not start. It only "clicked" a couple of times, then nothing. It did jump start with no issues and I drove it home (at night with lights on). I put it on a charger overnight. It started fine in the morning, but then again it would not start after work. Is this a battery problem or alternator issue? When I checked the battery (with engine running) using a volt meter (at the battery post), it was measuring at 18.4 volts. Is it over-charging? Isn't that just as bad as under-charging? Or is there a different or better way to check it? I think that it should read around 14 - 14.5 at the battery while the engine is running, is that correct? Thanks in advance for any help and advise. Steve.
Reply With Quote
  #2 (permalink)  
Old 14 Jan 2010, 07:31 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: 2008 PT Starting Issues

Welcome.

Sears & some other places test charging system and battery for free.
How do the terminals look? All crudded up?
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #3 (permalink)  
Old 14 Jan 2010, 08:25 pm
Fresh Cruiser
 
Join Date: Jan 2010
Location: San Antonio, Texas
Posts: 2
Default Re: 2008 PT Starting Issues

Thanks for the "Welcome"...

All of the cable ends are clean and look good. No corrosion has been seen on the battery or cables.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2002 Pt cruiser starting issues ort102 Tech & Performance Forum 5 11 Jul 2011 07:28 pm
speaker issues, wattage of stereo, door speaker replacement issues fabes89 General PT Cruiser Discussions 9 02 Jun 2009 10:59 am
Newbie here; same PT issues Wienerdog General PT Cruiser Discussions 11 04 May 2009 11:57 pm
2 Issues - Need Help 07PTSilver General PT Cruiser Discussions 2 09 Dec 2008 03:45 pm
security issues dollymama Interior Accessories Forum 3 20 Apr 2004 04:18 pm


All times are GMT -5. The time now is 06:50 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors