PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
2007 Wipers Malfunctioning

 
Like Tree2Likes
  • 1 Post By ptjimbo
  • 1 Post By ptcruisersteve

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 21 Mar 2010, 12:37 pm
Fresh Cruiser
 
Join Date: Mar 2010
Posts: 2
Default 2007 Wipers Malfunctioning

I have a 2007 (out of warranty) Touring and the wipers suddenly aren't working right. The delay no longer works and when you turn them off they stop where ever they are when the switch is turned off. They also seem to run for a while after the ignition is turned off and key removed. I looked for the relay but am guessing (perhaps wrong) it is buried in the TIPM (too expensive)which I appear to have. I don't have a wiring diagram to unravel the logic here so am currently running blind. Any thoughts????
Reply With Quote
  #2 (permalink)  
Old 30 Mar 2010, 06:44 pm
Fresh Cruiser
 
Join Date: Mar 2010
Posts: 2
Default Re: 2007 Wipers Malfunctioning

I was able to figure it out after some sleuthing. It turns out that the "parking switch" that is inside the wiper motor assembly failed. I took the entire assembly apart and put the voltmeter on it. There are some copper wipers that need to make contact...very questionable technology...and the one that tells the system that the wipers have returned to home position had yielded and no longer had any spring left in it. I am going to guess others have this problem. I soldered it back together to make a temporary fix until the rebuilt motor arrives. QED
buddyiramae likes this.
Reply With Quote
  #3 (permalink)  
Old 30 Mar 2010, 06:52 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: 2007 Wipers Malfunctioning

Glad you figured it out yourself but sounds like a one-off problem. Haven't heard of anyone else complaining about the wipers doing what yours did.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #4 (permalink)  
Old 21 May 2010, 10:17 am
Fresh Cruiser
 
Join Date: Jul 2008
Posts: 14
Default Re: 2007 Wipers Malfunctioning

I started having that very same problem this morning!

The intermittent no longer works. They come on and stay on at any setting until turned off. And once turned off, they just stop where ever they are, they don't return to home.

You say there is a switch on the motor itself??

2007 touring model as well
Reply With Quote
  #5 (permalink)  
Old 27 May 2010, 03:01 pm
Fresh Cruiser
 
Join Date: Jul 2008
Posts: 14
Default Re: 2007 Wipers Malfunctioning

An update. I found out that my car had an extended warranty. With 90k miles on the car, there was still some warranty left, granted, I had to pay a $100 deductible. I had some other things fixed while it was at the dealer as well.

So anyway, they said it was the switch on the column. I disagreed with the service advisor and asked them to check the wiper motor. Of course, they always know what's best ....

Without all the details, it finally ended up being the wiper motor. So if you have this same problem, check your motor as well. As described above, the wipers would come on but the the intermitent settings didn't work, they would stay on. And when turned off, the wipers would keep on going and eventually they would stop at random places on the windshield. Hence, a broken or shorted "homing switch" in the motor.

On a side note, the tech that worked on my car, put my driver side wiper on to where it was "homing" 6-8 inches up the windshield, almost in my field of view. And when you would turn them on, the wiper would go off the windshiled and past the pillar. How they let this out the door is beyond me. Took me all of 5 minutes to align it properly, I didn't have time to wait when I picked it up. I guess it's still hard to find a decent mechanic any more.... no offense
Reply With Quote
  #6 (permalink)  
Old 14 Sep 2012, 12:16 pm
Fresh Cruiser
 
Join Date: Sep 2012
Posts: 1
Smile Re: 2007 Wipers Malfunctioning

Hey all.I bought an 07 PT in June and recently obtained the same problem.My wipers no longer work intermittently and when shut off,they stop where they are.Good timing is needed to stop at home base.I am going to follow through with buying another wiper motor and let the forum know if this corrects my problem.
Reply With Quote
  #7 (permalink)  
Old 13 Jun 2015, 08:25 pm
Fresh Cruiser
 
Join Date: Apr 2015
Posts: 12
Default Re: 2007 Wipers Malfunctioning

Im having almost the same problem, but I guess is not the parking switch. Because my wiper works on direct speed and fast, and stop at the end when I turn it off. The intermitent is what doesnt work. Just do 1 pass on any speed and never move again until I move to next speed.

I guess there is some timing relay in some place that I need to change, but no idea where is it.
Reply With Quote
  #8 (permalink)  
Old 13 Jun 2015, 09:00 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,333
Default Re: 2007 Wipers Malfunctioning

Quote:
Originally Posted by deftoner View Post
Im having almost the same problem, but I guess is not the parking switch. Because my wiper works on direct speed and fast, and stop at the end when I turn it off. The intermitent is what doesnt work. Just do 1 pass on any speed and never move again until I move to next speed.

I guess there is some timing relay in some place that I need to change, but no idea where is it.
I would suggest you check the Multi-Switch Stalk and if that is okay then you need to check the TIPM.
Reply With Quote
  #9 (permalink)  
Old 15 Jun 2015, 07:46 am
Cool Cruiser
 
Join Date: Jul 2011
Location: somerset,ky
Posts: 223
Default Re: 2007 Wipers Malfunctioning

Got the same thing goin on with my 04
Reply With Quote
  #10 (permalink)  
Old 15 Jun 2015, 08:29 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,333
Default Re: 2007 Wipers Malfunctioning

Quote:
Originally Posted by drumrooster View Post
Got the same thing goin on with my 04
There is no TIPM on the 2004 PT Cruiser. I would suggest checking the wiper stalk.
3rcruiser likes this.

Last edited by ptcruisersteve; 15 Jun 2015 at 08:39 am.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intermittant wipers quit Nickatnite General PT Cruiser Discussions 8 13 Aug 2016 11:05 am
What windshield wipers do you use? Aviator747 Exterior Accessories Forum 5 20 Feb 2007 04:02 pm
Wipers w/ fluid jets Dekard General PT Cruiser Discussions 8 17 May 2004 03:10 pm
Malfunctioning remote door locking??? me encanta mi PT General PT Cruiser Discussions 3 25 Sep 2003 11:04 am
wipers???? cruisergeo Exterior Accessories Forum 5 24 Aug 2003 08:04 pm


All times are GMT -5. The time now is 03:59 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors