PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Water Pump (Mega FAIL)

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 21 Mar 2010, 07:37 pm
DigitaL101's Avatar
Fresh Cruiser
 
Join Date: Mar 2010
Location: Hampton Va
Posts: 37
Default Water Pump (Mega FAIL)

Water Pump started leaking after a boiling overheat , expected bad bearing or bad seal ..... never expected this .





What the hey .... could this possibly be normal where and tear ?

What happend here , and were did the rest of it go ...
The blades on this thing feel as though there made of tin .

Is there a "prefered" pump maker ? a pump with a little more "meat on the bone" ??

2002 Limited 5 Speed
Reply With Quote
  #2 (permalink)  
Old 21 Mar 2010, 09:57 pm
Fanatic Cruiser
 
Join Date: Mar 2010
Location: Billings, MT
Posts: 745
Default Re: Water Pump (Mega FAIL)

I would seriously check the rest of the engine if you can't find the missing pieces. The last thing you want is to have one of the blades blocking a water channel destroying your engine (by overheating).
__________________
-Chris
2010 PT Cruiser Classic, Deep Water Blue
Reply With Quote
  #3 (permalink)  
Old 21 Mar 2010, 11:08 pm
767skyking's Avatar
Fanatic Cruiser
 
Join Date: Nov 2009
Location: Inland Empire Ca
Posts: 754
Default Re: Water Pump (Mega FAIL)

I would remove the radiator hoses, heater core hoses and reverse flush both and the engine.
Reply With Quote
  #4 (permalink)  
Old 22 Mar 2010, 12:05 am
DigitaL101's Avatar
Fresh Cruiser
 
Join Date: Mar 2010
Location: Hampton Va
Posts: 37
Default Re: Water Pump (Mega FAIL)

Roger that guys ..

That right now is my greatest concern , thats a pretty large piece of metal floating around in there ... or most likely , lodged in a narrow water jacket somewhere .

on second look , its actualy three missing blades ....

i did a primary flush before the pull down , plenty of "green" non HOAT fluid
no foreign material , i'll do a more vigorous flush and see what i can find . I'll put on an old hat , find me some screen and pretend its 1849 .

on a brighter note , i think i found my overheating problem ..


2002 Limited 5 Speed

Last edited by DigitaL101; 12 Jul 2010 at 10:43 pm.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Water Pump rute66pt General PT Cruiser Discussions 4 03 Dec 2009 01:56 pm
How many bolts in the water pump? 2001PTCRUZ Tech & Performance Forum 1 07 Aug 2009 07:26 pm
water pump replacement questions JakeBrakeIH Tech & Performance Forum 10 25 Nov 2008 07:43 pm
water neck for the water pump Boxerjl2 Classifieds: For Sale/Trade 3 31 Jan 2008 02:48 am
Bad water pump/head gasket Gloria J Tech & Performance Forum 4 28 Oct 2003 06:06 pm


All times are GMT -5. The time now is 11:34 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors