PT Cruiser Forum  
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

speedo not working tranny not shifting

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 27 Mar 2010, 12:58 pm
csd csd is offline
Fresh Cruiser
 
Join Date: Aug 2007
Posts: 49
Default speedo not working tranny not shifting

I need help with this, from one day to another, the speedo stopped working and at the same time the transmission, stopped shifting, it won't go past 1st gear (auto trans), the car was working fine the day before and, for a long time, never had any problems.

pt 2003 touring 2.0 export.
Reply With Quote
  #2 (permalink)  
Old 27 Mar 2010, 04:44 pm
CREWZIN's Avatar
Obsessed Cruiser
 
Join Date: Sep 2001
Location: West Central Florida
Posts: 24,113
Default Re: speedo not working tranny not shifting

Found this conversation on a search:

The reverse works and it works fine in first gear but want shift to 2nd or higher. Also the speedometer needle doesn't move when I'm driving, it is on zero.

I tested both input and output speed sensors and they appear to work fine.
I'm wondering if anyone has seen this before or could give me an idea where to check next. The next place I would think to look is the TCM (Transmission Control Module) nut not sure how to test it.
Could I get one from a wrecker and try it out?
Any ideas?


The speedometer problem sounds like the VSS, which is located on the back of the transaxle. However, if the TCM is fried, that may prevent the speedometer from functioning.

Check Fluid? You probably have but I understand these trannies are real sensitive to fluid level.Also, after checking and adjusting fluid, I think you can reset the tranny computer by disconnecting the battery for a short time. It will "re-Train " itself.

Ok this is what I did. I bought the input and output sensors and tested them to see how the new ones worked. I connected my AC voltmeter on low scale to the electrodes on the new sensor and passed a magnet in front of the sensor. I could see a small amount of ac on my meter. So I then took out the two sensors from the transmission and tested them the same way and they appeared to have the same readings as the new ones. I then figured they where good.

I then called a person who works on dodge vehicles all day long and he said that 9 out of 10 times the problem is a bad sensor. If the output sensor is bad, the speedo does not work and you can't get out of first gear. If the speedo works and you have transmission problems then it is most likely the input sensor.

So I went ahead and changed out the output sensor and she works great. The speedo works and I have all my gears working.

This mechanic also said I should replace the fuel filter since I have 118,000 Km on it because they can cause problems if they are starting to get plugged.

Thanks to everyone that replied to my post.
__________________
......
...just CREWZIN along! . . . PT Cruiser Links Moderator
2000 PT. Original Owner, 118,000 miles
MY technical suggestions are given in GOOD FAITH without total guarantee, if in doubt go to a garage.
Visit My Home Page www.CREWZIN.com
Reply With Quote
  #3 (permalink)  
Old 27 Mar 2010, 05:23 pm
csd csd is offline
Fresh Cruiser
 
Join Date: Aug 2007
Posts: 49
Default Re: speedo not working tranny not shifting

Thanks crewzin, that seems to be the solution i'll try to change the output sensor.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
PT speedo not working paul25 Tech & Performance Forum 3 11 May 2013 12:40 am
120/140 speedo no abs desig in vin ?? calhbkid General PT Cruiser Discussions 7 14 Mar 2010 01:43 pm
Tach, Speedo & gas gauge not working?! mothersonion General PT Cruiser Discussions 2 15 Sep 2008 09:12 pm
speedo change 4SPEED General PT Cruiser Discussions 3 26 Sep 2006 07:49 pm
2002 PT -> 17" rims -> speedo off? vk Wheels, Tires, Suspension 5 26 Aug 2005 08:35 pm


All times are GMT -5. The time now is 12:08 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors