PT Cruiser Forum  
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

03 cruiser running hot

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 13 Apr 2010, 01:47 pm
cllwyrc's Avatar
Fresh Cruiser
 
Join Date: Apr 2010
Location: old monroe, mo
Posts: 25
Default 03 cruiser running hot

I recently bought a 03 cruiser and it tends to run at about 3/4 of the way up the gauge and the fan kicks on at the half way mark and doesn't shut off. Is this a thermostat problem or waterpump or something more sevier?
Reply With Quote
  #2 (permalink)  
Old 13 Apr 2010, 03:14 pm
Dino's Avatar
Senior Cruiser
 
Join Date: Feb 2010
Location: NY
Posts: 1,833
Default Re: 03 cruiser running hot

Quote:
Originally Posted by cllwyrc View Post
I recently bought a 03 cruiser and it tends to run at about 3/4 of the way up the gauge and the fan kicks on at the half way mark and doesn't shut off. Is this a thermostat problem or waterpump or something more sevier?
Is it only at idle? Does it do it when your at say parkway speed? Any leakage under the PT? When the fan comes on does it go back down to half? Do you have the right coolant on the radiator? Has it ever been flushed? How many miles on the PT?
__________________



"the people should not fear their government, the government should fear the people"- Thomas Jefferson
Reply With Quote
  #3 (permalink)  
Old 14 Apr 2010, 02:06 am
cllwyrc's Avatar
Fresh Cruiser
 
Join Date: Apr 2010
Location: old monroe, mo
Posts: 25
Default Re: 03 cruiser running hot

PT has 94,000 miles. It has the green coolant in it & not sure how long it has been in there, there is no leaks & it will jump up 3/4 of the way up no matter if your moving or sitting still.
Reply With Quote
  #4 (permalink)  
Old 14 Apr 2010, 08:20 am
CREWZIN's Avatar
Obsessed Cruiser
 
Join Date: Sep 2001
Location: West Central Florida
Posts: 24,264
Default Re: 03 cruiser running hot

cllwyrc,

Chrysler recommends HOAT coolant. It's red in color. It's possible you radiator is partially clogged because of the damage done by the wrong coolant.

Does the fan kick on before the half way mark if you have the A/C on? It should. If not you may have the lower speed part of the fan burnt out.

Other reasons for overheating, like you mentioned is the thermostat not operating properly or a damaged water pump that's not creating the proper flow.

First thing I'd do is check the fan operation, then have the coolant system completely flushed. Any signs of debris or rust in the radiator or it doesn't have a good flow then you'll know somethings wrong.


A work of caution: Your at the point (94K) that you'll be needing a timing belt and water pump change around the 100K mile mark. It's an expensive job requiring 5 to 7 hours labor from a competent mechanic. With parts and labor running anywhere from $800 - $1200 depending on the parts used and the hourly rate of the mechanic.
__________________
......
...just CREWZIN along! . . . PT Cruiser Links Moderator
2000 PT. Original Owner, 119,000 miles
MY technical suggestions are given in GOOD FAITH without total guarantee, if in doubt go to a garage.
Visit My Home Page www.CREWZIN.com

Last edited by CREWZIN; 14 Apr 2010 at 08:23 am.
Reply With Quote
  #5 (permalink)  
Old 14 Apr 2010, 10:43 am
cllwyrc's Avatar
Fresh Cruiser
 
Join Date: Apr 2010
Location: old monroe, mo
Posts: 25
Default Re: 03 cruiser running hot

it doesn't kick on until the half way mark unless you kick the a/c on.
Reply With Quote
  #6 (permalink)  
Old 14 Apr 2010, 02:21 pm
CREWZIN's Avatar
Obsessed Cruiser
 
Join Date: Sep 2001
Location: West Central Florida
Posts: 24,264
Default Re: 03 cruiser running hot

Sounds like the fan is working correctly, at least on the low speed. Without the A/C there's no reason for the fan to come on until a preset temperature is reached. When it's get over that temperature, the high speed should kick on and bring everything back to half way.

You should be able to hear the difference of the high and low because the low makes almost no noise at all above the engine running and the high will be loud enough to hear by itself way above the engine noise.
__________________
......
...just CREWZIN along! . . . PT Cruiser Links Moderator
2000 PT. Original Owner, 119,000 miles
MY technical suggestions are given in GOOD FAITH without total guarantee, if in doubt go to a garage.
Visit My Home Page www.CREWZIN.com
Reply With Quote
  #7 (permalink)  
Old 15 Apr 2010, 01:04 am
cllwyrc's Avatar
Fresh Cruiser
 
Join Date: Apr 2010
Location: old monroe, mo
Posts: 25
Default Re: 03 cruiser running hot

I forgot to mention that I don't have these problems at night when temps outside is cool except for the fan running on high once hitting the half way mark.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
03 GT Cruiser wont stay running. 03GTCruiser Tech & Performance Forum 2 23 Feb 2010 12:14 am
cruiser will not stop running DreamPT416 Tech & Performance Forum 8 05 Dec 2009 07:39 pm
PT cruiser Overheating - fan isn't running Torashi Tech & Performance Forum 4 13 Jul 2009 02:37 am
2003 PT Cruiser running power oscar514 Tech & Performance Forum 1 28 Feb 2009 05:13 pm
up and running again careyk Canada PT Forum 1 19 Feb 2008 01:31 am


All times are GMT -5. The time now is 11:54 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors