PT Cruiser Forum  
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

01 pt cruiser radiator fan not working HELP

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 21 Apr 2010, 03:38 am
Fresh Cruiser
 
Join Date: Apr 2010
Posts: 14
Default 01 pt cruiser radiator fan not working HELP

my 01 pt has been over heating and at first I thought it was in the thermostat. Changed that and it still overheated. Well the other day I was driving and got stuck in traffic and the temp gauge raised to 3/4 and made my radiator spring a leak. I replaced the radiator and it still overheated, I realized that the radiator fan was not coming on low speed or high speed. It was doing nothing. I immediately went out and bought a new radiator fan and still to my surprise NOTHING! I checked the fuse and replaced both relays after the new fan and still NOTHING! So where do I go from here? PLEASE help me out as I do have mechanical knowledge, im just stumped and don't know what else to do. Also I tried testing the old fan to see if it was the culprit and I grounded the middle wire and could only get the fan to come on low speed. The high speed was not coming on? If anyone could please help me and give me some advise I would really appreciate it
Reply With Quote
  #2 (permalink)  
Old 21 Apr 2010, 10:18 am
Dino's Avatar
Senior Cruiser
 
Join Date: Feb 2010
Location: NY
Posts: 1,833
Default Re: 01 pt cruiser radiator fan not working HELP

Quote:
Originally Posted by salteedogg View Post
my 01 pt has been over heating and at first I thought it was in the thermostat. Changed that and it still overheated. Well the other day I was driving and got stuck in traffic and the temp gauge raised to 3/4 and made my radiator spring a leak. I replaced the radiator and it still overheated, I realized that the radiator fan was not coming on low speed or high speed. It was doing nothing. I immediately went out and bought a new radiator fan and still to my surprise NOTHING! I checked the fuse and replaced both relays after the new fan and still NOTHING! So where do I go from here? PLEASE help me out as I do have mechanical knowledge, im just stumped and don't know what else to do. Also I tried testing the old fan to see if it was the culprit and I grounded the middle wire and could only get the fan to come on low speed. The high speed was not coming on? If anyone could please help me and give me some advise I would really appreciate it

See if you can test the new fan like you did the old, so at least your sure the new fan isn't a dud. Other than that your going to have to wait for one of the more knowledgeable guys to see this post. You have done everything I would have done, good luck.
__________________



"the people should not fear their government, the government should fear the people"- Thomas Jefferson
Reply With Quote
  #3 (permalink)  
Old 21 Apr 2010, 01:15 pm
Fresh Cruiser
 
Join Date: Apr 2010
Posts: 14
Default Re: 01 pt cruiser radiator fan not working HELP

Also was wondering if this may have anything to do with it. Here recently my ac has started cutting on and off when sitting still. So even if the radiator fan did work I don't see how it could with the compressor kicking on and off every other second. But regardless I think I should still see a low speed fan come on or something. Does anyone think it could be the engine coolant temp sensor? Its only 19.99 so it may be worth a shot.
Reply With Quote
  #4 (permalink)  
Old 31 Jul 2010, 07:18 pm
Fresh Cruiser
 
Join Date: Jul 2010
Posts: 1
Default Re: 01 pt cruiser radiator fan not working HELP

I had the exact same problem. I replaced the fan motor, the radiator fuse, radiator low speed relay, and radiator high speed relay. Still, the fan would not come on. I gave up and took to my local mechanic. He fixed it in less than an hour. It was a bad connection under the fuse box assembly. If I were a PT Cruiser owner with a fan problem ... I would check this first.
Reply With Quote
  #5 (permalink)  
Old 31 Jul 2010, 08:22 pm
CREWZIN's Avatar
Obsessed Cruiser
 
Join Date: Sep 2001
Location: West Central Florida
Posts: 24,263
Default Re: 01 pt cruiser radiator fan not working HELP

Salteedog,

As Doverdale found out, sometimes it's not a part that can easily be replaced but something that's not part of the equation of how the fan works like a bad wire. The two things you haven't tried (but mentioned one) is the ECT (Engine Coolant Temperature) sensor and the computer. They both have parts to play in operating the fan and keeping the car cool.

One thing to tell you is that when you hear the compressor going on and off repeatedly, it possibly means your low of R134a so yo want to have that checked.

Also on the overheating; are you using the right coolant in the radiator and at the proper 50/50 mixture? Are you sure all the air is out of the system?
__________________
......
...just CREWZIN along! . . . PT Cruiser Links Moderator
2000 PT. Original Owner, 119,000 miles
MY technical suggestions are given in GOOD FAITH without total guarantee, if in doubt go to a garage.
Visit My Home Page www.CREWZIN.com
Reply With Quote
  #6 (permalink)  
Old 01 Aug 2010, 07:39 pm
Fresh Cruiser
 
Join Date: Aug 2010
Location: Northeast, TN
Posts: 1
Default Re: 01 pt cruiser radiator fan not working HELP

I met and fell in love with my '01 PT Cruiser back in Jan of this year. I was looking for something small to get me back and forth to school (Adult going back to college) that I could just pay for and go. Alas, in April, on my way back from a conference in Nashville, my baby overheated. After getting her towed home, a garage charged me $125 to change a thermostat. Two months later, earlier this month, overheated again on a short run into the city. Hubby has changed thermostat, again, water pump, flushed cooling system including the radiator. The fan works when idling and our problem isn't with the car sitting and idling or even in stop and go traffic, it overheats when we are driving on the interstate. He's thinking of having to change the radiator and if that doesn't work, he's thinking of having to change the head. I do not want to sell my car, but do not want to put more money into something that's not going to ever get better. I've read other's with the same problems posts and am wondering if their cars are finally fixed. Thanks!
Reply With Quote
  #7 (permalink)  
Old 01 Aug 2010, 08:17 pm
CREWZIN's Avatar
Obsessed Cruiser
 
Join Date: Sep 2001
Location: West Central Florida
Posts: 24,263
Default Re: 01 pt cruiser radiator fan not working HELP

Paula,

Overheating when moving is usually one of two things. The coolant isn't circulating throughout the system (clogged radiator, air in the system) or a problem with the head gasket or head itself (either could be cracked).

Hubby is working on the right stuff but there's equipment to tell if there's internal damage without pulling everything apart so look for a mechanic with the right test equipment before spending serious money.

Unfortunately you can almost never tell why someone gave up their car and there's all kinds of things that can be done to make it run for awhile before problems will show up for the new owner.

Sorry you had to pay $125 for the thermostat but there's a bit of work that has to be done to change it and probably an hour or so to diagnose it, so depending on the hourly rate of some dealers, you might have got away cheap. My closest dealer is $90 an hour so it would have been closer to $200 if you had it done here. ...just trying to make you feel better.
__________________
......
...just CREWZIN along! . . . PT Cruiser Links Moderator
2000 PT. Original Owner, 119,000 miles
MY technical suggestions are given in GOOD FAITH without total guarantee, if in doubt go to a garage.
Visit My Home Page www.CREWZIN.com

Last edited by CREWZIN; 01 Aug 2010 at 08:23 pm.
Reply With Quote
  #8 (permalink)  
Old 15 May 2011, 08:39 pm
Fresh Cruiser
 
Join Date: Sep 2010
Posts: 20
Default Re: 01 pt cruiser radiator fan not working HELP

Was on my way out when my 2002 LE fan would not come on and needle was almost at red bar (fan usually come on at half/horizontal needle). Checked all the fuses, relays, power to fan and fan. all good.

rented a car and when I came back after 2 days it was working fine.

2 days later same problem. needle almost at red bar. and the fan was not running. stuck my head under the radiator and fiddled with the plug and socket. fan came on immediately, temp went down to half.

loose wiring I guess?

Anyone ever try to put a extra fan between the grill and the radiator?

My fan died a few years ago and cost me. Seems risky to just have one fan too. I miss the old days when the fan was run direct from engine/belt.
Reply With Quote
  #9 (permalink)  
Old 15 May 2011, 09:28 pm
CREWZIN's Avatar
Obsessed Cruiser
 
Join Date: Sep 2001
Location: West Central Florida
Posts: 24,263
Default Re: 01 pt cruiser radiator fan not working HELP

My Corvette has that extra fan in front of the radiator. It was wired to only come on at 230 degrees, way after the regular fan (behind the radiator) was already going. I rewired that other fan (called Auxiliary fan) so I can turn it on at will with a flip of a switch. Now, when it's really hot out (lots of times in Florida) and I know the car will sit idle for a few minutes, I flip the switch and I have one fan pushing air into the radiator, the other pulling air from the radiator and blowing over the engine. Keeps everything cool no matter how hot it is.

So yes, it can be done with the PT with just a bit of engineering work.
__________________
......
...just CREWZIN along! . . . PT Cruiser Links Moderator
2000 PT. Original Owner, 119,000 miles
MY technical suggestions are given in GOOD FAITH without total guarantee, if in doubt go to a garage.
Visit My Home Page www.CREWZIN.com
Reply With Quote
  #10 (permalink)  
Old 15 May 2011, 11:53 pm
Fresh Cruiser
 
Join Date: Sep 2010
Posts: 20
Default Re: 01 pt cruiser radiator fan not working HELP

thanks!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
PLEASE HELP! with my Radiator fan NIL8r General PT Cruiser Discussions 10 02 Apr 2010 07:58 am
HEADLIGHTS NOT WORKING ON OUR 2001 P.T. CRUISER brodas3 Tech & Performance Forum 1 06 Jan 2010 06:13 am
radiator fan removal on 06 up cruiser mscott1979 Tech & Performance Forum 3 02 Aug 2009 07:11 pm
Neon SRT Radiator Hoses on PT Cruiser Turbo? intim3 Turbo Performance 7 01 May 2009 09:13 pm
$800 to have a new radiator put in a 2002 pt cruiser? jgandcag General PT Cruiser Discussions 2 11 Dec 2008 05:17 pm


All times are GMT -5. The time now is 10:51 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors