PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Error Code 320

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 17 May 2010, 12:18 pm
Fresh Cruiser
 
Join Date: May 2010
Posts: 1
Default Error Code 320

I have a 2001 PT. Driving down the road the car just dies. After coasting to a stop you can turn the car off wait a couple of minutes and the car will start and run for awhile longer. I checked the codes and am getting a P1684 then a P0320... Will changing the canshaft sensor fix this?

OK Just to be sure I disconnected the wiring to the camshaft sensor and checked for bad spots, found none.. Also I removed the neg battery post and cleared the computer codes. Took it back out for a drive and it again died four times. Checked the codes only revieled a P1684. When it dies trying to start it is no good. You must turn the key off wait at lease two minutes then it will start again.

Last edited by okla2001pt; 17 May 2010 at 01:36 pm.
Reply With Quote
  #2 (permalink)  
Old 17 May 2010, 12:42 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Error Code 320

Welcome.
Probably camshaft sensor - be sure and buy a Chrysler part - others have had aftermarket sensors die quickly or not work.Also check the wiring - you might have a place wher insulation got eaten off.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
What does the error code PO 138 really mean? TheFox General Turbo Discussions 8 15 Jul 2012 10:10 pm
Error Code bds02pt Tech & Performance Forum 2 29 Jan 2010 03:01 pm
Error Code saldagus Tech & Performance Forum 2 25 Nov 2008 09:51 pm
CPS Error Code smokeydan1 Tech & Performance Forum 16 23 Sep 2008 09:58 pm
Error code??? russ00001 Tech & Performance Forum 0 29 May 2007 04:24 pm


All times are GMT -5. The time now is 05:05 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors