PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Rough idle

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 29 May 2010, 02:56 pm
Jcamden's Avatar
Fresh Cruiser
 
Join Date: May 2008
Location: Redmond, Washington
Posts: 28
Default Rough idle

Hey guys/gals,

My car has not been running so well for about a month. Just hit 60k and got the tranny flushed. Have been changing oil + filter every 3k miles and I just got new plugs gapped at .035. The wires are less than a year old. After I put in the new plugs it seemed to be running a little better but I can still feel she misses when idle. Idles around 6k - 7k,

What next?

Thanks!
__________________
04 - Platinum PT 2.4l turbo
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
rough idle while careyk Tech & Performance Forum 1 02 Oct 2009 11:12 am
Rough idle 03 GT elmeyer Tech & Performance Forum 2 03 Jul 2009 09:44 pm
Rough Idle, Rough @60, check engine light NEW Dystroy Tech & Performance Forum 8 12 Jan 2009 09:07 pm
Rough Idle sobbad Tech & Performance Forum 6 18 Jul 2008 08:57 am
rough idle on 01 2.4 Davestone General PT Cruiser Discussions 8 26 Mar 2008 09:52 pm


All times are GMT -5. The time now is 08:24 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors