PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
No Power at all.

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 02 Jun 2010, 12:59 pm
Fresh Cruiser
 
Join Date: Apr 2010
Location: North Carolina
Posts: 3
Default No Power at all.

used this forum several times, It has been VERY helpful, but I am stuck now...
At stop light and died completely. No power, not even to door locks.
Read something that said it could be the in the ignition electronics, but I would think I'd still get power locks to work. Stuck in parking lot right now. Haven't checked battery yet.

Any help would be great, thanks.
Reply With Quote
  #2 (permalink)  
Old 02 Jun 2010, 02:48 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: No Power at all.

Start with the battery, as you mentioned. If it's completely dead than absolutely nothing will work.

If it turns out to be your battery you now need to find out why. The whole charging system has to be checked out, plus the battery cables.
Reply With Quote
  #3 (permalink)  
Old 02 Jun 2010, 03:07 pm
Fresh Cruiser
 
Join Date: Apr 2010
Location: North Carolina
Posts: 3
Default Re: No Power at all.

Yep, the Battery.
I noticed I didn't have hold downs, but not sure if that would cause the short.
Getting some hold downs now, I will have the charging system checked.

Thanks.
Reply With Quote
  #4 (permalink)  
Old 02 Jun 2010, 03:09 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: No Power at all.

Quote:
Originally Posted by kgreene View Post
Yep, the Battery.
I noticed I didn't have hold downs, but not sure if that would cause the short.
That doesn't sound like it would cause a short but it does sound like someone was messing around with it that didn't know what he/she were doing.
Reply With Quote
  #5 (permalink)  
Old 07 Jun 2010, 11:00 am
Fresh Cruiser
 
Join Date: Apr 2010
Location: North Carolina
Posts: 3
Default Re: No Power at all.

discovered the problem.
My battery tray was cracked and the hold down is at the bottom.
Can't get to it without removing air filter assembly. So I got a new tray and
while lowering the battery back in I touched the dipstick assembly (metal)
with the back of the Pos cable and "ZAAAP".
The lack of effective hold down allowed the battery to slide on left turns.
As the weather heated up the constant touching of the hot metal surface
against the terminal connection cause the "insulation" to melt away exposing the copper. Eventually it slid against the dipstick assembly and shorted out the battery.
So with a new tray, Hold down and battery I believe I'm good.

Thanks
Attached Images
File Type: jpg battery.jpg (40.2 KB, 6 views)
Reply With Quote
  #6 (permalink)  
Old 07 Jun 2010, 03:24 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: No Power at all.

Glad you found the problem.
Reply With Quote
Reply

Tags
no power, power


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 PT Cruiser no power to power seat paradyne64 General PT Cruiser Discussions 5 29 Dec 2016 02:54 am
PT in-car power and rca/vga PTmodrod Interior Accessories Forum 4 03 Oct 2007 07:15 am
more power PTWHAT Exterior Accessories Forum 16 17 Jan 2004 11:40 am
PT Power..... studymunguy General PT Cruiser Discussions 20 02 Dec 2003 01:38 am
A/C Power Mel K Turbo Performance 9 05 Nov 2003 05:34 am


All times are GMT -5. The time now is 03:42 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors