PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Please Help P0171 Code Still

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 25 Jun 2010, 09:32 am
Fresh Cruiser
 
Join Date: Jun 2010
Location: Virginia Beach, VA
Posts: 16
Default Please Help P0171 Code Still

Hey guys,

I have been troubleshooting my 01 Limited Pt Cruiser now for weeks to resolve this code. The car has had a tune up with premium plugs, coil pack was changed, and both oxygen sensors have been changed. The weird part: After each part was changed, I would go for a drive and do fine for a while, then at between 12 and 16 miles that check engine light comes back on and it's the same code. Interestingly, it seems to come back on when I go up a steep hill. It seemed to run fine until that light comes on then it wants to hesitate. Any more thoughts? I've run out of ideas and money!! Could this be a stupid vacuum leak?

Steven

Last edited by cusunfireguy; 25 Jun 2010 at 09:34 am.
Reply With Quote
  #2 (permalink)  
Old 25 Jun 2010, 10:37 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Please Help P0171 Code Still

Vacuum leak or you didn't say anything about plug wires. When was the last time they were changed?
Reply With Quote
  #3 (permalink)  
Old 25 Jun 2010, 10:43 am
Fresh Cruiser
 
Join Date: Jun 2010
Location: Virginia Beach, VA
Posts: 16
Default Re: Please Help P0171 Code Still

Plugs and wires have been changed recently. The only thing I could think of would be a vacuum leak or map sensor maybe? Fan is working fine, ac blows cold all the time.

Steven

Work done:
New Starter
New coil pack
New plugs & wires
New O2 sensors (both)

Last edited by cusunfireguy; 25 Jun 2010 at 10:45 am.
Reply With Quote
  #4 (permalink)  
Old 25 Jun 2010, 11:54 am
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: Please Help P0171 Code Still

Were the O2 sensors OEM or aftermarket? PT's do not like aftermarket sensors.
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #5 (permalink)  
Old 25 Jun 2010, 11:55 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Please Help P0171 Code Still

My hunch - intake gasket.
Usually it is # 4 cylinder and usually the lower gasket and usually gives a P0304.
Does it idle smoothly?
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #6 (permalink)  
Old 25 Jun 2010, 12:05 pm
Fresh Cruiser
 
Join Date: Jun 2010
Location: Virginia Beach, VA
Posts: 16
Default Re: Please Help P0171 Code Still

I don't get code P0304, just P0171. Both sensors were OEM.

Steven
Reply With Quote
  #7 (permalink)  
Old 25 Jun 2010, 12:18 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Please Help P0171 Code Still

I know, but there are a lot of intake gasket leaks - could be you got a different code - is idle smooth?
Reply With Quote
  #8 (permalink)  
Old 25 Jun 2010, 03:26 pm
Fresh Cruiser
 
Join Date: Jun 2010
Location: Virginia Beach, VA
Posts: 16
Default Re: Please Help P0171 Code Still

It idle's smooth after it starts but not at first because it still doesn't want to start right. It does idle smooth running at full speed with a/c on. I checked the map sensor. With the car running, I unplugged it and the car shut off which I'm told that is what it is supposed to do. If it is a vacuum leak, where should I start? In regards to the intake gaskets, is that the intake manifold gaskets? I've had the intake manifold off a couple of times doing the plugs wires and coil pack and like a dummy, didn't even think of those gaskets! Argh! Thanks so much!

Steven

Last edited by cusunfireguy; 25 Jun 2010 at 04:28 pm.
Reply With Quote
  #9 (permalink)  
Old 26 Jun 2010, 11:33 am
Fresh Cruiser
 
Join Date: Jun 2010
Location: Virginia Beach, VA
Posts: 16
Default Re: Please Help P0171 Code Still

Well, I've got my fingers crossed! I took your advice and this morning I replaced the upper intake manifold gaskets, a dry rotted hose, and noticed a bolt missing on one module so I replaced that too. Drove it pretty hard up hills and down hills for 18.1 miles and the check engine light did not come back on! Jeez, I hope this did it! I am give out!

Steven
Reply With Quote
  #10 (permalink)  
Old 27 Jun 2010, 10:31 am
Fresh Cruiser
 
Join Date: Jun 2010
Location: Virginia Beach, VA
Posts: 16
Default Re: Please Help P0171 Code Still

I went to the mall this morning and the CEL came back on. When I got home and pulled the codes, it's still that pesky P0171 code. After all that I have done, other than the lower intake manifold gaskets, what else should I check?

So frustrated!!

Steven
Reply With Quote
Reply

Tags
p 0171


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Code ? 1lowufo Tech & Performance Forum 1 25 May 2010 06:25 pm
Code Help jennylyn General PT Cruiser Discussions 1 21 Sep 2009 01:57 pm
Code P0171 leftoverture Tech & Performance Forum 1 12 Jun 2009 06:17 pm
344 code jkinard73 Southeast PT Forum 2 08 Apr 2009 12:54 pm
P0171 Error code RIvey Tech & Performance Forum 3 02 May 2007 10:24 am


All times are GMT -5. The time now is 03:36 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors