PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Went to stop and engine raced..

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 03 Jul 2010, 01:04 pm
Fresh Cruiser
 
Join Date: Jul 2010
Posts: 3
Default Went to stop and engine raced..

Hi- I'm new to the forum and I don't know if this has been discussed. I have a 2002 PT Cruiser, 95,000 miles. Yesterday, I pulled into a parking space, one foot on the brake, and my engine started to race. I had to use 2 feet on the brake to stop the car and panicked and threw the car into park (which was probably the wrong thing to do). Now I know how the Toyota owners felt. Has anyone had this problem? What can I do about it? Now I'm frightened to drive and always have the other foot ready to slam on the brake. Thanks for you help!
Reply With Quote
  #2 (permalink)  
Old 03 Jul 2010, 02:19 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Went to stop and engine raced..

Welcome to the forum.

A couple owners have reported problems with the cruise control that wouldn't turn off. Were you using that right before you pulled in?

Are you sure part of your foot wasn't on the accelerator as you pushed on the brake pedal? That's happened a lot, more than you know, even did it once myself. It just has to be the tip of a shoe on the gas pedal to make it want to rush forward and accelerate.

No one has reported unattended acceleration problems like on the Toyota's.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 04 Jul 2010, 07:43 am
Fresh Cruiser
 
Join Date: Jul 2010
Posts: 3
Default Re: Went to stop and engine raced..

Hi, Thanks for your reply, but I don't have cruise control. And, my foot was definitely on the brake because I had to put my left foot on the brake to help stop the car, thinking that I needed to get my right foot on the gas to hit it to stop the car from racing-because it was stuck or something. Any other ideas?
Reply With Quote
  #4 (permalink)  
Old 04 Jul 2010, 08:25 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Went to stop and engine raced..

Well, then you better have someone take a look at the throttle linkage cable running across the top of the engine. It might be off track, frayed, loose, whatever. Make sure your floor mats are away from the gas pedal also. That seemed to be some of the problems Toyota was having. The floor mat was slipping up underneath the gas pedal and getting caught on the accelerator pedal.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #5 (permalink)  
Old 04 Jul 2010, 08:27 am
Fresh Cruiser
 
Join Date: Jul 2010
Posts: 3
Default Re: Went to stop and engine raced..

Thanks so much! I'm calling my mechanic tomorrow.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Y engine turns off when i stop BSTING General Turbo Discussions 2 09 Jun 2010 08:38 am
I raced an SRT-4 yesterday... BlueTurboGT General Turbo Discussions 5 26 Apr 2004 06:19 pm
Raced a Mustang Cobra skylight General Turbo Discussions 18 27 Aug 2003 09:43 pm
raced a Mitsu AWD-T COP TZER Turbo Performance 20 03 Jul 2003 02:08 am


All times are GMT -5. The time now is 07:40 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors