PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Help Please ! Electrical issues.

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 03 Jul 2010, 09:30 pm
Fresh Cruiser
 
Join Date: May 2010
Location: Houston,TX
Posts: 10
Default Help Please ! Electrical issues.

2004 Base PT Out of nowhere today no ac/heat , no window switches , and air bag light stays on. All worked fine earlier today. I have checked all fuses inside and under air filter box = good. Any advice,other than a trip to the stealership would be very appreciated.

Went outside right after posted to close it for the nite and everythng worked fine ? Closed it up to move it of course the same issue returned.
Has to be somethin simple that im missing. No check engine or key dance codes either.

Thanks ....

Last edited by thegooch2; 03 Jul 2010 at 10:27 pm.
Reply With Quote
  #2 (permalink)  
Old 03 Jul 2010, 10:26 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Help Please ! Electrical issues.

Welcome to the forum.

I know you said you checked the fuses but here's other owner's with multiple failures....

Pwr Windows/Blower Fan/Back-up lights/Rear Window Defogger/Air Bag Light

http://answers.edmunds.com/question-...-on-31297.aspx

http://repairpal.com/airbag-light-st...op-working-145
Reply With Quote
  #3 (permalink)  
Old 04 Jul 2010, 06:28 pm
Fresh Cruiser
 
Join Date: May 2010
Location: Houston,TX
Posts: 10
Default Re: Help Please ! Electrical issues. FIXED !

Thanks Crewzin,
After i tore it all apart,again, finally found the culprit.
The connector next to the steering tilt lever was not "snapped" all the way.
Reply With Quote
  #4 (permalink)  
Old 09 Jul 2010, 01:00 am
Fresh Cruiser
 
Join Date: Jul 2010
Posts: 1
Default Re: Help Please ! Electrical issues.

I just ran into the exact same problem on my '05 base PT. First none of the windows worked, then the a/c,heat fan stopped working and the airbag light came on. All fuses are good. I'll check the connections to see if that is the problem. It's nice to know there are other forums like this to share info. Thanks guys!
Reply With Quote
  #5 (permalink)  
Old 15 Aug 2010, 07:08 pm
Fresh Cruiser
 
Join Date: Aug 2010
Posts: 14
Default Re: Help Please ! Electrical issues. FIXED !

Quote:
Originally Posted by thegooch2 View Post
Thanks Crewzin,
After i tore it all apart,again, finally found the culprit.
The connector next to the steering tilt lever was not "snapped" all the way.
Which connector was that? I have the same problem and I am convinced that is were the problem is since I removed a remote starter from under there that the wires were getting wrapped around the steering column and shorting out the 30 amp fuse under the hood stalling the car.
Reply With Quote
  #6 (permalink)  
Old 16 Aug 2010, 06:53 am
Fresh Cruiser
 
Join Date: Aug 2010
Posts: 8
Default Re: Help Please ! Electrical issues.

I have an 03 turbo GT. My Radio, Compass and Sunroof all would go dead on me from time to time. After I checked all the fuses were good I was stumped! Also, this would mostly happen on cold days and after a while of driving...BAM...the radio would come on, sometimes scaring the shit outta me. Anyway, I was always checking the fuses with the car off, but just last week I played with the fuses...pushing on them...and Bam...everything came on. In short, your fuses may be good but the contact that the fuses have to the fuse box may not be. Hope it helps!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical Gremlins SantaGuy General PT Cruiser Discussions 10 24 Sep 2009 05:01 am
Electrical Issues? SillyEB Tech & Performance Forum 5 02 Jul 2009 10:52 am
speaker issues, wattage of stereo, door speaker replacement issues fabes89 General PT Cruiser Discussions 9 02 Jun 2009 10:59 am
Not sure where to put electrical questions? ravix Tech & Performance Forum 9 28 May 2009 09:25 pm
need electrical help thundercat2 Tech & Performance Forum 0 27 Sep 2008 08:02 am


All times are GMT -5. The time now is 05:05 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors