PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
ac problem

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 05 Jul 2010, 10:05 am
Fresh Cruiser
 
Join Date: Jul 2010
Posts: 2
Default ac problem

hello all I'm new here and I'm not the owner of the pt but my mother in law is and since im the most mechanically inclined i get to work on it!! which I've always had a place in my hart for the cruiser.

but any who her ac stopped working at the beginning of the summer after working just fine all last year and what i have found out is that the clutch is just not engaging, it has proper pressure and no leaks that i know of, any suggestions on how to check the compressor without getting a whole new one?
Reply With Quote
  #2 (permalink)  
Old 06 Jul 2010, 06:59 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: ac problem

Welcome to the forum.

You don't memtion what year the cruiser is but I'm taking it that's it between 2000-2005.

Did you check the A/C fuse in the PDC (Power Distribution Center) that's located in the engine compartment?

The high pressure switch itself located on the compressor has been giving problems for some owners. If that's not working properly, the compressor won't enguage.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 06 Jul 2010, 09:53 am
Fresh Cruiser
 
Join Date: Jul 2010
Posts: 2
Default Re: ac problem

yeah sorry its a 03 checked all the fuses and relays and all are intact and good, i even treed that trick with the paperclip on the sensor on the condenser, ill look into the high pressure switch thank you!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
any one else have this problem tommeyb General PT Cruiser Discussions 13 07 Apr 2008 12:21 am
is anyone else having this problem? blustar714 PT Cruiser Convertible Forum 0 05 May 2005 11:32 pm
Problem? deederz Tech & Performance Forum 3 04 May 2005 10:19 am
a/c problem deez92 Tech & Performance Forum 11 25 Jul 2004 04:25 am
RDS problem Brad Vandrasik Sound and Security Forum 3 02 Jan 2004 01:15 pm


All times are GMT -5. The time now is 08:34 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors