PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
A/C switch issue?

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 16 Jul 2010, 09:53 pm
Fresh Cruiser
 
Join Date: Jul 2010
Posts: 4
Default A/C switch issue?

I am having problems with my 03' PT's A/C system. I noticed that it does blow cooler air than ambient, but only barely, and only intermittently. I tried recharging, and upon testing discovered that the pressure would increase to the red, and then gradually drop back to low pressure. This cycle repeated over and over, and I also noticed that the low line was consistently very cold. I am assuming that means the compressor is working.

All of the repair shops I have taken it to tell me different things. either the compressor is bad or the whole system needs to be replaced. But I am hesitant to believe that since the low line is cold and that is due to COMPRESSION of the 134a. There are two switches, high side and low side, and common sense tells me something is switching on and off in order to change the pressures. seeing as how either switch is less than $30, I am looking to self diagnose if possible. I have only checked low side at this point. Can any real diagnosis be made that the low cycle pressure switch has gone bad? Any ideas or suggestions on my next step?

shag
Reply With Quote
  #2 (permalink)  
Old 18 Jul 2010, 09:32 am
Fresh Cruiser
 
Join Date: Jul 2010
Posts: 4
Default Re: A/C switch issue?

Update - I changed out the low side cycling switch. This had no effect on the problem. Anyone have any ideas?
Reply With Quote
  #3 (permalink)  
Old 19 Jul 2010, 11:27 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: A/C switch issue?

were you adding the refrigerant while A/C (and engine, of course) was running? I read that was how you did it....
If so, try a place that specializes in A/C and have system properly evacuated and refilled.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #4 (permalink)  
Old 19 Jul 2010, 12:31 pm
Fresh Cruiser
 
Join Date: Jul 2010
Posts: 4
Default Re: A/C switch issue?

I did run the engine with AC on high to test. I also let some of the refrigerant out to lower the pressure and then topped off before replacing the switch. Do you think full evacuation and recharging can solve the problem?
Reply With Quote
  #5 (permalink)  
Old 19 Jul 2010, 12:49 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: A/C switch issue?

Dunno. But a leak can let air in, and air won't do squat, but will prevent you getting more refrigerant in.
Reply With Quote
  #6 (permalink)  
Old 19 Jul 2010, 01:12 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: A/C switch issue?

Look around or check the local papers. Many shops will do free diagnostic A/C work hoping to get your business. Unless someone worked with A/C systems beforehand I always tell them to leave it to the professionals. Too much R134a can burn out the compressor too little and the system won't work. A proper set of guages is needed and the knowledge to use them is mandatory.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #7 (permalink)  
Old 19 Jul 2010, 01:43 pm
Young Cruiser
 
Join Date: Jun 2010
Posts: 97
Default Re: A/C switch issue?

i'm with crewzin

you need to take it a local shop, there is a chance that there is a leak and can be detected by either vacuming the system or when charging it back they will add a dye to the system that you can detect the leak piont with uv light

doubt that it is the compressor or any one of the switches. please dont vent 134a into the atmosphere it is bad for the ozone layer!!

btw, the cycle you're talking about is to prevent the low pressure pipes from freezing and it should not happen very frequently (more than 2 cycles per minute as that meens system is low on freon, for 06 pt the system should hold only 1lb of freon, it is measured by lb not psi as psi will fluctuate due to ambient temp. )
Reply With Quote
  #8 (permalink)  
Old 04 Aug 2010, 09:52 am
Fresh Cruiser
 
Join Date: Jul 2010
Posts: 4
Default Re: A/C switch issue?

Thanks for all the advice. I wanted to follow up. Since I added the R134 from the canister, the pressure has ended up stabilizing. I noticed an improvement over the course of a week and upon verifying that the pressure had stabilized, I topped off the R134 and now the girl is blowing ice cold.

It appears yall were right. The canister mentioned a leak sealer and I can only assume that was what was fixed. I also assume this is a temp fix and I will need to get it checked out and have it properly sealed. But for now we have A/C. And not a moment too soon, high yesterday was 105.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: 2008 OEM 'Combo Switch' (turn signal/headlight switch) Maxxam Classifieds: For Sale/Trade 3 08 Aug 2017 06:23 am
Headlamp switch (w/foglight) B/O issue Katharyn2000 General PT Cruiser Discussions 2 16 Jul 2009 08:16 pm
THE SWITCH. I need this part. AC Clutch Cycling SWITCH outfit Tech & Performance Forum 0 03 Jul 2009 02:59 pm
HID issue CYCLONE_06 Tech & Performance Forum 0 16 Apr 2009 08:00 pm
02 PT issue jparksp Tech & Performance Forum 4 18 Feb 2009 12:11 am


All times are GMT -5. The time now is 08:37 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors