PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
fuel pump, fuel filter or o2 sensor?

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 30 Jul 2010, 03:58 pm
Fresh Cruiser
 
Join Date: Jul 2010
Location: Cincinnati Ohio
Posts: 6
Default fuel pump, fuel filter or o2 sensor?

My 06 PT Cruiser bogs down every time I press on the gas, but idles just fine. Anyone else with this issue and do you have any suggestions? The check engine light also came on while this started going on.
Reply With Quote
  #2 (permalink)  
Old 30 Jul 2010, 05:17 pm
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: fuel pump, fuel filter or o2 sensor?

Welcome, do the "key dance" (info in the performance section) and let us know what code you get.
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #3 (permalink)  
Old 06 Aug 2010, 10:52 pm
Fresh Cruiser
 
Join Date: Jul 2010
Location: Cincinnati Ohio
Posts: 6
Default Re: fuel pump, fuel filter or o2 sensor?

no codes are displayed and I used an OBD II scanner also no codes. the scanner is good (I hooked it to the truck and it worked). so the i held in the trip button on the PT, turned the key to "on", and it looked like a test of some sort was going on. no code came up, but this is what was displayed in the odometer: sw ver 88, can 430, then lin ver 429. i was confused because some of these numbers matched my trip miles, so i don't think their codes. ??? i cleaned the maf, replaced air filter and added some fuel cleaner and it ran great. after 100 miles, cel light came on again and started putting. tonight i put on a new gas cap, thinking that maybe there just isn't a code for a faulty cap. any ideas?
Reply With Quote
  #4 (permalink)  
Old 07 Aug 2010, 07:45 am
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: fuel pump, fuel filter or o2 sensor?

Joey, you didn't do the key dance correctly. You have to turn the key from acc to start 3 times quickly to get the code,if any. If there are no codes, you will get a DONE. the info you stated are NOT codes. There is a "sticky" in the performance section of this website.
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #5 (permalink)  
Old 08 Aug 2010, 10:59 am
Fresh Cruiser
 
Join Date: Jul 2010
Location: Cincinnati Ohio
Posts: 6
Default Re: fuel pump, fuel filter or o2 sensor?

When doing the "key dance", do I start this process with the key all the way OFF, or start it with the key in the "accelerator" position?
Reply With Quote
  #6 (permalink)  
Old 08 Aug 2010, 11:06 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: fuel pump, fuel filter or o2 sensor?

All the way off. here's the instructions:

How to retrieve fault codes.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #7 (permalink)  
Old 08 Aug 2010, 12:02 pm
Dino's Avatar
Senior Cruiser
 
Join Date: Feb 2010
Location: NY
Posts: 1,839
Default Re: fuel pump, fuel filter or o2 sensor?

On the last turn the key just stays up, I think your going to need a camshaft position sensor
__________________



"the people should not fear their government, the government should fear the people"- Thomas Jefferson
Reply With Quote
  #8 (permalink)  
Old 09 Aug 2010, 10:05 pm
Fresh Cruiser
 
Join Date: Jul 2010
Location: Cincinnati Ohio
Posts: 6
Default Re: fuel pump, fuel filter or o2 sensor?

Dino, you're exactly right. I finally got the "key dance" thing down right, thanks HOOLIGAN. Anyway, it said PO340 which is the cam shift sensor (right on Dino!). I went to Advance Auto Parts and got the sensor for $37. It looks fairly easy to put in, we'll see what I say about that tomorrow. I'm just glad to finally have an answer! I'll let you know if this stops the CEL from coming on. Thanks everyone for all your help. It is greatly appreciated.
Reply With Quote
  #9 (permalink)  
Old 10 Aug 2010, 09:07 am
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: fuel pump, fuel filter or o2 sensor?

Joey, our PT's don't like aftermarket sensors. OEM are the best.
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #10 (permalink)  
Old 14 Aug 2010, 01:25 pm
Fresh Cruiser
 
Join Date: Jul 2010
Location: Cincinnati Ohio
Posts: 6
Default Re: fuel pump, fuel filter or o2 sensor?

Hi Hooligan. I am starting to figure that out. I thought I had it whooped when I realized the wiring harness thing was laying on a hot metal tube thing, so I moved it and secured it. I retorqued the sensor to 115 lbs, unhooked the battery for 1/2 hr and cleared codes. Then I test drove it out to the lake, and the CEL came on again once I hit 3000 rpm. I suppose it's time to return the faulty part and call Chrysler. Fun on a Saturday. Can I get OEM at the auto parts store? How much more is it?

thanks for all your input!!!

Joellen
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bad Fuel Pump/Filter or what? onedivinehammer General Turbo Discussions 11 09 Aug 2010 10:11 pm
fuel pump help twincruiserturbos General Turbo Discussions 10 29 Jun 2010 05:53 pm
2002 PT (in tank) Fuel Pump/ Fuel Sender cruiserich Classifieds: For Sale/Trade 0 27 Jan 2009 06:08 pm
Fuel pump nevinsrt Turbo Performance 4 15 Aug 2008 09:03 am
What Fuel Pump to Upgrade to? nitrouspt Turbo Performance 2 16 Jun 2006 01:22 pm


All times are GMT -5. The time now is 12:09 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors