PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
2005 PT A/C Question

 
Like Tree2Likes
  • 1 Post By CREWZIN
  • 1 Post By Capriman86

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 07 Aug 2010, 04:46 pm
Fresh Cruiser
 
Join Date: Apr 2010
Posts: 2
Default 2005 PT A/C Question

Hello - A question regarding my A/C. It seems to only really get "cool", not cold when I get the car up to speed on the freeway or around town. But when I idle, it blows warm air. What should I be looking for? I recharged it and lasted about a month, and in fact, just after the recharge I noticed that it "spewed" freon at a stop light (at low idle).

Thoughts?
Reply With Quote
  #2 (permalink)  
Old 07 Aug 2010, 05:11 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: 2005 PT A/C Question

The main cause of the A/C blowing warm at idle is the 2 speed fan. You sound like you also may have a slow leak. When it was filled up last time did you put the dye in so you could see if there was a leak?

Once you get up to speed (above 35mph) the electric fan cuts off becuase there's enough air coming in the front of the car to keep everything cool. Once you slow down, the radiator and A/C depend on the fan. Mostly high speed to keep everything cool.
Reply With Quote
  #3 (permalink)  
Old 07 Aug 2010, 05:52 pm
Fresh Cruiser
 
Join Date: Apr 2010
Posts: 2
Default Re: 2005 PT A/C Question

No, I didn't have the system dye tested, but know that I need to. Regarding the 2-speed fan, how would I know if it's working properly? I hear it go on at idle, unless it's another type of fan.

Thanks for the help!
Reply With Quote
  #4 (permalink)  
Old 07 Aug 2010, 06:14 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: 2005 PT A/C Question

No, that's the only fan there is. If you can here it at idle (that's the high speed) and your A/C is still blowing cool (not cold) and it "spewed" the R134a that's a sign of your compressor overheating.

I'm not sure. A slow leak of the R134a will cause you to lose the cold air so that's one problem. The dye will help you find that. Why your compressor is overheating with the fan blowing on high is another matter. Usually the coolant itself starts to overheat (mostly at idle) if something like the fan is not turning or the radiator is clogged.

Hopefully someone else with a better understanding of the A/C system will come along with more help. If not, it's time you visited an A/C shop that can pinpoint your problem.

One more thing. You said you can hear the fan going on at idle. If the A/C is ON, the fan should be ON also. The fan should never stop when the A/C in ON.
t1sby likes this.
Reply With Quote
  #5 (permalink)  
Old 07 Aug 2010, 09:56 pm
Capriman86's Avatar
Regular Cruiser
 
Join Date: Jul 2010
Location: RI
Posts: 147
Default Re: 2005 PT A/C Question

As CREWZIN said, the fan should be on ALL the time with the A/C on.


Have your car sitting and let it idle with the A/C off. Listen for the fan, if it is on, wait for the car temp to come down and shut off while still idling. Once the fan shuts off turn the A/C on and the fan should turn right back on, if it does turn on, shut the A/C back off and the fan should turn back off.


If that all happens ok, its not the fan.....but this was my issue, the fan never turned on with the A/C.


I also saw in another post there is a "High Speed" fan relay under the hood, you could check that as well but it's probably the fan.

I just bought mine off eBay for $80 delivered. Working like a champ now.
t1sby likes this.
__________________
2003 PT Cruiser SOLD
Reply With Quote
Reply

Tags
a/c questions


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Key with Built-in fob for 2005 PT? DustyPaynts General PT Cruiser Discussions 3 16 Aug 2011 11:03 am
question about services 2005 turbo ragtop gatorgal1 Tech & Performance Forum 1 05 Jan 2010 02:28 pm
2005 Power Outlet Question Psychobabbler Sound and Security Forum 2 06 Aug 2009 06:58 pm
Luggage Rack question and trailer hitch question Patrick_Dickey General PT Cruiser Discussions 5 26 Apr 2009 09:19 pm
2005 pt con skip white General PT Cruiser Discussions 6 31 May 2004 09:05 pm


All times are GMT -5. The time now is 05:04 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors