PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Turn Signals Won't Work - 2003 PT Touring

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 19 Aug 2010, 12:25 pm
hootiemomma's Avatar
Fresh Cruiser
 
Join Date: Aug 2010
Location: Overland Park, KS
Posts: 1
Red face Turn Signals Won't Work - 2003 PT Touring

Hi everyone! I love this site! I also LOVE my PT Cruiser. It's been an awesome car. I have had a lot of maintenance items to deal with this year and my latest situation is one I cannot afford to take to the shop again. Here is my situation:

2003 PT Cruiser Ė Touring Edition, 94,000 miles +/-

Sometime in February 2009, my turn signals stopped working. When I moved the turn signal to indicate right or left turn, nothing happened at all.
I took the car to a shop I trust in Overland Park, KS. I was informed that I needed a new multifunction switch. They installed it and when I picked the car up, the mechanic had drawn me a picture and explained that if I turn the Hazards on, the turn signals will not work. It will cause it to malfunction again.

August 2010, I was cleaning my car and I barely depressed on the Hazards. I knew what I had done the moment I did it. So of course, the turn signals stopped working and the Hazards do not work either.

I took the car back to the same shop. They did not know which mechanic had worked on my car and they did not have the picture he drew me. [It had been a year and a half so Iím not mad or anything about this, itís just a bummer.] They said I needed another multifunction switch and a flasher. They quoted me almost $400 to do this.

I went to the Chrysler dealer and purchased a new multifunction switch. I got on-line and figured out how to do it myself. I took off the multifunction switch and installed the new one. No change.
Then I went down to OíReillyís and bought a new flasher, 12 Volt Five prong thing. No change. Returned that flasher and got my $20 back.

I checked all the fuses under the hood and under the dash. I checked all the bulbs on the car to make sure a bulb wasnít burnt out.
Went home, uninstalled the new Multifunction switch and took that back to the dealer and was refunded 100% of my money!

So I have eliminated several things but I am still at a loss for what it could be. Any suggestions?

I just picked up the Chilton's Manual from the library. The wiring diagrams look a little complicated. Am I in over my head or is this something a beginning DIYer can do herself?
Reply With Quote
  #2 (permalink)  
Old 19 Aug 2010, 02:00 pm
Fanatic Cruiser
 
Join Date: Mar 2010
Location: Billings, MT
Posts: 745
Default Re: Turn Signals Won't Work - 2003 PT Touring

First off, you shouldn't have returned the parts just yet. You'll need them so you have a known working m/f switch and flasher, and continue your diagnosis from there. Only after finding the problem should you return any parts you didn't need. You might still have a problem with one or both of those, on top of something else, such as wiring.

Did you try the hazard relay? It sounds like the shop did something with the hazards to get the turn signals to work and threw it all together. If they told me I couldn't use my hazards, I would have refused to pay and told them to fix the car properly! I wouldn't go back to that shop.

Trace the wiring for both the hazards and the turn signals all the way from the main harness through the fuse block and up to the respective switches to see if anything was cut/spliced/altered. They may have hotwired your signals through the hazards and by turning the hazards on, you shorted the two systems together. Just a possibility.
__________________
-Chris
2010 PT Cruiser Classic, Deep Water Blue
Reply With Quote
  #3 (permalink)  
Old 19 Aug 2010, 03:29 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Turn Signals Won't Work - 2003 PT Touring

^^^^ Agree.
There is no reason to molest the 4-way flasher - the mechanic screwed up - go back there .
I don't know what they did - I replaced a multifunction switch and it's easy - why they loused up the 4-ways is beyomd me.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
PT turn signals (or lack of) dgranros Tech & Performance Forum 6 05 Jan 2015 01:54 pm
turn signals and hazzards asguard Tech & Performance Forum 2 08 Feb 2010 02:33 pm
turn signals AlexJB Exterior Accessories Forum 6 12 May 2008 08:12 pm
Help with Stealth turn signals toplessPT Exterior Accessories Forum 4 16 Mar 2005 10:43 am
Turn Signals Not Working Indynick General PT Cruiser Discussions 9 15 Sep 2004 02:25 pm


All times are GMT -5. The time now is 10:15 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors