PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
ODD RADIATOR FAN PROBLEM

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 24 Aug 2010, 12:54 pm
Fresh Cruiser
 
Join Date: Aug 2010
Posts: 3
Default ODD RADIATOR FAN PROBLEM

Howdy all, Ive got a radiator problem that I cant seem to find a solution to by searching through the forums, here it goes,

I recently found my fan was only running when the ac was on so I wired it up and checked it, it was burnt up on either high or low,I dont know which is which?, I replaced the fan motor and now the fan runs all the time, what would cause it to run all the time? Im guessing something has went bad letting it run continuously and thats what burnt the brushes up on the first one, any ideas as to where I should begin? Ive swapped the relays around and no luck, help me out fellas
Reply With Quote
  #2 (permalink)  
Old 24 Aug 2010, 01:50 pm
Fanatic Cruiser
 
Join Date: Mar 2010
Location: Billings, MT
Posts: 745
Default Re: ODD RADIATOR FAN PROBLEM

Your low speed was burned out. Only the high speed fan will come on with the a/c, so the high was working fine.

You may have a short somewhere in the fan wiring, or there may be an internal fault in the PCM supplying constant power to the fan. The PCM is what controls the fan speed through the two relays.
__________________
-Chris
2010 PT Cruiser Classic, Deep Water Blue
Reply With Quote
  #3 (permalink)  
Old 24 Aug 2010, 11:13 pm
mdfrodolives's Avatar
Senior Cruiser
 
Join Date: May 2010
Posts: 1,313
Default Re: ODD RADIATOR FAN PROBLEM

Maybe your low-speed fan relay is faulty, and stays open all the time.

Tim
Reply With Quote
  #4 (permalink)  
Old 25 Aug 2010, 07:23 am
Fresh Cruiser
 
Join Date: Aug 2010
Posts: 3
Default Re: ODD RADIATOR FAN PROBLEM

It sounds like its running on high anytime the key is on, its pretty loud and theres no change in it when I turn the AC on, so should I just change both relays and if its not that assume its the PCM? is there a sensor anywhere that tells the fan to come on? I unplugged the temp sending unit and the gauge quit working and high temp light came on, Oh and BTW its throwing a code PO481 Cooling fan relay 2 control circuit, anybody seen that one before? thanks
Reply With Quote
  #5 (permalink)  
Old 25 Aug 2010, 07:40 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: ODD RADIATOR FAN PROBLEM

From PT Do-It-Yourself.net:

Radiator fan operation is controlled by the Powertrain Control Module (PCM) with inputs from the temperature of the coolant, which is sensed by the coolant temperature sensor, and vehicle speed, which is measured by the vehicle speed sensor. The PCM turns on the fan through either the high or low speed fan relay.

P0481 - High Speed Fan Relay Control Circuit - An open or shorted condition detected in the high speed radiator fan relay control circuit.

Possible causes on the 2005 model year and earlier include:

High Speed Radiator Fan Relay Operation
Fused Ignition Switch Output Circuit
High Speed Radiator Fan Relay Resistance
High Speed Rad Fan Relay Control Circuit Open
High Speed Rad Fan Relay Control Circuit Short To Ground
PCM

Possible causes on the 2006 model year and later include:

Fused (B+) Circuits
Ground Circuit
High Speed Rad Fan Control Circuit Shorted To Battery Voltage
High Speed Rad Fan Control Circuit Open
High Speed Rad Fan Control Circuit Shorted To Ground
Radiator Cooling Fan Module
Totally Integrated Power Module

This is not a DIY repair. Unless you have a DRB III scan tool, multi-meter diagnostic manual and the experience to use all three, see your dealer.
Reply With Quote
  #6 (permalink)  
Old 25 Aug 2010, 07:50 am
Fresh Cruiser
 
Join Date: Aug 2010
Posts: 3
Default Re: ODD RADIATOR FAN PROBLEM

yup thats way over my head, thanks man that answered alot of my questions
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
The radiator fan fix 03PTMOM Tech & Performance Forum 26 25 Sep 2014 01:02 pm
2001 radiator fan problem koor Tech & Performance Forum 14 23 Aug 2010 06:47 pm
Radiator fan problem moparman3 Turbo Performance 0 29 Oct 2009 08:23 am
radiator sandylolee General Turbo Discussions 0 04 Jun 2009 12:59 pm
Radiator 4b316 Tech & Performance Forum 3 26 Dec 2008 05:56 pm


All times are GMT -5. The time now is 11:13 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors