PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
help, A/C problem :(

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 07 Sep 2010, 05:58 am
Fresh Cruiser
 
Join Date: Sep 2010
Posts: 8
Unhappy help, A/C problem :(

Hi,its me again..i have a 2006 touring..the A/C is working but not cooling..when i turn on fans,they are ok,when i press the a/c cooling switch it lights,but there is no cold air..i checked the forum but couldnt fix my problem..any ideas_?
thx..
Reply With Quote
  #2 (permalink)  
Old 07 Sep 2010, 06:25 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: help, A/C problem :(

Did you check your freon (R134a) level and pressure?
Reply With Quote
  #3 (permalink)  
Old 07 Sep 2010, 06:35 am
Young Cruiser
 
Join Date: Jun 2010
Posts: 97
Default Re: help, A/C problem :(

either you take it to a A/C shop and they do an A/C test and tell you what is wrong with the A/C system, usually cost about 80$, might go on sale for 40$ for some shops!

or you have to do some tests, you need to check to see if the compressor is actually working when you turn the A/C on (with the cooling switch light on ). you need to purchase a UV detector can of 134a with a pressure guage, first check the pressure to see if there is any pressure in the system, if not, there is a big leak and you need to find it and fix it;this causes the compressor to stop (to protect it ), if the pressure is low add the can of UV detector 134A and turn on the A/C (add it to low pressure service port). the air should comes out cold and if you use a blue light or UV detector light you should be able to find the leak and then fix it !
once you have done this come back as there is more steps to make sure that your system is working properly ! (as you need to check the low pressure valve and high speed fan too )
Reply With Quote
  #4 (permalink)  
Old 13 Sep 2010, 07:10 pm
Fresh Cruiser
 
Join Date: Sep 2010
Posts: 8
Default Re: help, A/C problem :(

thx for the replies..i took my car to repair and they told me that the compressor is not working
Reply With Quote
  #5 (permalink)  
Old 13 Sep 2010, 07:16 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: help, A/C problem :(

Quote:
Originally Posted by drsarman View Post
thx for the replies..i took my car to repair and they told me that the compressor is not working

If they did a free check (lots of places do) your not out anything so look around for a second opinion. Sorry, but I wouldn't put it past any auto place to tell you the most costly part of the system needs replacing.

If you can't do any of the tests yourself that Bugatti suggested, your kind of tied to a shop but there's nothing to say you can't get different opinions.
Reply With Quote
  #6 (permalink)  
Old 18 Sep 2010, 09:15 am
Young Cruiser
 
Join Date: Jun 2010
Posts: 97
Default Re: help, A/C problem :(

if you are looking to replace it yourself i can try to help you ! it needs patients and about 8hrs of your time if it is your first time !

i got to the piont when my A/C died on me that i had two choices, live with it and enjoy the heat of arizona or pay the dealer 1800$ to replace the system which i dont trust anyone else to work on my pt !!

i ended up paying 900$ in parts and related services and about 8hrs of my time ( first time working on a car ), i know some people would say that's too much (900$) but for me it was worth it as many shops offer to replace compressor for 800$ (that's just the compressor, no warrenty or only 30 days) while i ended up with 2 years warrenty on the compressor and i completly flushed the system add to that i gained some experience
Reply With Quote
  #7 (permalink)  
Old 21 Sep 2010, 04:04 am
Fresh Cruiser
 
Join Date: Sep 2010
Posts: 1
Lightbulb Re: help, A/C problem :(

check volts at the compressor clutch plug or put 2 jumper wire on the plug one with 12 v. pos the other with 12 v. neg
if the clutch is good you will hear the plate "snap " shut .also the motor doesn't need to be running when doing this test...
__________________
Keeping your A/C at its top working state is just a matter of replacing damaged parts or upgrading to more reliable parts from trusted manufacturers.
Reply With Quote
Reply

Tags
a/c questions, cooling


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
So, is my FAN the problem!? kcpope General PT Cruiser Discussions 38 11 Aug 2012 07:38 pm
No one knows what the problem is?? will21 Tech & Performance Forum 6 30 Oct 2009 07:41 pm
anyone ever had this problem Vengence General PT Cruiser Discussions 1 12 Aug 2009 08:58 pm
Help with WGA Problem? Nam9482 Turbo Performance 5 09 Oct 2005 12:57 am
still having problem mo-cash General Turbo Discussions 6 10 Feb 2004 09:16 pm


All times are GMT -5. The time now is 11:16 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors