PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
2006 PT NON TURBO

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 11 Sep 2010, 07:36 pm
Fresh Cruiser
 
Join Date: Sep 2010
Posts: 1
Default 2006 PT NON TURBO

I AM READY TO BLOW MY PT UP. A COUPLE OF WEEKS AGO. MY CHECK ENGINE LIGHT CAME ON. CHECKED THE CODE IT SAID IT NEEDED CAM SENSOR. REPLACED IT AND ENGINE LIGHT IS STILL ON . I DID RESEST THE BATTERY AND USED A CODE READER TO RESET ENGINE LIGHT. IT COMES RIGHT BACK ON. THE ENGINE IS IN LIMP MODE. I HAVE HAD TWO SHOPS LOOK AT IT THEY SAY IT IS THE ECU. SO THEY OREDERED ME ONE AND THEN THEY LET ME KNOW THAT IT IS COVERED BY WARRENTY SO I TAKE IT TO THE DEALER HE LOOKS AT IT AND TELLS ME . I WILL HAVE TO BRING IT BACK ON MONDAY HE THINKS THE ECU NEEDS TO BE FLASHED. HE ALSO SAID THE AFTER MARKET CAM SENSOR MAY BE MESSING THE ECU UP. SO I PUT THE OLD ONE BACK ON. HE ASKED ME TO. THE ENGINE LIGHT WHENT OFF AND THEN CAME ON WHILE DRIVING A FEW MIN LATER I DID DISCONECT THE BATT. AND THE CODE SHOWS NOTHING NOW. NO CODE ERROR ENGINE LIGHT IS ON AND THE CAR IS IN LIMP AGAIN. I AM TAKING BACK TO DEALER ON MONDAY BUT I AM SCARED THEY ARE GOING TO SAY IT CAM THEN SOMETHING ELSE. SHOULD I JUST BUY THE NEW ECU AND GO THAT ROUTE OR LET THE DEALER PIECE IT TOGEATHER. I AM AT A LOSS.
Reply With Quote
  #2 (permalink)  
Old 12 Sep 2010, 01:13 am
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: 2006 PT NON TURBO

I did the same thing with a cam sensor it lasted a week and then puked i am going to replace it with a mopar one if there is such a animal anyway you could replace the sensor and see what happens but if that fails you have to do something
Reply With Quote
  #3 (permalink)  
Old 12 Sep 2010, 04:21 am
Freezinghot's Avatar
Fanatic Cruiser
 
Join Date: Jun 2010
Location: Fort Worth, Tx
Posts: 547
Default Re: 2006 PT NON TURBO

I replaced a cam sensor not too long ago, and it couldnt have gone smoother. Simply walked into pep boys (yuck , i know) and asked for a replacement one,but it worked fine. If its a sensor or something like that, i would always try to get one from the dealer first. Who knows that kind of parts those japanese companies are making for it. Not sure if you know this, but if you turn the power on in your car without starting it, then in 5 seconds turn the key rapidly counter-clockwise all the way, and then back ,3 times, youll get the error code on your odometer just like if you had a code reader.
But your problem sounds classic of a bad cam sensor
__________________
04 graphite(vroom!) N/A Limited 110,000 miles -original owner. Custom short ram intake ( CGS motor-sport pipe, specter open-end air filter, specter breathing hose),OEM spoiler, Pioneer receiver ,10" bazooka sub,Blue LED interior lighting, Bosch +4 plugs and Accel super stock 8mm universal plug wires.

Last edited by Freezinghot; 12 Sep 2010 at 04:27 am.
Reply With Quote
  #4 (permalink)  
Old 12 Sep 2010, 08:04 am
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: 2006 PT NON TURBO

firehunter2000,Welcome to the Forum.

Please do not use all caps as that signifies shouting!!! Thanks.
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #5 (permalink)  
Old 17 Sep 2010, 11:58 pm
Young Cruiser
 
Join Date: Feb 2010
Location: Buffalo,NY
Posts: 56
Default Re: 2006 PT NON TURBO

Just had cam sensor and wiring replaced today. So far so good. The wires were touching some sort of metal and ended up shorting out the wiring and the cam sensor. Anywho autzone told me it would cost around $300 to fix but I took it to a local garage and got everything done in 1 day for $145, they also eliminated the possibility of a future short. I think thats fair even though the sensor is only $35, But I wouldn't have known how to check all the wires. I sometimes wonder where the guys from autozone come up with their prices.Autozone guy also told me that I would have to take apart the engine to get to the cam sensor and I would be better off not trying to fix it myself. I found out that's also incorrect.
__________________
2005 Pt Cruiser Convertible Touring Edition
Jvc KD-R300 Dash Unit
Kicker K35 3.5in Dash Speakers
Pioneer TS-A1673R 6.5in Door
Pioneer TS-A6963R 6x9 Rears
Infinity Kappa 12in Sub
Infinity REF5350A 5 Channel Amp
Reply With Quote
  #6 (permalink)  
Old 18 Sep 2010, 02:43 pm
Freezinghot's Avatar
Fanatic Cruiser
 
Join Date: Jun 2010
Location: Fort Worth, Tx
Posts: 547
Default Re: 2006 PT NON TURBO

I bought my camshaft sensor at pep boys for like 30$ and did it myself in 5 minutes
__________________
04 graphite(vroom!) N/A Limited 110,000 miles -original owner. Custom short ram intake ( CGS motor-sport pipe, specter open-end air filter, specter breathing hose),OEM spoiler, Pioneer receiver ,10" bazooka sub,Blue LED interior lighting, Bosch +4 plugs and Accel super stock 8mm universal plug wires.
Reply With Quote
  #7 (permalink)  
Old 20 Sep 2010, 02:47 am
Fanatic Cruiser
 
Join Date: Mar 2010
Location: Billings, MT
Posts: 745
Default Re: 2006 PT NON TURBO

First off, do not use aftermarket electrical parts such as sensors because you'll run into the exact problem your having and they won't work.

Buy an OEM sensor. If that doesn't work, have the PCM checked. If it's bad, have the dealer replace it under warranty.
__________________
-Chris
2010 PT Cruiser Classic, Deep Water Blue
Reply With Quote
  #8 (permalink)  
Old 20 Sep 2010, 08:55 am
Dino's Avatar
Senior Cruiser
 
Join Date: Feb 2010
Location: NY
Posts: 1,839
Default Re: 2006 PT NON TURBO

The OEM sensor cost me 34 bucks, their is no reason not to buy OEM with a part like this.
__________________



"the people should not fear their government, the government should fear the people"- Thomas Jefferson
Reply With Quote
  #9 (permalink)  
Old 29 Sep 2010, 03:42 am
chris15's Avatar
Senior Cruiser
 
Join Date: Jan 2008
Location: Tampa, Florida
Posts: 1,035
Default Re: 2006 PT NON TURBO

Agreed. Bought a MAP sensor from Autozone-- two days later, the glue melted and the sensor fell into two pieces. Tried to return it, guy at the counter gave me the 'run-around', so I walked back, grabbed a $3 tube of super glue and-- viola! Problem solved.

Moral to the story: OEM sensors only.
__________________
2003 GT (6262, the works)
2001 PT MTX-Swapped/Turbo

Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 PT Cruiser GT Turbo KC2IFR General Turbo Discussions 26 02 Jun 2010 12:11 pm
2006 or 2005 Pt Gt turbo Which one??? dehcho General PT Cruiser Discussions 5 24 Dec 2009 09:16 am
FS - K&N Air Filter For 2006+ PT Turbo jmr Classifieds: For Sale/Trade 2 15 Jan 2008 10:51 pm
245/40/18 on 2006 Turbo? Tom and Marj Green Turbo Wheels/Suspension/Handling 2 18 Feb 2006 11:55 pm
2006 Turbo cruiserboy General PT Cruiser Discussions 1 04 Oct 2005 09:17 am


All times are GMT -5. The time now is 07:04 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors