PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
car wont start. car alarm light and airbag light on

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 05 Nov 2010, 11:36 am
Fresh Cruiser
 
Join Date: Nov 2010
Posts: 4
Default car wont start. car alarm light and airbag light on

hello new to this forum. I have a 2003 pt cruiser. I've read up on a lot of posts here which has really been helpful so I think i have an idea what the problem is. first off. I thought my ecu was fried because my car wouldn't turn. The lights were working, etc. but it wouldn't turn. I got a brand new battery and a used ecu. It started up and i screamed in joy. That was short lived.

I noticed that my car alarm light and the airbag light is on perminantly now when the car ran for a brief period. I'm thinking the car alarm system is causing the car to shut off. Isn't the car alarm connected to the computer system? Do i just remove the alarm system? if that solves the issue, is there a way to disconnect it correctly? If it's not the problem I have a killer electrical problem eitherway. somewhere or another. definately electrical.

at first after changing the ecu i then thought it might be a bad crankshaft and camshaft sensor. But not so sure now.

any help would be really appreciated.
Reply With Quote
  #2 (permalink)  
Old 05 Nov 2010, 12:23 pm
Kawizx9r's Avatar
Senior Cruiser
 
Join Date: Aug 2010
Location: Salinas, CA
Posts: 1,575
Default Re: car wont start. car alarm light and airbag light on

I'm on a whole different page as to why it happened to my car, but mine won't turn on either. Thought I'd chime in though to see if your issue is the same as mine in the end.

Long story short, my tuner failed to update calibration files/etc when plugged into the OBD port (to flash/tune my PCM). Well after it failed, the SKIM kicked in. It's a security feature which prevents the car from being started. If I put the key in and put it to the ON position I can still work the lights/stereo/etc. But if I try to crank it, nothing at all happens. On the RPM gauge, I've got a red LED that stays lit notifying me that the SKIM is engaged.

Not sure if that's what you've got going on that prevents your car from turning on. If I'm correct (after lots of reading), the SKIM was optional...unfortunately for me since my 03 GT has every option available, it has it too.
__________________
Quote:
Originally Posted by Chromenut View Post
Kawi is a friggin genius!
Reply With Quote
  #3 (permalink)  
Old 05 Nov 2010, 12:49 pm
Fresh Cruiser
 
Join Date: Nov 2010
Posts: 4
Default Re: car wont start. car alarm light and airbag light on

my lights turn on in the dash just fine as well when i turn the ignition however it wont make a peep just like your situation. the way it happened time line wise was like this.

about 3 weeks ago...

1. car wouldn't turn, guages flickering. assumed it was a low battery.
Attempted Solution 1: jumped car, charged it by riding, worked for another two days

2. car would turn again one morning.
Attempted Solution 2: jumped car. got it to start after a couple tries. took cable wires off car, immediately died out. got used battery, guy comes over to check it out, says the starters fine, battery cables fine, battery fine and is sure theres an electrical problem, common in cruisers. he blows me off doesn't come fix it.

3. Other friend who is a mechanic comes along, he can figure it out. he thinks the ecu is fried. His diagnostic machine pick up code P0340 Attempted Solution 3: We get a used ecu install it, car wont start, so he jumps it and it starts up but then takes cable wires off and it dies out, he's sure it a bad battery, which takes me back to step 2 again. I assumed the other guy sold me a bad battery. Now I'm thinking I was wrong.

There's something else wrong with it. I read your problem and someone said that it was thecrankshaft and(or) the camshaft sensors, Which both point to an electrical problem which is good, cause I'm convinced it's an electrical problem anyway.

What do you think your problem is?
Reply With Quote
  #4 (permalink)  
Old 05 Nov 2010, 01:02 pm
Kawizx9r's Avatar
Senior Cruiser
 
Join Date: Aug 2010
Location: Salinas, CA
Posts: 1,575
Default Re: car wont start. car alarm light and airbag light on

Sorry I meant to say the red LED on the LEFT gauge is on (not the RPM gauge).

I already know what my problem is, it's the SKIM.

But yeah it seems like you've got an electrical problem of the sort. Hopefully someone else can chime in about it for ya.

As for my car, my PCM and Tuner are being sent out to be reflashed. If that doesn't solve the issue, I might have to get the car towed to the dealership and get the security thing taken care of which could end up costing me a couple of hundred bucks (hope that's not the case).
__________________
Quote:
Originally Posted by Chromenut View Post
Kawi is a friggin genius!
Reply With Quote
  #5 (permalink)  
Old 05 Nov 2010, 01:22 pm
Fresh Cruiser
 
Join Date: Nov 2010
Posts: 4
Default Re: car wont start. car alarm light and airbag light on

I just figured the problem out over the phone with the dealership. I have a grey key which has a computer chip in it and and recognized by the computer. I also have a black key which is only good for locking and unlocking the doors, it's not good for turning the ignition.

So I was using my black key which had no chip in it and the car didn't recognize the key, thought it was being broken into and automatically started shutting down everthing. The repare lady said that the car needs to be towed and they have to recalibrate the grey key with the chip in it to the computer to prevent the security feature from kicking in. It cost $45 dollars to do. Just gotta tow it there.

Hopefully my Geico insurance has a tow left in it. It's not official, but I'm almost positive this is the problem, I'll write back to let you know officially soon.
Reply With Quote
  #6 (permalink)  
Old 05 Nov 2010, 01:27 pm
Kawizx9r's Avatar
Senior Cruiser
 
Join Date: Aug 2010
Location: Salinas, CA
Posts: 1,575
Default Re: car wont start. car alarm light and airbag light on

Quote:
Originally Posted by trigimon View Post
I just figured the problem out over the phone with the dealership. I have a grey key which has a computer chip in it and and recognized by the computer. I also have a black key which is only good for locking and unlocking the doors, it's not good for turning the ignition.

So I was using my black key which had no chip in it and the car didn't recognize the key, thought it was being broken into and automatically started shutting down everthing. The repare lady said that the car needs to be towed and they have to recalibrate the grey key with the chip in it to the computer to prevent the security feature from kicking in. It cost $45 dollars to do. Just gotta tow it there.

Hopefully my Geico insurance has a tow left in it. It's not official, but I'm almost positive this is the problem, I'll write back to let you know officially soon.
Yep. Grey key here too, that's the security thing I was talking about!

Since my tuner was probably faulty, it's why it's being sent to the manufacturer. But once I get it back, if it doesn't work then I'll have to get mine towed out there and taken care of.

I was going to call them as well, just to see how much it'd cost. On another forum, they too were charged just $45 bucks. Hopefully the towing is the only expense I have to worry about...the $45 bucks is a simple fill-up at the gas station so it won't hurt the wallet.
__________________
Quote:
Originally Posted by Chromenut View Post
Kawi is a friggin genius!
Reply With Quote
  #7 (permalink)  
Old 05 Nov 2010, 01:50 pm
Kawizx9r's Avatar
Senior Cruiser
 
Join Date: Aug 2010
Location: Salinas, CA
Posts: 1,575
Default Re: car wont start. car alarm light and airbag light on

Got quoted for $60 bucks, not bad if it'll take care of the issue.
__________________
Quote:
Originally Posted by Chromenut View Post
Kawi is a friggin genius!
Reply With Quote
  #8 (permalink)  
Old 05 Nov 2010, 03:42 pm
Banned
 
Join Date: Sep 2009
Location: south of Tampa, Florida
Posts: 3,037
Default Re: car wont start. car alarm light and airbag light on

trigimom, have you tried putting your original PCM back in. It's already programed to your "good" grey chipped keys. Normally, if the wrong (un-chipped key) is used, you can then simply insert the correct chipped key and it will bring things back to "situation normal" status. That's if using the wrong key is all that was wrong.

Just another helpful hint; never unhook the battery cables on a computer controled car. The chances are very good you will damage your PCM by doing that. They are very sensitive to electrical irregularities. I personally know of three that have been damaged by unhooking a battery cable with the engine running and every manual that I've seen warns against doing it. In some cases, these modern cars don't always take well to old school tactics. This is one of them.

Jerry
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Airbag light ON sullyfla Tech & Performance Forum 10 18 Feb 2017 10:59 am
Airbag Light ptguy69 General PT Cruiser Discussions 1 17 Aug 2010 10:30 pm
Red security alarm light but no alarm! TrishsPT Sound and Security Forum 9 02 Aug 2010 02:38 am
Airbag light plus other problems Bill3256 Tech & Performance Forum 2 18 Jul 2010 07:16 pm
Car Sometimes won't start (oil pressure light & Engine Light) gerardio Tech & Performance Forum 6 18 Jul 2008 08:22 am


All times are GMT -5. The time now is 03:30 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors